Problem mit udev Regeln

Diskutiere Problem mit udev Regeln im Installation & Basiskonfiguration Forum im Bereich Linux/Unix Allgemein; Hallo zusammen, ich bin so langsam am verzweifeln mit meinen udev Regeln. Ich nutze ein LFS und habe meine Regeln aus dem LFS-Buch übernommen...

  1. Olti

    Olti Mitglied

    Dabei seit:
    06.03.2006
    Beiträge:
    41
    Zustimmungen:
    0
    Hallo zusammen,

    ich bin so langsam am verzweifeln mit meinen udev Regeln.
    Ich nutze ein LFS und habe meine Regeln aus dem LFS-Buch übernommen und zum Teil umgeschrieben bzw. selbst geschrieben. Soweit funktioniert auch alles, nur weigert sich udev meinen CD- bzw. DVD-Laufwerken andere Gruppen zuzuweisen. Meine Datei mit den Regeln die ich eigentlich gerne hätte sieht wie folgt aus:
    Code:
    cat 10-cdrom.rules
    # /etc/udev/rules.d/50-cdrom.rules: udev rules to handle cdrom devices
    
    # dvdrom device
    SUBSYSTEM=="block", KERNEL=="hdc", NAME="%k", GROUP="cdrom", SYMLINK+="cdrom"
    
    # dvdram device
    SUBSYSTEM=="block", KERNEL=="hdd", GROUP="burning", SYMLINK+="dvdrw"
    
    # End /etc/udev/rules.d/50-cdrom.rules
    Die Links werden erstellt, aber die GID bleibt auf "disk". Ich kann mir nur erklären, dass das von einer Regel weiter unten kommt, die die Speichermedia allgemein verwaltet:

    Code:
    cat 55-storage.rules
    # /etc/udev/rules.d/15-memory.rules: Rules to handle storage devices
    
    ...
    KERNEL=="hd*",                  GROUP="disk"
    ...
    
    # /etc/udev/rules.d/15-memory.rules
    
    
    Sieht jemand zufällig meinen Fehler oder was ich falsch mache.

    Danke.

    Gruß
    Olti
     
  2. Anzeige

    Anzeige

    Wenn du mehr über Linux erfahren möchtest, dann solltest du dir mal folgende Shellkommandos anschauen.


    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 Wolfgang, 08.01.2008
    Wolfgang

    Wolfgang Foren Gott

    Dabei seit:
    24.04.2005
    Beiträge:
    3.978
    Zustimmungen:
    0
    Ort:
    Erfurt
    IMHO solltest du dann negativ matchen lassen.

    Code:
    KERNEL=="hd[!c-d]",                  GROUP="disk"
    
    Hoffe das hilft.

    Gruß Wolfgang
     
Thema:

Problem mit udev Regeln

Die Seite wird geladen...

Problem mit udev Regeln - Ähnliche Themen

  1. xorg-server update: umstieg von hal auf udev -> probleme mit tastatur & maus

    xorg-server update: umstieg von hal auf udev -> probleme mit tastatur & maus: Hi also der Betreff sagt schon des meiste. Hab mein Gentoo-System seit längerer Zeit mal wieder aktualisiert, was 2 größere Änderungen mit sich...
  2. problem mit udev & pcmciautils

    problem mit udev & pcmciautils: hallo! nach dem upgrade von pcmciautils auf 013 kommt beim booten folgende fehlermeldung: add_to_rules: unknown key 'MODALIAS' in...
  3. webdav automount (+coda-udev-Problem)

    webdav automount (+coda-udev-Problem): Hi alle, nachdem ich davfs2 uebersetzt bekommen habe (musste fuer kernel-2.6-codafs gepatcht werden) und es zumindest mit dem GMX-Mediacenter...
  4. Mageia 7.1 patcht Boot-Problem bei AMD Ryzen 3000 CPUs

    Mageia 7.1 patcht Boot-Problem bei AMD Ryzen 3000 CPUs: Mageia hat kurzfristig mit Version 7.1 ein Point-Release veröffentlicht, um einen Boot-Fehler mit AMDs Ryzen 3000 CPUs zu beheben, der einige...
  5. ip6tables Problem

    ip6tables Problem: Hallo zusammen, ich hab ein Problem kann aber keinen Fehler finden, äußert sich wie folgt, ich habe endlich für ein System in Netz eine IPv6...
  1. Diese Seite verwendet Cookies um Inhalte zu personalisieren. Außerdem werden auch Cookies von Diensten Dritter gesetzt. Mit dem weiteren Aufenthalt akzeptierst du diesen Einsatz von Cookies.
    Information ausblenden