problem mit tune2fs filesystem-check

Diskutiere problem mit tune2fs filesystem-check im Linux OS Forum im Bereich Linux/Unix Allgemein; hi, ich hab FC 4 und Ubuntu auf meinem Desktop-system. da mich die voreingestellte filesystem-überprüfung von ubuntu nach 30 reboots nervt...

  1. #1 supersucker, 25.01.2006
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    hi,

    ich hab FC 4 und Ubuntu auf meinem Desktop-system. da mich die voreingestellte filesystem-überprüfung von ubuntu nach 30 reboots nervt wollte ich die mit tune2fs abstellen.
    merkwürdigerweise tut sich aber gar nichts wenn ich das mit tune2fs probiere, soll heissen:

    schaue ich in die man-page von tune2fs:


    Code:
    OPTIONS
           -c max-mount-counts
                  Adjust  the  maximal  mounts  count  between  two filesystem checks.  If max-mount-counts is 0 or -1, the number of times the filesystem is
                  mounted will be disregarded by e2fsck(8) and the kernel.
    
                  Staggering the mount-counts at which filesystems are forcibly checked will avoid all filesystems being checked at one time when using jour‐
                  naled filesystems.
    
                  You  should  strongly consider the consequences of disabling mount-count-dependent checking entirely.  Bad disk drives, cables, memory, and
                  kernel bugs could all corrupt a filesystem without marking the filesystem dirty or in error.  If you are using journaling on your  filesys‐
                  tem,  your filesystem will never be marked dirty, so it will not normally be checked.  A filesystem error detected by the kernel will still
                  force an fsck on the next reboot, but it may already be too late to prevent data loss at that point.
    
                  See also the -i option for time-dependent checking.
    
    
    ok, aber führe ich nun als root

    Code:
    root@supersucker:~# tune2fs -c 100
    tune2fs 1.38 (30-Jun-2005)
    Usage: tune2fs [-c max_mounts_count] [-e errors_behavior] [-g group]
            [-i interval[d|m|w]] [-j] [-J journal_options]
            [-l] [-s sparse_flag] [-m reserved_blocks_percent]
            [-o [^]mount_options[,...]] [-r reserved_blocks_count]
            [-u user] [-C mount_count] [-L volume_label] [-M last_mounted_dir]
            [-O [^]feature[,...]] [-T last_check_time] [-U UUID] device
    
    damit weise ich das system laut manpage an den check erst nach 100 reboots das zu machen.

    tja, dachte ich zumindest, denn das system führt den check immer noch nach 30 reboots aus.

    auch ein

    Code:
    tune2fs -c 0
    
    womit ich den check testweise komplett ausschalten wollte wurde einfach nicht übernommen.
    desweiteren wundert mich das nach ausführen des befehls die einzelnen schalter aufgeführt werden wie oben zu sehen, das sollte mir doch eigentlich sagen das ich irgendeinen parameter vergessen hab?
    laut manpage und diversen beispielen im netz sollte das aber doch so gehen.........bin ziemlich ratlos jetzt warum das nicht funktioniert...

    das filesystem ist ext3, und zwar auf allen platten die ich eingebaut habe...

    bin für jede hilfe dankbar
     
  2. Anzeige

    Anzeige

    Wenn du mehr über Linux erfahren möchtest, dann solltest du dir mal folgende Shellkommandos anschauen.


    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. rikola

    rikola Foren Gott

    Dabei seit:
    23.08.2005
    Beiträge:
    2.133
    Zustimmungen:
    0
    Wenn Du nur
    Code:
     tune2fs -c 100 
    eingibst, weiss das Programm nicht, auf welche Partition es den Befehl anwenden soll. Du musst diese als Parameter mit angeben:
    Code:
     tune2fs -c 100 /dev/hda1 
    Das musst Du fuer alle Partitionen einzeln machen, fuer die Du die Parameter aendern willst. hda1 ist dabei die erste Partition auf der ersten IDE-Festplatte. Falls Du scsi-Platten hast, musst Du stattdessen 'sda1' angeben. Fuer die zweite Partition auf der ersten IDE-Platte musst Du 'hda2' angeben, und fuer die fuenfte Partition auf der dritten Platte 'hdc5' usw.
     
Thema:

problem mit tune2fs filesystem-check

Die Seite wird geladen...

problem mit tune2fs filesystem-check - Ähnliche Themen

  1. Mageia 7.1 patcht Boot-Problem bei AMD Ryzen 3000 CPUs

    Mageia 7.1 patcht Boot-Problem bei AMD Ryzen 3000 CPUs: Mageia hat kurzfristig mit Version 7.1 ein Point-Release veröffentlicht, um einen Boot-Fehler mit AMDs Ryzen 3000 CPUs zu beheben, der einige...
  2. ip6tables Problem

    ip6tables Problem: Hallo zusammen, ich hab ein Problem kann aber keinen Fehler finden, äußert sich wie folgt, ich habe endlich für ein System in Netz eine IPv6...
  3. VDSL 50 FRITZBOX 7490 PROBLEM?

    VDSL 50 FRITZBOX 7490 PROBLEM?: Hallo ,ich besitze seit letzter Woche VDSL 50 also eine 50000er Leitung. Im Router wird mir allerdings unter "DSL Informationen" 109,34 Mbit/s...
  4. Problem mit SATA

    Problem mit SATA: Hallo zusammen Wo liegt hier das Problem? - Controller defekt? (LSI SAS3041X-L) - Festplatten defekt (Western Digital Green 1.5 TB)...
  5. Probleme mit WinSCP und Rechten

    Probleme mit WinSCP und Rechten: Hallo. Ich habe vor ein paar Tgen meinen ersten Ubuntu 16.04 vServer bei 1&1 bestellt, gemäß dem sicheren Umgang damit, habe ich erstmal den SSH...
  1. Diese Seite verwendet Cookies um Inhalte zu personalisieren. Außerdem werden auch Cookies von Diensten Dritter gesetzt. Mit dem weiteren Aufenthalt akzeptierst du diesen Einsatz von Cookies.
    Information ausblenden