Problem mit src.rpm vom SUSE Buildservice

Diskutiere Problem mit src.rpm vom SUSE Buildservice im RedHat,Fedora & CentOS Forum im Bereich Linux Distributionen; Hi Ich fahre den RHEL5 Clone Scientificlinux auf meinem Hobel. Das ist auch auf dem Server drauf. Für diesen und weitere will ich RPM's für...

  1. #1 minimike, 16.04.2010
    minimike

    minimike Mitglied

    Dabei seit:
    14.10.2005
    Beiträge:
    34
    Zustimmungen:
    0
    Hi

    Ich fahre den RHEL5 Clone Scientificlinux auf meinem Hobel. Das ist auch auf dem Server drauf. Für diesen und weitere will ich RPM's für .NET, MojoPortal, 389 Server und Free-IPA vorhalten.

    Mono habe ich schon fertig aus dem Source RPM vom SUSE Buildservice erstellt. Mir fehlt aber noch MonoDevelop um weitere Pakete zu paketieren. Es scheitert derzeit an gtk-sharp2 aus dem Source RPM für RHEL5 aus dem SuSE Buildservice als Abhängigkeit für MonoDevelop

    hier mal die SPEC File http://debianforum.de/forum/pastebin.php?mode=view&s=34530

    Problem ist das rpmbuild mit
    Code:
    Version:        %_version
    nicht funktioniert rpmbuild findet dann die "Sourcen%_version.tar.bz2" nicht

    Schreibe ich dann die Version 2.10.4 ein, werden die Sourcen gefunden. Aber das patchen der Sourcen schlägt anschliesend fehl
    Kann mir jemand einen Tip geben wie ich mit der Specfile meine RPM's bauen kann?
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 defcon, 16.04.2010
    Zuletzt bearbeitet: 16.04.2010
    defcon

    defcon Kaiser
    Moderator

    Dabei seit:
    22.08.2005
    Beiträge:
    1.487
    Zustimmungen:
    1
    Ort:
    Bruchsal
    Super, Fehlermeldung?

    Crossposting:
    http://www.fedoraforum.de/viewtopic.php?f=4&p=112245#p112245
     
Thema:

Problem mit src.rpm vom SUSE Buildservice

Die Seite wird geladen...

Problem mit src.rpm vom SUSE Buildservice - Ähnliche Themen

  1. Problem bei der installation einer Sun Netzwerkkarte

    Problem bei der installation einer Sun Netzwerkkarte: Guten Morgen zusammen, beim installieren einer zusätzlichen Netzwerkkarte habe ich ein Problem. Die Karte wird nicht automatisch installiert. Es...
  2. Problem bei der Vergabe von Sciherheitsinformationen auf eine Freiagbe

    Problem bei der Vergabe von Sciherheitsinformationen auf eine Freiagbe: Liebe Community, zurzeit arbeite ich an eine Active Directory Domäne die mittels Samba läuft. Dazu habe ich einen AD DC auf Debian 8.7 mit Samba...
  3. Netzwerkproblem ? , wo ud wie suchen

    Netzwerkproblem ? , wo ud wie suchen: Hallo Folgende Problem: Testserver ist i686 Debian-unstable , auf dem läuft primär der apt-proxy apt-cahcer ng. Zugriff im Moment nur per ssh....
  4. Verständnisproblem Samba / LDAP

    Verständnisproblem Samba / LDAP: Hallo zusammen! Ich habe unter Ubuntu 16.04 einen LDAP und Samba Server aufgesetzt. Diese scheinen auch ordnungsgemäß zu funktionieren, sodaß ich...
  5. nginx+php-fpm problem

    nginx+php-fpm problem: Moin, ich hab hier gerade ein Problem und keine Idee mehr woran es liegt. Ich muss wie schon in der Überschrift erwähnt nginx dazu bringen php...