Problem mit "Prism54" WLAN-Card Driver

Diskutiere Problem mit "Prism54" WLAN-Card Driver im Internet, lokale Netzwerke und Wireless Lan Forum im Bereich Netzwerke & Serverdienste; [gelöst] Problem mit "Prism54" WLAN-Card Driver Hallo zusammen Gerade mal vorweg. Ich bin erst seit knapp 3 Wochen Linux User. (15 Jahre...

  1. #1 hampa, 04.10.2005
    Zuletzt bearbeitet: 04.10.2005
    hampa

    hampa Jungspund

    Dabei seit:
    27.09.2005
    Beiträge:
    15
    Zustimmungen:
    0
    Ort:
    Graubünden, Schweiz
    [gelöst] Problem mit "Prism54" WLAN-Card Driver

    Hallo zusammen

    Gerade mal vorweg. Ich bin erst seit knapp 3 Wochen Linux User. (15 Jahre Windows-"geschädigt") Also habt Einsicht mit einem Newbie. :D

    Ich habe einen "alten" Laptop 233Mhz/100MB (Toshiba Satelite 490CDT) und habe auf Anraten Zenwalk installiert. Das hat auch wunderbar geklappt. Das einzige, was nicht erkannt wurde war die Soundkarte sowie die WLAN-Karte.

    Durch "Nachforschungen" im Netz habe ich herausgefunden, dass mit meiner PCMCIA-Karte von Fujitsu-Siemens E-5400 der Treiber von "Prism54" zu verwenden sei. Gesagt getan. Ich habe mir also den Treiber heruntergeladen. Aber da fings schon an, welchen soll ich jetzt nehmen? Was ist ein TarBall? :think: Also habe ich mir den geschnappt, der mir vom Gefühl her der Richtige sein musste.

    In der README-Datei war nun folgendes zu lesen.

    Code:
    tar xjf prism54-cvs-latest.tar.bz2
    
    Change to the prism directory:
    cd prism54-cvs-latest
    
    If you are running the target kernel, then you should be
    able to do :
    
    make clean modules
    (and as root or with sudo)
    make install
    depmod -a
    Cool dachte ich mir, das kann ja nicht so schwer sein und habe gleich begonnen, das auszuführen, was da geschrieben stand. Mit folgendem Ergebnis:

    Code:
    .....
    Entering directory '/usr/src/linux-2.6.12.2'
    *** No rule to make target 'modules'  Stop
    ......
    Da war die anfägnliche Euphorie schon mal arg angekratzt. :(

    Ausserdem habe ich noch etwas seltsamens entdeckt. Während der Ausführung von 'make clean modules' heisst es unter anderem.

    Code:
    make -C /lib/modules/2.6.12.2/build SUBDIR= ......
    Diese build-Verzeichnis ist aber bloss ein Link. Dieser Link wiederum verweist auf das verzeichnis /usr/src/linux-2.6.12.2/ Dieses Verzeichnis existiert aber nicht auf meinem System. Ich schnalls nicht. :(

    Eventuell hat jemand von Euch Lust und die Geduld mir das zu erklären. Das wäre toll. :headup:

    Grüsse aus der Schweiz
    Hampa
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 monarch, 04.10.2005
    Zuletzt bearbeitet: 04.10.2005
    monarch

    monarch Schattenparker

    Dabei seit:
    13.02.2005
    Beiträge:
    222
    Zustimmungen:
    0
    Schau mal zuallererst ob du den prism54 nicht schon im Kernel hast.

    Code:
    modprobe prism54
    und dann kannst du nachschauen mit
    Code:
    lsmod
    ob in dem ganzen Gewusel eine Zeile mit "prism54" drinsteht.


    Achja, wo dus schon erwähnst: ein tarball ist nichts anderes als ein tar-Archiv. Haste ja beim entpacken sicher gemerkt dass das ne gepackte Datei ist.

    README gelesen! Sehr gut. :oldman :)


    Zu dem build-Link, der ins Nirvana geht: Dieses "build" zeigt immer auf das Verzeichnis wo der Kernel kompiliert worden ist. In deinem Fall ist nur der Kernel selber installiert, keine Kernelquellen usw. Also geht der Link ins Leere.
    Das ganze müßte reibungslos funktionieren wenn du dir die Kernel-Header für deine Kernelversion installierst. Die ganzen Kernel-Sources brauchst du nicht, nur die Header.
     
  4. hampa

    hampa Jungspund

    Dabei seit:
    27.09.2005
    Beiträge:
    15
    Zustimmungen:
    0
    Ort:
    Graubünden, Schweiz
    Hallo monarch

    Ich bin im Moment gerade dabei Ubuntu 5.04 auf dem genannten Laptop zu installieren. Die genannte Karte (E-5400) wurde schon im Verlaufe der Installation erkannt und arbeitet ohne mein Zutun perfekt.

    Ich will Zenwalk nicht schlecht machen. Wahrscheinlich kenn ich mich mit Linux einfach noch zuwenig aus. Aber wie immer. "Gut Ding will Weile haben".

    Ich schau mal, wie die Installation weiterläuft. Auf meinen "kräftigen" Maschinen bleibe jedoch bei SuSe 9.3.

    Vielen Dank für Deine Ausführen. Ich habe wieder Wertvolles dazugelernt.

    Viele Grüsse
    Hampa
     
Thema:

Problem mit "Prism54" WLAN-Card Driver

Die Seite wird geladen...

Problem mit "Prism54" WLAN-Card Driver - Ähnliche Themen

  1. Netzwerkproblem ? , wo ud wie suchen

    Netzwerkproblem ? , wo ud wie suchen: Hallo Folgende Problem: Testserver ist i686 Debian-unstable , auf dem läuft primär der apt-proxy apt-cahcer ng. Zugriff im Moment nur per ssh....
  2. Verständnisproblem Samba / LDAP

    Verständnisproblem Samba / LDAP: Hallo zusammen! Ich habe unter Ubuntu 16.04 einen LDAP und Samba Server aufgesetzt. Diese scheinen auch ordnungsgemäß zu funktionieren, sodaß ich...
  3. nginx+php-fpm problem

    nginx+php-fpm problem: Moin, ich hab hier gerade ein Problem und keine Idee mehr woran es liegt. Ich muss wie schon in der Überschrift erwähnt nginx dazu bringen php...
  4. Problem mit Windows auf Ordner auf dem Linuxsystem zuzugreifen

    Problem mit Windows auf Ordner auf dem Linuxsystem zuzugreifen: Ich mache gerade meine ersten Schritte mit Linux und würde gerne auf Dateien meines Linuxsystems auch mit Windows zugreifen, ich bin am...
  5. Virtualboxproblem

    Virtualboxproblem: Hallo Folgnedes Problem: Ich kann ohne Probleme In Debian-Sid, 64Bit und virtualbox-dkms Unixoide installieren, wenn es sich um eine...