Problem mit ncurses bei gentoo install

Diskutiere Problem mit ncurses bei gentoo install im Gentoo Forum im Bereich Linux Distributionen; Ich habe folgendes Probkem bei der Gentoo installation wenn ich emerge --emptytree system mache:...

  1. #1 Drizzt_DoUrden, 09.10.2005
    Drizzt_DoUrden

    Drizzt_DoUrden Tripel-As

    Dabei seit:
    06.01.2003
    Beiträge:
    200
    Zustimmungen:
    0
    Ich habe folgendes Probkem bei der Gentoo installation wenn ich emerge --emptytree system mache:

    /ncurses-5.4-r6/work/ncurses-5.4/test/../include -I. -I../include -D_GNU_SOURCE -DNDEBUG -march=pentium2 -O3 -pipe -fomit-frame-pointer -fPIC
    make[1]: Leaving directory `/var/tmp/portage/ncurses-5.4-r6/work/narrowc/test'
    cd misc && make DESTDIR="" all
    make[1]: Entering directory `/var/tmp/portage/ncurses-5.4-r6/work/narrowc/misc'
    make[1]: Nothing to be done for `all'.
    make[1]: Leaving directory `/var/tmp/portage/ncurses-5.4-r6/work/narrowc/misc'
    cd c++ && make DESTDIR="" all
    make[1]: Entering directory `/var/tmp/portage/ncurses-5.4-r6/work/narrowc/c++'
    cd ../obj_s; -I../c++ -I../include -I/var/tmp/portage/ncurses-5.4-r6/work/ncurses-5.4/c++ -DHAVE_CONFIG_H -I/var/tmp/portage/ncurses-5.4-r6/work/ncurses-5.4/c++/../include -I. -I../include -D_GNU_SOURCE -DNDEBUG -march=pentium2 -O3 -pipe -fomit-frame-pointer -fPIC -c /var/tmp/portage/ncurses-5.4-r6/work/ncurses-5.4/c++/cursesf.cc
    /bin/sh: -I../c++: No such file or directory
    make[1]: *** [../obj_s/cursesf.o] Error 127
    make[1]: Leaving directory `/var/tmp/portage/ncurses-5.4-r6/work/narrowc/c++'
    make: *** [all] Error 2

    !!! ERROR: sys-libs/ncurses-5.4-r6 failed.
    !!! Function do_compile, Line 86, Exitcode 2
    !!! make failed
    !!! If you need support, post the topmost build error, NOT this status message

    habe auch schon versucht ncurses aleine zu kompilieren brachte den selben fehler.
    Weis da einer was?

    Gruss Drizzt
     
  2. Anzeige

    Schau dir mal diese Kategorie an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. #2 energyman, 09.10.2005
    energyman

    energyman Mitglied

    Dabei seit:
    24.04.2002
    Beiträge:
    35
    Zustimmungen:
    0
    Hi,

    erstmal: warum --emptytree? Normalerweise gibt es KEINEN Grund, --emptytree zu machen?
    Zweitens bin ich mir ziemlich sicher, den Fehler schon auf bug.gentoo.org gesehen zu haben - schon nachgeschaut?
     
  4. dramen

    dramen Routinier

    Dabei seit:
    13.01.2005
    Beiträge:
    356
    Zustimmungen:
    0
    Ort:
    Wien
    das passiert bei mir nur wenn die festplatte voll ist.
     
  5. hex

    hex Lebende Foren Legende
    Moderator

    Dabei seit:
    10.12.2003
    Beiträge:
    1.775
    Zustimmungen:
    0
    Ort:
    Stuttgart
    Wird im Handbuch empfohlen! Über Sinn und Unsinn lässt sich phylosophieren!

    mfg hex
     
  6. #5 DennisM, 09.10.2005
    DennisM

    DennisM Moderator u. Newsposter

    Dabei seit:
    08.05.2004
    Beiträge:
    4.883
    Zustimmungen:
    0
    Ort:
    GER/NRW/Essen
    Es könnte auch an den Compiler Flags liegen, probier es mal mit "humaneren" Flags.

    MFG

    Dennis
     
Thema:

Problem mit ncurses bei gentoo install

Die Seite wird geladen...

Problem mit ncurses bei gentoo install - Ähnliche Themen

  1. [ncurses] Probleme mit Umlauten und ein paar Sonderzeichen

    [ncurses] Probleme mit Umlauten und ein paar Sonderzeichen: Hi Ich weiß nicht ob es jetzt an C++ und ncurses oder am System liegt, ich habs mal hier rein, falls ein MOD mein, es gehört wo anders hin,...
  2. Problem bei der installation einer Sun Netzwerkkarte

    Problem bei der installation einer Sun Netzwerkkarte: Guten Morgen zusammen, beim installieren einer zusätzlichen Netzwerkkarte habe ich ein Problem. Die Karte wird nicht automatisch installiert. Es...
  3. Problem bei der Vergabe von Sciherheitsinformationen auf eine Freiagbe

    Problem bei der Vergabe von Sciherheitsinformationen auf eine Freiagbe: Liebe Community, zurzeit arbeite ich an eine Active Directory Domäne die mittels Samba läuft. Dazu habe ich einen AD DC auf Debian 8.7 mit Samba...
  4. Netzwerkproblem ? , wo ud wie suchen

    Netzwerkproblem ? , wo ud wie suchen: Hallo Folgende Problem: Testserver ist i686 Debian-unstable , auf dem läuft primär der apt-proxy apt-cahcer ng. Zugriff im Moment nur per ssh....
  5. Verständnisproblem Samba / LDAP

    Verständnisproblem Samba / LDAP: Hallo zusammen! Ich habe unter Ubuntu 16.04 einen LDAP und Samba Server aufgesetzt. Diese scheinen auch ordnungsgemäß zu funktionieren, sodaß ich...