Problem mit Kernelkonfiguration

Diskutiere Problem mit Kernelkonfiguration im Gentoo Forum im Bereich Linux Distributionen; Hallo, ich bin seit einiger Zeit dabei, mir meinen Kernel zu konfigurieren, was jedoch irgendwie nicht so richtig will. (Ich muss dazusagen, dass...

  1. #1 EagleMF, 21.11.2006
    EagleMF

    EagleMF Jungspund

    Dabei seit:
    01.12.2005
    Beiträge:
    16
    Zustimmungen:
    0
    Hallo,
    ich bin seit einiger Zeit dabei, mir meinen Kernel zu konfigurieren, was jedoch irgendwie nicht so richtig will. (Ich muss dazusagen, dass ich recht neu in dieser Materie bin). Ich benutze die 2.6.18-gentoo-r2 Version und bekomme beim Booten folgende Fehlermeldung:
    meine grub.conf sieht folgendermaßen aus:
    Also ich hab vorläufig eine Kernelkonfiguration von einem Freund übernommen und die ist mittlerweile die Einzige, mit der ich mein System noch starten kann. Jedoch ist halt dieser Kernel nicht auf mein System abgestimmt, weshalb auch die meiste Hardware nicht richtig (oder überhaupt nicht) läuft. Deshalb wollt ich mir nun das ganze selbst basteln was mir allerdings nicht so ganz gelingt. Also ich bin der Meinung, dass die grub.conf richtig sein muss, da der Eintrag bis auf den Kernelnamen identisch mit dem Kernel meines Freundes ist, sodass ich vermute, dass ich irgendwie was am Kernel machen muss.
    Kann mir vielleicht jemand einen Tipp geben, nach was ich schauen muss?

    Vielen Dank
     
  2. Anzeige

    Anzeige

    Wenn du mehr über Linux erfahren möchtest, dann solltest du dir mal folgende Shellkommandos anschauen.


    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. rikola

    rikola Foren Gott

    Dabei seit:
    23.08.2005
    Beiträge:
    2.133
    Zustimmungen:
    0
    Vermutlich enthaelt Dein Kernel nicht den Treiber fuer das Dateisystem der root-Partition. Entweder, Du kompilierst den fest hinein, oder, falls er als modul vorliegt, erstellst Du Dir eine initrd und gibst die in/boot/grub/menu.lst mit an.
     
  4. #3 nikster77, 21.11.2006
    nikster77

    nikster77 Routinier

    Dabei seit:
    15.03.2004
    Beiträge:
    307
    Zustimmungen:
    0
    Du musst halt schauen ob im Kernel
    - alle Treiber fuer deine Platten (SATA/IDE, wenn ja welcher Chipsatz, etc.)
    - alle Filesysteme (so trivial das man's gerne vergisst...)

    drin sind.

    Sag halt mal was zur Hardware, vor allem RAIDs, SATA-Platten, von dir verwendete Filesysteme, etc. dann kann dir bestimmt jemand weiterhelfen.

    edit:
    aehm... ok hda also kein sata... aber trotzdem...
     
  5. heady

    heady Routinier

    Dabei seit:
    13.12.2005
    Beiträge:
    424
    Zustimmungen:
    0
    Ort:
    im Herzen Europas
    naja irgendwie hatte ich auch die selben probleme mit dem kernel...
    ich habs aber irgendwie mit dem befehl rdev gelöst, weiß aber nicht mer ganz wie
    außerdem lief der neue kernel auf meinem laptop ziemlich mies...ka warum...
     
  6. #5 whopper, 22.11.2006
    whopper

    whopper Foren As

    Dabei seit:
    01.10.2006
    Beiträge:
    96
    Zustimmungen:
    0
    Das Problem hatte ich auch und ich habs auch irgendwie hinbekommen mit dem Kernel.

    Mein Problem waren aber die Chipsätze für den IDE-Controller AFAIK.
     
  7. #6 illtiss, 22.11.2006
    illtiss

    illtiss Routinier

    Dabei seit:
    19.01.2005
    Beiträge:
    449
    Zustimmungen:
    0
    Kann das auch an der fstab, oder der grub.conf liegen?

    Überprüfe das noch einmal. Vielleicht passt was nicht ganz mit den Festplatten bzw. Partitions Angaben.
     
  8. #7 EagleMF, 22.11.2006
    EagleMF

    EagleMF Jungspund

    Dabei seit:
    01.12.2005
    Beiträge:
    16
    Zustimmungen:
    0
    ich vermute, dass es daran liegt... muss mal schauen.
    Also zur Hardware (Laptop Samsung X20 1730 V)
    - IDE Controler
    - Chipsatz: Mobile Intel 915GM Express

    Also falsche Partitionsangaben oder Fehler in der Fstab / grub.conf kann ich ja eigentlich ausschließen, da wie gesagt der Kernel meines Freundes damit läuft.
     
  9. name

    name Inactive user

    Dabei seit:
    28.08.2004
    Beiträge:
    592
    Zustimmungen:
    0
    Ort:
    Wien->127.0.0.1
    [X]'e mal alle pseudo filesystems beim kernel..
     
  10. #9 EagleMF, 23.11.2006
    EagleMF

    EagleMF Jungspund

    Dabei seit:
    01.12.2005
    Beiträge:
    16
    Zustimmungen:
    0
    bringt leider auch nichts...
     
Thema:

Problem mit Kernelkonfiguration

Die Seite wird geladen...

Problem mit Kernelkonfiguration - Ähnliche Themen

  1. Linux 5.6 löst Jahr-2038-Problem für 32-Bit-Systeme

    Linux 5.6 löst Jahr-2038-Problem für 32-Bit-Systeme: Die kommende Version 5.6 wird der erste Linux-Kernel sein, der gegen das Jahr-2038-Problem auf 32-Bit-Systemen immun ist. Damit das greifen kann,...
  2. kleines curl Problem

    kleines curl Problem: Hallo, ich bin LINUX Frischling und hab mich ein wenig in eien Sackgasse verlaufen... Ich habe vor, die Verzeichnisgröße via curl Befehl in eine...
  3. Samba 4.0.0 - DNS-Problem

    Samba 4.0.0 - DNS-Problem: Hallo, ich betreibe seit 2013 einen Samba4 Server auf Basis der sernet-Pakete als DC für eine kleine Domäne. Nur mit dem DNS gibt es Probleme....
  4. Mageia 7.1 patcht Boot-Problem bei AMD Ryzen 3000 CPUs

    Mageia 7.1 patcht Boot-Problem bei AMD Ryzen 3000 CPUs: Mageia hat kurzfristig mit Version 7.1 ein Point-Release veröffentlicht, um einen Boot-Fehler mit AMDs Ryzen 3000 CPUs zu beheben, der einige...
  5. ip6tables Problem

    ip6tables Problem: Hallo zusammen, ich hab ein Problem kann aber keinen Fehler finden, äußert sich wie folgt, ich habe endlich für ein System in Netz eine IPv6...
  1. Diese Seite verwendet Cookies um Inhalte zu personalisieren. Außerdem werden auch Cookies von Diensten Dritter gesetzt. Mit dem weiteren Aufenthalt akzeptierst du diesen Einsatz von Cookies.
    Information ausblenden