postgresql-server update problem

Diskutiere postgresql-server update problem im SQL und Datenbanken Forum im Bereich Netzwerke & Serverdienste; hi zusammen, hab wieder mal ein problem, bei dem ich eure hilfe brauche : bei fedora 3 ist ja freundlicherweise schon ein postgreserver...

  1. #1 supersucker, 12.03.2005
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    hi zusammen,

    hab wieder mal ein problem, bei dem ich eure hilfe brauche :

    bei fedora 3 ist ja freundlicherweise schon ein postgreserver vorinstalliert auf den ich über webmin bzw. psql zugreife. nun würde ich gerne (also eigentlich muss ich besser gesagt) mit der neuen 8-version arbeiten, ich kriegs aber nicht gebacken das zu updaten, was ich versucht hab:

    yum search postgresql

    hat nur die version gefunden die ich schon installiert hatte, hab mir also das rpm von der postgresql-seite gezogen und dann folgendes gemacht:

    rpm -i postgresql-8.0.1-1PGDG.i686.rpm

    das hat mir dann sehr viele fehlermeldungen folgender art gebracht:

    file /usr/bin/clusterdb from install of postgresql-8.0.1-1PGDG conflicts with file from package postgresql-7.4.7-3.FC3.1

    hab dann versucht den installierten server mit

    rpm -e postgresql

    zu deinstallieren, bekam darauf folgende meldung:

    Fehler: Failed dependencies:
    postgresql = 7.4.7 is needed by (installed) postgresql-server-7.4.7-3.FC3.1.i386
    postgresql = 7.4.7 is needed by (installed) postgresql-pl-7.4.7-3.FC3.1.i386
    postgresql = 7.4.7 is needed by (installed) postgresql-test-7.4.7-3.FC3.1.i386

    und hab dann zuletzt versucht ob ich den server einfach so updaten kann mit:

    rpm -U postgresql-8.0.1-1PGDG.i686.rpm

    mit folgender meldung:
    Fehler: Failed dependencies:
    postgresql = 7.4.7 is needed by postgresql-server-7.4.7-3.FC3.1.i386
    postgresql = 7.4.7 is needed by (installed) postgresql-server-7.4.7-3.FC3.1.i386
    postgresql = 7.4.7 is needed by (installed) postgresql-pl-7.4.7-3.FC3.1.i386
    postgresql = 7.4.7 is needed by (installed) postgresql-test-7.4.7-3.FC3.1.i386

    warum das installieren nicht geklappt hat kann ich mir noch erklären (also, so halbwegs zumindest) , nur mit den letzten fehlermeldungen bei rpm-e und rpm-U kann ich gar nix anfangen........

    wäre nett wenn mir einer von euch erklären könnte was ich da denn falsch gemacht habe......

    danke im voraus!
     
  2. phlekk

    phlekk Doppel-As

    Dabei seit:
    14.04.2004
    Beiträge:
    101
    Zustimmungen:
    0
    Ort:
    Chemnitz
    hi

    postgresql besteht aus mehreren rpm-paketen, deswegen kommt diese fehlermeldung. schau mal auf www.rpmseek.de da kannst du alle pakete, die zum postgresql gehören ( es sind auch da welche zusätzlich dabei ), sehen. zum beispiel
    das sagt, dass das paket postgresql-server noch installiert ist und das du das zu erst deinstallieren musst und dan postgresql.

    gruss phlekk
     
  3. #3 supersucker, 17.03.2005
    supersucker

    supersucker Foren Gott

    Dabei seit:
    21.02.2005
    Beiträge:
    3.873
    Zustimmungen:
    0
    hi,

    erstmal danke für die hilfe............
    hab das problem mittlerweile dadurch gelöst, dass ich mit "yum remove postgresql" erst mal alles von platte geschmissen hab, und dann den neuen 8-ter server selber kompiliert hab, und der läuft jetzt wenigstens........:-)
     
Thema:

postgresql-server update problem

Die Seite wird geladen...

postgresql-server update problem - Ähnliche Themen

  1. Problem mit mysqld und postgresql-server

    Problem mit mysqld und postgresql-server: hi, ich hab im bootlog folgende fehlermeldungen: Sat Mar 17 12:59:22 2007: Starting MySQL database server: mysqld . . . . . . . . . . . . . ....
  2. postgresql-server läuft, aber pgadmin will nicht verbinden...

    postgresql-server läuft, aber pgadmin will nicht verbinden...: moin zusammen, hab folgendes problem: hab mir den postgresql-server (7.4.7-3.FC3.1, fedora 3) installiert sowie webmin, beide laufen auch,...
  3. Meldung nach initramfs update

    Meldung nach initramfs update: Hallo Was bedeutet die folgende Meldung nach einem initramfs update ---------- I: The initramfs will attempt to resume from /dev/sda15 I:...
  4. Update auf Apache >=2.4.12 unter Debian Jessie

    Update auf Apache >=2.4.12 unter Debian Jessie: Hi, aufgrund eines Bugs in Apache 2.4 benötige ich zum Deployment von Seafile unter Debian Jessie das Paket apache2 in der Version >= 2.4.12...
  5. Nicht erkannte Zeichen nach Update

    Nicht erkannte Zeichen nach Update: Hi, nachdem ich mein Kali Linux geupdated habe, ist mir aufgefallen dass viele Zeichen auf verschiedenen Nutzeroberflächen nur fehlerhaft...