Postfix problem

Diskutiere Postfix problem im Internet, lokale Netzwerke und Wireless Lan Forum im Bereich Netzwerke & Serverdienste; Postfix problem [glöst] Guten morgen, folgende problematik: Ich habe den postfx 2.5.5 installiert. Ich kann auch mail rausschicken. Allerdings...

  1. #1 tiptel170, 05.05.2009
    Zuletzt bearbeitet: 06.05.2009
    tiptel170

    tiptel170 Tripel-As

    Dabei seit:
    20.07.2008
    Beiträge:
    161
    Zustimmungen:
    0
    Postfix problem [glöst]

    Guten morgen,

    folgende problematik: Ich habe den postfx 2.5.5 installiert. Ich kann auch mail rausschicken. Allerdings wird mir immer der benutername bei t-online nicht umgeschrieben.

    Ich habe 3 e-mail provider und bei einem sind 3accounts darauf. Nun habe ich folgende einstellungen vorgenommen:

    In der /etc/postfix/main.cf
    Code:
    smtp_sasl_password_maps = hash:/etc/postfix/smtp_auth
    smtp_sasl_security_options = noanonymous
    smtp_sasl_auth_enable = yes
    smtp_sasl_auth_soft_bounce = yes
    smtp_generic_maps = hash:/etc/postfix/generic
    sender_dependent_relayhost_maps = hash:/etc/postfix/senderrelay
    sender_canonical_maps = hash:/etc/postfix/sender_canonical
    recipient_canonical_maps = hash:/etc/postfix/recipient_canonical
    
    In der /etc/postfix/smtp_auth steht drin:
    Code:
    smtpmail.t-online.de            User1:passwd
    smtpmail.t-online.de            User2:passwd
    smtpmail.t-online.de            User3:passwd
    smtp.web.de                     User4:passwd
    
    wenn ich dass dann mache:
    Code:
    postmap smtp_auth
    postmap: warning: smtp_auth.db: duplicate entry: "smtpmail.t-online.de"
    postmap: warning: smtp_auth.db: duplicate entry: "smtpmail.t-online.de"
    
    
    Ich kann die email auch verschicken, allerdings wird mir immer der User1 als absender dargestellt.

    Meine Frage: "Wie bekomme ich es hin, dass in der smtp_auth mehere benutzer dirn stehen für einen e-mail-provider? Und wo kann ich es einstellen, dass er mir dann auch die externe e-mail-adresse richtig zu ordnet?"

    Gruss tiptel170
     
  2. foexle

    foexle Kaiser

    Dabei seit:
    02.05.2007
    Beiträge:
    1.104
    Zustimmungen:
    0
    Ort:
    Saarbrücken
    verstehe ich nicht deine frage ....
    soll das eine weiterleitung zu einem anderen EMail-Konto werden ?
    Oder eine Mailingliste?
    Oder willst du einfach einen anderen Relayhost nutzen ?
     
  3. rikola

    rikola Foren Gott

    Dabei seit:
    23.08.2005
    Beiträge:
    2.133
    Zustimmungen:
    0
    Hilft vielleicht diese Seite weiter? Sie schlaegt vor, pro user einen Eintrag ein relayhost_map anzulegen, so dass sich ein Eintrag in sasl_password darauf beziehen kann.
     
  4. #4 T-One, 05.05.2009
    Zuletzt bearbeitet: 05.05.2009
    T-One

    T-One Routinier

    Dabei seit:
    14.10.2008
    Beiträge:
    493
    Zustimmungen:
    7
    Ort:
    Österreich
    Du brauchst nur einen User für die Smarthost-Einträge pro Provider, meherere User für einen Smarthost sind vollkommen überflüssig.
    Deine E-Mail-Addy gibt der Postfix so oder so mit, da macht dir der SMTP-Server vom Provider nichts mehr dran.

    http://tools.ietf.org/html/rfc2821
    Macht das ganze vielleicht etwas deutlicher
     
  5. #5 tiptel170, 06.05.2009
    Zuletzt bearbeitet: 06.05.2009
    tiptel170

    tiptel170 Tripel-As

    Dabei seit:
    20.07.2008
    Beiträge:
    161
    Zustimmungen:
    0
    Danke für den link. Dies hilft mir nicht weiter.

    Also nochmal:

    user1@xxx.xxx.ddd => hallo@t-online.de
    user2@xxx.xxx.ddd => mhallo@t-online.de
    user3@xxx.xxx.ddd => hhallo@web.de

    Mit dieser einstellung, habe ich folgende.

    In der smtp_auth steht für jeden benutzer die login daten. Bei web.de funktioniert dies.

    smtp_auth:
    Code:
    smtpmail.t-online.de            hallo:geheim
    smtpmail.t-online.de            mhallo:sgeheim
    smtp.web.de                     hhallo:ssgheim
    
    Wenn ich die datei mit postmap mappe, bekomme ich immer die fehlermeldung - wie am anfang beschrieben!

    Wenn ich vom user2 eine mail verschicke, dann zeigt mir der client die externe mail-adresse vom user1 an (hallo@t-online.de).

    In der senderrelay:

    Code:
    @web.de                 [smtp.web.de]
    @t-online.de             [smtpmail.t-online.de]
    
    Und in der main.cf habe ich dies eingestellt:

    Code:
    smtp_sender_dependent_authentication = yes
    
    Vielleicht hilft dies weiter.
    .
    .
    .
    EDIT (autom. Beitragszusammenführung) :
    .

    Habe die lösung:

    in der senderrelay sollten folgende einträge drin stehen:
    Code:
    web.de                 [smtp.web.de]
    hallo@t-online.de                     [smtpmail.t-online.de]
    mhallo@t-online.de       [smtpmail.t-online.de]
    
    Bei web.de darf nur web.de drin stehen, sonst funktioniert versand nicht, wird als "opnenrelay" erkannt.
    t-online, muss der benutzername(at)t-online.de drinstehen, sonst funktioniert die einzelne authenfication nicht. Siehe die smtp_auth:

    smtp_auth:
    Code:
    hallo@t-online.de             hallo:geheim
    mhallo@t-online.de               mhallo:sgeheim
    smtp.web.de                      hhallo:ssgheim
    
    Bei web.de darf nur smtp.web.de stehen! Bei t-online nur benutzername(at)t-online.de
    So authenfiziert sich postfix für jeden benutzer von intern nach extern.

    Gruss tiptel170 und danke
     
Thema:

Postfix problem

Die Seite wird geladen...

Postfix problem - Ähnliche Themen

  1. dovecot und postfix Konfiguration Problem

    dovecot und postfix Konfiguration Problem: Hallo, ich bekomme es einfacht hin, Dovecot und postfix richtig zu konfigurieren, damit die beiden zusammenarbeiten. Meine Configs sehen aktuell...
  2. Postfix: Problem CA-Zertifikat zu konfigurieren

    Postfix: Problem CA-Zertifikat zu konfigurieren: [gelöst] Postfix: Problem CA-Zertifikat zu konfigurieren Hallo zusammen, habe auf meinem Server ein von Geotrust signiertes Zertifikat...
  3. postfix spam problem

    postfix spam problem: Hallo, habe ein massives Problem mit postfix. Über einen Debian 5.0 Server werden sporadisch, noch nicht massiv, Spammails versendet. Ich soll...
  4. Postfix-Problem

    Postfix-Problem: [Gelöst] Postfix-Problem Guten abend leute, vielleicht hat da jemand eine idee. Und zwar habe ich mir eine SDSL-Standleitung schalten lassen...
  5. Postfix, Dovecot Mail-Directory Problem

    Postfix, Dovecot Mail-Directory Problem: Hallo, ich hab folgendes Problem: Ich hab einen Mailserver aufgesetzt (Dovecot & Postfix), er läuft zumindest mal (ob pop3/imap funktioniert,...