mdadm - kann Raid nicht wiederherstellen

Diskutiere mdadm - kann Raid nicht wiederherstellen im Linux OS Forum im Bereich Linux/Unix Allgemein; Hallo, ich bin gerade dabei, von SuSE aud gentoo umzustellen. Ich kann aus irgendeinem Grund mein RAID 5 nicht wieder erstellen. Da die nods md*...

  1. #1 netbui, 01.07.2006
    Zuletzt bearbeitet: 01.07.2006
    netbui

    netbui Eroberer

    Dabei seit:
    08.06.2006
    Beiträge:
    61
    Zustimmungen:
    0
    Hallo,

    ich bin gerade dabei, von SuSE aud gentoo umzustellen. Ich kann aus irgendeinem Grund mein RAID 5 nicht wieder erstellen.
    Da die nods md* in /dev gefehlt haben, habe ich versucht sie sowohl mit:
    Code:
    fs ~ # mknod /dev/md0 b 9 1
    fs ~ # mknod /dev/md1 b 9 1
    fs ~ # mknod /dev/md2 b 9 1
    fs ~ # mknod /dev/md3 b 9 1
    fs ~ # mknod /dev/md4 b 9 1
    fs ~ # mknod /dev/md5 b 9 1
    als auch mit
    Code:
    MKNOD md
    anzulegen. Ein ls -al /dev/md* bringt:
    Code:
    brw-rw---- 1 root disk 9,  0 Jul  1 07:46 /dev/md0
    brw-rw---- 1 root disk 9,  1 Jul  1 07:46 /dev/md1
    brw-rw---- 1 root disk 9, 10 Jul  1 07:46 /dev/md10
    brw-rw---- 1 root disk 9, 11 Jul  1 07:46 /dev/md11
    brw-rw---- 1 root disk 9, 12 Jul  1 07:46 /dev/md12
    brw-rw---- 1 root disk 9, 13 Jul  1 07:46 /dev/md13
    brw-rw---- 1 root disk 9, 14 Jul  1 07:46 /dev/md14
    brw-rw---- 1 root disk 9, 15 Jul  1 07:46 /dev/md15
    brw-rw---- 1 root disk 9,  2 Jul  1 07:46 /dev/md2
    brw-rw---- 1 root disk 9,  3 Jul  1 07:46 /dev/md3
    brw-rw---- 1 root disk 9,  4 Jul  1 07:46 /dev/md4
    brw-rw---- 1 root disk 9,  5 Jul  1 07:46 /dev/md5
    brw-rw---- 1 root disk 9,  6 Jul  1 07:46 /dev/md6
    brw-rw---- 1 root disk 9,  7 Jul  1 07:46 /dev/md7
    brw-rw---- 1 root disk 9,  8 Jul  1 07:46 /dev/md8
    brw-rw---- 1 root disk 9,  9 Jul  1 07:46 /dev/md9
    die Gerätedateien sind also da. Wenn ich aber versuche, das Raid zu Reassembeln, erhalte ich die Fehlermeldung:
    Code:
    fs / # mdadm -A /dev/md0 /dev/hda1 /dev/hdb1 /dev/hdc1 /dev/hdd1
    mdadm: error opening /dev/md0: No such device or address
    Mit der Gentoo 2006.0 Livecd habe ich das Raid mit dem o.g. Befehl starten können.
    Hat jemand vielleicht eine Idee, was ich falsch mache?
    Code:
    fs dev # mdadm --examine /dev/hda1 /dev/hdb1 /dev/hdc1 /dev/hdd1
    /dev/hda1:
              Magic : a92b4efc
            Version : 00.90.01
               UUID : c80f9a51:148aae32:a6b9b155:ebd0928c
      Creation Time : Thu Nov  3 20:56:43 2005
         Raid Level : raid5
        Device Size : 156280192 (149.04 GiB 160.03 GB)
         Array Size : 312560384 (298.08 GiB 320.06 GB)
       Raid Devices : 3
      Total Devices : 4
    Preferred Minor : 0
    
        Update Time : Mon Jun 26 08:01:51 2006
              State : clean
     Active Devices : 3
    Working Devices : 4
     Failed Devices : 0
      Spare Devices : 1
           Checksum : aa74ff9b - correct
             Events : 0.6600631
    
             Layout : left-symmetric
         Chunk Size : 64K
    
          Number   Major   Minor   RaidDevice State
    this     3       3        1        3      spare   /dev/hda1
    
       0     0      22       65        0      active sync   /dev/hdd1
       1     1       3       65        1      active sync   /dev/hdb1
       2     2      22        1        2      active sync   /dev/hdc1
       3     3       3        1        3      spare   /dev/hda1
    .
    .
    .
    .
    
    
    ___________________________________


    Nachtrag: ich habe noch ein Bischen rumgeggoglet und gelesen, dass man den Rechner - UNIX untüpisch - nach dem anlegen der Devicefiles rebooten muss.

    Das Problem: nach dem Reboot sind die md* Gerätedateien verschwunden!
     
  2. rikola

    rikola Foren Gott

    Dabei seit:
    23.08.2005
    Beiträge:
    2.133
    Zustimmungen:
    0
    Das mit dem Neustart klingt mir etwas seltsam, aber naja.
    Hast Du sichergestellt, dass das md-Kernelmodul geladen ist?
     
  3. mcas

    mcas Routinier

    Dabei seit:
    29.12.2005
    Beiträge:
    398
    Zustimmungen:
    0
  4. theton

    theton Bitmuncher

    Dabei seit:
    27.05.2004
    Beiträge:
    4.820
    Zustimmungen:
    0
    Ort:
    Berlin, Germany
    Wenn die Devices nicht erkannt werden, sind normalerweise die md-LKM nicht geladen, denn erst durch diese werden die Platten an die md*-Devices gebunden. Ausserdem sollte natuerlich mdadm laufen.
     
Thema:

mdadm - kann Raid nicht wiederherstellen

Die Seite wird geladen...

mdadm - kann Raid nicht wiederherstellen - Ähnliche Themen

  1. Software-Raid (mdadm) - Festplatte ersetzen

    Software-Raid (mdadm) - Festplatte ersetzen: Hallo, so nach längerer Zeit lass ich mich hier auch mal wieder blicken... Also vorab: Momentan verwende ich in meinem Debian-Homeserver den...
  2. mdadm Problem (Raid1 von drei auf zwei Platten reduziert)

    mdadm Problem (Raid1 von drei auf zwei Platten reduziert): Hallo, ich habe ein mdadm Raid 1 Problem. Bei der Installation habe ich ein Raid1 mit drei 500GB Festplatten aufgebaut. Nun habe ich eine davon...
  3. mdadm: cannot open device: No such file or directory

    mdadm: cannot open device: No such file or directory: Hallo, bin grad etwas am verzweifeln. Meine alte Boot-Platte mit debian hatte mehr und mehr schreib-lesen-fehler. Deshalb neue Platte rein,...
  4. [TIPP] Grub mit mdadm und uuid booten lassen

    [TIPP] Grub mit mdadm und uuid booten lassen: Hallo Gemeinde, da es mir ziemlich vor einem Jahr bereits passiert ist und heute wieder passiert wäre (hätte ich mir nicht extra einen gelben...
  5. mdadm Problem

    mdadm Problem: Hallo, ich versuche in seiner XEN Domain ein mdadm Raid5 zu erstellen. Dazu habe ich 3 Identische Festplatte in die Domain durchgereicht, eine...