LICQ - QT-GUI Problem

N

Newman

the newman
Hi.

Habe folgendes Problem. Habe gerade LICQ 1.2.7 installiert.
Jetzt sagt er mir ich soll den QT-Plugin installieren (qt-gui).

../licq-1.2.7/plugins/qt-gui # ./configure

checking for QT includes...
configure: error:

I can't find the QT header files.

Install the QT development package, or if you have them installed, override
this check with the --with-qt-includes argument, and I'll take your word for
it.


Jetzt hab ich verschiedene QT-Pakete nachinstalliert, aber der erzaehlt mir immer das selbe.

Woran koennte das liegen ?
 
erathosthenes

erathosthenes

my love
gast du auch die qt-devel pakete installiert,
wenn das alles ix hilft qt ausm netz ziehen, kompilieren und installieren, so hab ich es damals irgendwie gemacht, aber nicht bei licq sondern wegen k3b.
 
N

Newman

the newman
Ich habe alles versucht. Die Installation hat ziemlich lange gedauert. Wuerde das ungern wiederholen.
Unter (KDE)-System habe ich auch QT-Einstellungen. Scheint doch zu laufen ?

qt-devel habe ich auch installiert.

Sonst noch Vorschläge vorhanden ?
 
erathosthenes

erathosthenes

my love
Übergib an das configure script den pfad zu deinen qt header files.
./configure --qith-qt-includes=/usr/local/qt/include
wäre der pfad bei mir, schau mal wo du deine header files hast und paß den pfad dann an.
 
N

Newman

the newman
checking for QT libraries... yes, lib: -lqt-mt in /usr/lib/qt3/lib
checking for QT >= 2.1... no
configure: error:
Sorry, but you need QT version 2.1 or higher to compile the Qt gui plugin.


Der will mir erzaehlen das waere eine zu alte Version. Die erste Reihe sagt doch schon das er sich von QT3 die Headerdateien holt. Das sagt er mir auch wenn ich auf qt-devel delegiere.
 
erathosthenes

erathosthenes

my love
Sehr hartnäckig, das licq :).
Trag mal in deiner bashrc folgendes ein:
QTDIR=/usr/local/qt (bzw. wo dein qt dir halt ist)
und dann bei export schreibst einfach QTDIR noch mit rein.
Dann MUSS es einfach gehen ;).
 
N

Newman

the newman
hm, leider auch nicht. hab das profil umgestellt.

gibts nicht noch vernuenftige andere clients fuer icq ?
 
erathosthenes

erathosthenes

my love
Geben tut es viele, hier im forum gibt es da irgendwo einen thread zu.
Also sim ist ne empfehlung, hat aber bei mir nie funktioniert, wegen nem speicherzugriffsfehler, obwohl die windows variante aber ok gewesen ist, und andere hab ich noch nicht getestet.
Aber weshalb dein qt nicht gefunden wird, ist echt komisch.
qt ist installiert und QTDIR ist gesetzt und exportiert.
Aber ich hab grade gelesen man soll nicht /usr/local/qt3 sondern /usr/lib/qt3 als QTDIR setzen, halt "export QTDIR=/usr/lib/qt3".
Kannst es ja nochmal damit testen.
 
N

Newman

the newman
Hatte ich sowieso. :)

Danke dir, fuer deine Hilfe!
 
devilz

devilz

Pro*phet
Also ich würde dir echt SIM ans Herz legen wenn du nicht weiter kommst :)
 

Ähnliche Themen

configure schlägt bei X fehl

Zugriff Ubuntu 16.04. auf Freigabe 18.04. LTS nicht möglich

JBidWatcher: Problem bei loading Auctions in Verbindung mit mySQL

Samba 4 Gast Zugang unter Ubuntu funktioniert nicht

NagiosGrapher 1.7.1 funktioniert nicht

Oben