keine Soundtreiber für 64bit?

Diskutiere keine Soundtreiber für 64bit? im Gentoo Forum im Bereich Linux Distributionen; hab mir gerade die soundtreiber für mein onBoardSound von der Asus-Seite geladen(für A8N-SLI premium). Mein soundchip wird nicht automatisch...

  1. #1 GendoIkari, 15.01.2007
    GendoIkari

    GendoIkari Routinier

    Dabei seit:
    04.12.2006
    Beiträge:
    336
    Zustimmungen:
    0
    Ort:
    Dort wo die Sonne aufgeht...
    hab mir gerade die soundtreiber für mein onBoardSound von der Asus-Seite geladen(für A8N-SLI premium). Mein soundchip wird nicht automatisch erkannt.
    Ich bin nach der turbolinux.txt vorgegangen ,nach dem ich mit der readme.txt keinen erfolg hatte.
    ####################### turbolinux.txt ########################
    Unresolved compiled problem with TurboLinux 10
    -------------------------------

    1. rebuild kernel:
    a. move to /usr/src/linux.
    a. run "make xconfig".
    b. Turn on all items in the Loadable module support.
    c. make clean; make; make modules; make modules_install

    2. compile the ALSA driver:
    a. copy core.h to /usr/src/linux/include/sound.
    b. upcompress the ALSA driver in the /usr/src/linux.
    c. move to /usr/src/linux/alsa-driver-1.0.4.
    d. make clean; ./configure; make; make install
    e. ./snddevices

    3. edit /etc/modules.conf
    Please refer the modules.txt.

    4. reboot system or run "modprobe snd-atiixp".

    ps: If possible, use the fully install the TurboLinux 10.
    ########################################################
    bin bis 2. d. make gekommen


    nach make kam dass:
    ####################### consolen ausgabe ####################
    make dep
    make[1]: Entering directory `/usr/src/linux-2.6.19-gentoo-r1/alsa-driver-1.0.4'
    make[2]: Entering directory `/usr/src/linux-2.6.19-gentoo-r1/alsa-driver-1.0.4/acore'
    make -C ioctl32 fastdep
    make[3]: Entering directory `/usr/src/linux-2.6.19-gentoo-r1/alsa-driver-1.0.4/acore/ioctl32'
    /usr/src/linux-2.4.18-3/alsa-driver-1.0.4/include/sndversions.h was not updated
    make[3]: Leaving directory `/usr/src/linux-2.6.19-gentoo-r1/alsa-driver-1.0.4/acore/ioctl32'
    make -C oss fastdep
    make[3]: Entering directory `/usr/src/linux-2.6.19-gentoo-r1/alsa-driver-1.0.4/acore/oss'
    /usr/src/linux-2.4.18-3/alsa-driver-1.0.4/include/sndversions.h was not updated
    gcc -D__KERNEL__ -DMODULE=1 -I/usr/src/linux-2.4.18-3/alsa-driver-1.0.4/include -I/lib/modules/2.4.18-3/build/include -O2 -mpreferred-stack-boundary=2 -march=i686 -DLINUX -Wall -Wstrict-prototypes -fomit-frame-pointer -Wno-trigraphs -O2 -fno-strict-aliasing -fno-common -pipe -DALSA_BUILD -nostdinc -iwithprefix include -I/usr/src/linux-2.4.18-3/alsa-driver-1.0.4/alsa-kernel/core/oss -fno-omit-frame-pointer -E -D__GENKSYMS__ mixer_oss.c
    | /sbin/genksyms -k 2.4.18 > /usr/src/linux-2.4.18-3/alsa-driver-1.0.4/include/modules/-usr-src-linux-2.6.19-gentoo-r1-alsa-driver-1.0.4-acore-oss__mixer_oss.ver.tmp
    mixer_oss.c:0: error: CPU you selected does not support x86-64 instruction set
    mixer_oss.c:0: error: CPU you selected does not support x86-64 instruction set
    mixer_oss.c:0: error: -mpreferred-stack-boundary=2 is not between 4 and 12
    mv /usr/src/linux-2.4.18-3/alsa-driver-1.0.4/include/modules/-usr-src-linux-2.6.19-gentoo-r1-alsa-driver-1.0.4-acore-oss__mixer_oss.ver.tmp /usr/src/linux-2.4.18-3/alsa-driver-1.0.4/include/modules/-usr-src-linux-2.6.19-gentoo-r1-alsa-driver-1.0.4-acore-oss__mixer_oss.ver
    gcc -M -D__KERNEL__ -D__isapnp_now__ -DMODULE=1 -I/usr/src/linux-2.4.18-3/alsa-driver-1.0.4/include -I/lib/modules/2.4.18-3/build/include -O2 -mpreferred-stack-boundary=2 -march=i686 -DLINUX -Wall -Wstrict-prototypes -fomit-frame-pointer -Wno-trigraphs -O2 -fno-strict-aliasing -fno-common -pipe -DALSA_BUILD -nostdinc -iwithprefix include -I/usr/src/linux-2.4.18-3/alsa-driver-1.0.4/alsa-kernel/core/oss -fno-omit-frame-pointer mixer_oss.c pcm_oss.c pcm_plugin.c io.c copy.c linear.c mulaw.c route.c rate.c > .depend
    mixer_oss.c:0: error: CPU you selected does not support x86-64 instruction set
    mixer_oss.c:0: error: CPU you selected does not support x86-64 instruction set
    mixer_oss.c:0: error: -mpreferred-stack-boundary=2 is not between 4 and 12
    pcm_oss.c:0: error: CPU you selected does not support x86-64 instruction set
    pcm_oss.c:0: error: CPU you selected does not support x86-64 instruction set
    pcm_oss.c:0: error: -mpreferred-stack-boundary=2 is not between 4 and 12
    pcm_plugin.c:0: error: CPU you selected does not support x86-64 instruction set
    pcm_plugin.c:0: error: CPU you selected does not support x86-64 instruction set
    pcm_plugin.c:0: error: -mpreferred-stack-boundary=2 is not between 4 and 12
    io.c:0: error: CPU you selected does not support x86-64 instruction set
    io.c:0: error: CPU you selected does not support x86-64 instruction set
    io.c:0: error: -mpreferred-stack-boundary=2 is not between 4 and 12
    copy.c:0: error: CPU you selected does not support x86-64 instruction set
    copy.c:0: error: CPU you selected does not support x86-64 instruction set
    copy.c:0: error: -mpreferred-stack-boundary=2 is not between 4 and 12
    linear.c:0: error: CPU you selected does not support x86-64 instruction set
    linear.c:0: error: CPU you selected does not support x86-64 instruction set
    linear.c:0: error: -mpreferred-stack-boundary=2 is not between 4 and 12
    mulaw.c:0: error: CPU you selected does not support x86-64 instruction set
    mulaw.c:0: error: CPU you selected does not support x86-64 instruction set
    mulaw.c:0: error: -mpreferred-stack-boundary=2 is not between 4 and 12
    route.c:0: error: CPU you selected does not support x86-64 instruction set
    route.c:0: error: CPU you selected does not support x86-64 instruction set
    route.c:0: error: -mpreferred-stack-boundary=2 is not between 4 and 12
    rate.c:0: error: CPU you selected does not support x86-64 instruction set
    rate.c:0: error: CPU you selected does not support x86-64 instruction set
    rate.c:0: error: -mpreferred-stack-boundary=2 is not between 4 and 12
    make[3]: *** [fastdep] Error 1
    make[3]: Leaving directory `/usr/src/linux-2.6.19-gentoo-r1/alsa-driver-1.0.4/acore/oss'
    make[2]: *** [_sfdep_oss] Error 2
    make[2]: Leaving directory `/usr/src/linux-2.6.19-gentoo-r1/alsa-driver-1.0.4/acore'
    make[1]: *** [dep] Error 1
    make[1]: Leaving directory `/usr/src/linux-2.6.19-gentoo-r1/alsa-driver-1.0.4'
    make: *** [include/sndversions.h] Error 2
    #########################################################

    gibt's auch soundtreiber für 64bit? Auf der Asus Seite jedenfalls hab ich keinen gefunden. Und über autodetect findet mein system auch nix. ;(
     
  2. Anzeige

    Anzeige

    Wenn du mehr über Linux erfahren möchtest, dann solltest du dir mal folgende Shellkommandos anschauen.


    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. rikola

    rikola Foren Gott

    Dabei seit:
    23.08.2005
    Beiträge:
    2.133
    Zustimmungen:
    0
    Ich habe keine Ahnung von Gentoo, doch die Fehler, die Du hast, ruehren nur von der Option '-march=i686': Der i686 ist kein 64bit-Rechner. Korrigiere also diese Option (nocona, athlon64...) und probiere es noch mal.
     
  4. #3 GendoIkari, 15.01.2007
    GendoIkari

    GendoIkari Routinier

    Dabei seit:
    04.12.2006
    Beiträge:
    336
    Zustimmungen:
    0
    Ort:
    Dort wo die Sonne aufgeht...
    muss ich da alle dateien umschreiben oder "make -march=athlon64" eingeben?
     
  5. #4 Keruskerfürst, 15.01.2007
    Keruskerfürst

    Keruskerfürst Kaiser

    Dabei seit:
    12.02.2006
    Beiträge:
    1.366
    Zustimmungen:
    0
    lspci -v posten


    1. AMD64 Installationscd verwenden.
    2. Soundtreiber ist im Kernel enthalten
    3. Durch Konfiguration des Kernels kann der Sound aktiviert werden. Auf der Gentoo Seite gibt es dazu Dokumentation: http://www.gentoo.org/doc/en/alsa-guide.xml
     
  6. #5 GendoIkari, 19.01.2007
    GendoIkari

    GendoIkari Routinier

    Dabei seit:
    04.12.2006
    Beiträge:
    336
    Zustimmungen:
    0
    Ort:
    Dort wo die Sonne aufgeht...
    hab jetzt die nvidia treiber emerged und den alsa mixer. der erkennt: card: NVidia CK804; chip: Realtek ALC850 rev 0;
    der KDE Mixer erkennt aber nix. Wenn ich unter dem" control center">"sound & multimedia">"sound system" schau kommt nur die meldung "unable to start the sound server to retrieve possible sound I/O methodes" "Only automatic detection will be available"

    nun ja, was schließe ich daraus? die treiber sind jetzt drauf, bloß der sound server startet aus unbekannten gründen nicht. wie grig ich raus woran das liegt?
    ?(
     
  7. #6 Keruskerfürst, 19.01.2007
    Keruskerfürst

    Keruskerfürst Kaiser

    Dabei seit:
    12.02.2006
    Beiträge:
    1.366
    Zustimmungen:
    0
    Nimm doch einfach die Treiber, die im Kernel enthalten sind.
     
  8. #7 GendoIkari, 19.01.2007
    GendoIkari

    GendoIkari Routinier

    Dabei seit:
    04.12.2006
    Beiträge:
    336
    Zustimmungen:
    0
    Ort:
    Dort wo die Sonne aufgeht...
    soll ich da die advanced oder die oss abteilung nehmen? finden tu ich nämlich in beden nix mit: NVidia CK804 oder Realtek ALC850 rev 0
     
  9. #8 Keruskerfürst, 19.01.2007
    Keruskerfürst

    Keruskerfürst Kaiser

    Dabei seit:
    12.02.2006
    Beiträge:
    1.366
    Zustimmungen:
    0
    Dieser ist unter ALSA zu finden.
    Der Treiber ist: Intel/Nvidia/Via AC´97 sound.
     
  10. #9 GendoIkari, 19.01.2007
    GendoIkari

    GendoIkari Routinier

    Dabei seit:
    04.12.2006
    Beiträge:
    336
    Zustimmungen:
    0
    Ort:
    Dort wo die Sonne aufgeht...
    so bald ich was in: divice drivers>sound>advanced> pci divices einstell kommt nach "make && make modules_install"
    ############################################################
    scripts/kconfig/conf -s arch/x86_64/Kconfig
    CHK include/linux/version.h
    CHK include/linux/utsrelease.h
    CHK include/linux/compile.h
    GZIP kernel/config_data.gz
    IKCFG kernel/config_data.h
    CC kernel/configs.o
    LD kernel/built-in.o
    CC sound/core/sound.o
    sound/core/sound.c: In function 'snd_lookup_minor_data':
    sound/core/sound.c:122: error: dereferencing pointer to incomplete type
    sound/core/sound.c:123: error: dereferencing pointer to incomplete type
    sound/core/sound.c: In function 'snd_open':
    sound/core/sound.c:163: error: dereferencing pointer to incomplete type
    sound/core/sound.c:163: error: dereferencing pointer to incomplete type
    sound/core/sound.c:163: error: dereferencing pointer to incomplete type
    sound/core/sound.c: In function 'snd_kernel_minor':
    sound/core/sound.c:207: error: dereferencing pointer to incomplete type
    sound/core/sound.c:214: error: dereferencing pointer to incomplete type
    sound/core/sound.c: At top level:
    sound/core/sound.c:241: error: conflicting types for 'snd_register_device'
    include/sound/core.h:229: error: previous declaration of 'snd_register_device' was here
    sound/core/sound.c: In function 'snd_register_device':
    sound/core/sound.c:247: error: dereferencing pointer to incomplete type
    sound/core/sound.c:250: error: dereferencing pointer to incomplete type
    sound/core/sound.c:251: error: dereferencing pointer to incomplete type
    sound/core/sound.c:251: error: dereferencing pointer to incomplete type
    sound/core/sound.c:252: error: dereferencing pointer to incomplete type
    sound/core/sound.c:253: error: dereferencing pointer to incomplete type
    sound/core/sound.c:254: error: dereferencing pointer to incomplete type
    sound/core/sound.c:270: error: dereferencing pointer to incomplete type
    sound/core/sound.c:271: error: dereferencing pointer to incomplete type
    sound/core/sound.c:274: error: dereferencing pointer to incomplete type
    sound/core/sound.c:275: error: dereferencing pointer to incomplete type
    sound/core/sound.c: At top level:
    sound/core/sound.c:281: error: conflicting types for 'snd_register_device'
    include/sound/core.h:229: error: previous declaration of 'snd_register_device' was here
    sound/core/sound.c: In function 'find_snd_minor':
    sound/core/sound.c:291: error: dereferencing pointer to incomplete type
    sound/core/sound.c:294: error: dereferencing pointer to incomplete type
    sound/core/sound.c:295: error: dereferencing pointer to incomplete type
    sound/core/sound.c:296: error: dereferencing pointer to incomplete type
    sound/core/sound.c: At top level:
    sound/core/sound.c:313: error: conflicting types for 'snd_unregister_device'
    include/sound/core.h:230: error: previous declaration of 'snd_unregister_device' was here
    sound/core/sound.c:331: error: conflicting types for 'snd_unregister_device'
    include/sound/core.h:230: error: previous declaration of 'snd_unregister_device' was here
    sound/core/sound.c: In function 'snd_add_device_sysfs_file':
    sound/core/sound.c:341: error: dereferencing pointer to incomplete type
    sound/core/sound.c: In function 'snd_minor_info_read':
    sound/core/sound.c:388: error: dereferencing pointer to incomplete type
    sound/core/sound.c:389: error: dereferencing pointer to incomplete type
    sound/core/sound.c:391: error: dereferencing pointer to incomplete type
    sound/core/sound.c:391: error: dereferencing pointer to incomplete type
    sound/core/sound.c:392: error: dereferencing pointer to incomplete type
    sound/core/sound.c:395: error: dereferencing pointer to incomplete type
    sound/core/sound.c:396: error: dereferencing pointer to incomplete type
    sound/core/sound.c:399: error: dereferencing pointer to incomplete type
    make[2]: *** [sound/core/sound.o] Error 1
    make[1]: *** [sound/core] Error 2
    make: *** [sound] Error 2
    #########################################################
    muss ich die alsa-driver,mixer,tolls usw. wieder deinstallieren? damit das geht?
     
  11. #10 Keruskerfürst, 19.01.2007
    Keruskerfürst

    Keruskerfürst Kaiser

    Dabei seit:
    12.02.2006
    Beiträge:
    1.366
    Zustimmungen:
    0
    Installiere male den Kernelsource neu.
    emerge -av gentoo-sources.
     
  12. #11 GendoIkari, 19.01.2007
    Zuletzt bearbeitet: 19.01.2007
    GendoIkari

    GendoIkari Routinier

    Dabei seit:
    04.12.2006
    Beiträge:
    336
    Zustimmungen:
    0
    Ort:
    Dort wo die Sonne aufgeht...
    nach dem neustart konnte ich dann wieder die treiber im kernel einstellen.
    ich kann jetzt die lautstärke im kmixer und im alsamixer einstell, aber xine findet immer noch kein audio treiber. ich kann in amarok unter adio-ausgabe nur "xine" einstellen und im ausgabe-modul nur a"utomatische erkennung" oder "file" einstellen. mit letzterem kann ich nix anfangen. das einzige was sich wirklich geändert hat ist das ,wenn ich im mixer die lautstärke änder sich das durch ein knacken in meine lautsprechern bemerkbar macht ,also ist schon eine audio ausgabe vorhanden aber das programm weis nix davon ;)
     
  13. #12 GendoIkari, 20.01.2007
    GendoIkari

    GendoIkari Routinier

    Dabei seit:
    04.12.2006
    Beiträge:
    336
    Zustimmungen:
    0
    Ort:
    Dort wo die Sonne aufgeht...
    Ein stück weiter aber immer nochnicht am Ziel...
    Mit KMixer kann ich die Lautstärke regeln dort shet jetzt sogar meine soundkarte, aber eine veränderung des rauschens bem verstellen der lautstärke bringt mir das nix.
    Im Control Center kann ich im Sound-System> Hardware : OSS ,ALSA ;OSS mit Treats und Automaik auswählen.
    Es scheint als soweit alles da zu sein, aber beim start von amarok kommt immer noch "xine konnte keine audio treiber initalisieren"

    Wie mach ich demxine das begreiflich das da doch was da ist? Gib es alternativen zu xine?
    Ich habe mich auch nach alternativen zu xine umgeschaut und diese installiert, kann die aber in amarok als audio ausgabe nicht auswählen. und xine findet mitAudio Module:"auto erkennungeinstellung" keine lautsprecher die man auswählen könnte. ich hab langsam keine ideen mehr was ich noch machen könnte. :(
     
Thema:

keine Soundtreiber für 64bit?

Die Seite wird geladen...

keine Soundtreiber für 64bit? - Ähnliche Themen

  1. Samba keine rechte auf Überordner, aber auf Unterordner

    Samba keine rechte auf Überordner, aber auf Unterordner: Hi, hoffe ich bin hier richtig :-) Ich spiele hier gerade etwas mit Samba Active Directory herrum um eventuell den Windows AD Server damit zu...
  2. Keine Anmeldung bei phpmyadmin möglich!

    Keine Anmeldung bei phpmyadmin möglich!: Hallo, ich habe "LAMP PHP V5.6.0 auf meinem Linux Ubuntu Server 18.04. LTS gemacht. Habe alles fertig! Ich habe nun die Anmeldeseite von...
  3. Win 10 1803 und alte Samba Versionen: EXE von Share startet, aber keine Netzwerkverbindungen

    Win 10 1803 und alte Samba Versionen: EXE von Share startet, aber keine Netzwerkverbindungen: Seit Windows 10 1803 habe ich folgenden Effekt auf mehreren PCs beobachtet: EXE Dateien lassen sich wie gewohnt von den Shares starten (am besten...
  4. Dell D620 bootet keine Installation

    Dell D620 bootet keine Installation: Hallo zusammen, ich versuche seit einigen Tagen auf meinen alten Dell D620 ein 32Bit Linux zu installieren.(Prozessor bedingt) Ich würde gern mit...
  5. Samba als Fileserver keine Berechtigung auf Unterordner

    Samba als Fileserver keine Berechtigung auf Unterordner: Hallo! Leider bin ich kein Spezialist unter Linux oder Samba. Ich muss hier einen alten Linux Samba Server als Fileserver für einen neuen Windows...
  1. Diese Seite verwendet Cookies um Inhalte zu personalisieren. Außerdem werden auch Cookies von Diensten Dritter gesetzt. Mit dem weiteren Aufenthalt akzeptierst du diesen Einsatz von Cookies.
    Information ausblenden