KDE startet nicht mehr

softkick

softkick

Jungspund
Hallo zusammen,

ich quäle mich mit einer Redhat advanced server 2.1 installation rum. Hab zu diesem OS schon ein Posting losgelassen und keine Antwort gekriegt. Nun mein zweites Problem:

Nach der Redhat as 2.1 installation startete kde wunderbar. Danach habe ich auf der konsole das netzwerk eingerichtet und auf einmal beim erneuten eingeben von startx kommt ein grauer Bildschirm und ein Maus-Kreuz und nichts geht mehr. Ich muss dann den X-Server mit Ctrl-ALT-Backslash killen um wieder auf die Konsole zu gelangen.

hat jemand eine idee wie ich kde wieder zum arbeiten überrede und vor allem warum das passierte. Ich habe wirklich nur die Netzwerkkarte konfiguriert (hostnamen, ip-adresse, gateway ) und auf einmal funktionierte kde nicht mehr. ?(
 
D

damager

Moderator
fehlermeldungen?
/var/log/messages ?
/var/log/XFree86.0.0.log ?

ausgabe von "dmesg" irgend etwas komisches?
evtl. X-Server neu einstellen ...(brechstange)
 
chb

chb

Steirer
hmm die Brachialmethode könnte sein einfach ~/.kde zu löschen ...
 
D

damager

Moderator
ob sich was tut wenn er "startx kde" eingibt?
der x-server scheint ja zu funtzen nur er startet wohl keine WM.

vieleicht auch einfach mal KDM starten ...der startet doch x-server und wm ...imho.
 
softkick

softkick

Jungspund
...... genau so ist es DAMAGER

Hallo zusammen,

der Zustand ist immer noch der gleiche.

- in den eintsprechenden LOG - Files ist nichts zu finden.

DAMAGER hat jedoch recht! Anscheinend funktioniert das STARTX - Script nicht richtig, denn wenn ich kdm starte geht es. Also ist X wohl richtig konfiguriert - nur WM nicht.......

Wie könnte ich weiter vorgehen ??
 
D

damager

Moderator
im welchen runlevel startest du immer?
im runlevel 5 sollte per dafailt auch immer KDM (oder gdm, wdm, xdm..) gestaret werden.
sieht aber auch so aus also ob keine default WM definiert wurde!?!

bei redhat sollte das, glaube ich, unter /etc/sysconfig/desktop
zu definieren sein.

klappt das?

greetz
 
softkick

softkick

Jungspund
..... klar damager

...... wenn ich mit init 5 in Rlevel 5 wechsle startet kdm und alles ist klar.
aber ich starte im Rlevel 3 und will nur bei bedarf X starten.

in /etc/sysconfig/desktop steht KDE drin........

irgendwie hab ich das gefühl dass irgendeine umgebungsvariable fehlt.....
 
D

damager

Moderator
machs dir, fürs erste, einfach:
kopiere "startx" als backup weg z.b. als "startx_org".
und dann ein sym-link von kdm auf startx ...

klar, ist nur ein woraround bis du ne lösung findest ...
ach ja, was passiert bei "startx kde" ?
 
softkick

softkick

Jungspund
... startx kde bringt > bad command line option 'kde' - egal wie ich es schreibe
.. den symlink brauch ich net : kann ja gleich mit kdm starten......

was komisch ist: ich habe redhat as2.1 installiert, direkt nach der Installation funzte alles mit startX, dann habe ich nur die Netzwerkkarte installiert, den hostnamen und ie ip eingegeben und den Rechner neu gebootet - und nichts ging mehr mit startx.
 
B

Belkira

Routinier
softkick schrieb:
Nach der Redhat as 2.1 installation startete kde wunderbar.

Ich habe wirklich nur die Netzwerkkarte konfiguriert (hostnamen, ip-adresse, gateway ) und auf einmal funktionierte kde nicht mehr. ?(
Das klingt sehr danach, als ob Du die Konfiguration für das loopback network device gelöscht hast. Ist ein ziemlich häufiger Fehler. In den Netzwerkeinstellungen sollte localhost weiterhin 127.0.0.1 sein.
 
softkick

softkick

Jungspund
zu Belkira

..... nee : lsconfig zeigt lo und eth0 an !!

und in /etc/hosts ist <127.0.0.0 localhost localhost.localdomain> auch drin
 
softkick

softkick

Jungspund
... to barny

na bitte .........

# Do not remove the following line, or various programs
# that require network functionality will fail.
127.0.0.1 localhost.localdomain localhost
 
D

damager

Moderator
hmmm....was passiert wenn du den hostnamen wieder
auf den alten änderst ... funtzt es dann?
just for a test...

hab schon config-files gesehen die den hostnamen tragen ...aber in dem fall muss es ja nicht sein :-)
 
softkick

softkick

Jungspund
ZwischenStand

..... habe das Problem RedHat geschickt ..... ist ja zwar kein wichtiges Problem, aber meine Firma zahlt ja eine Jahrespauschale an RH - warum sollte ich das nicht ausnutzen. RH hat mir auch sofort zurückgemailt mit einem Shell - Script im Anhang, das eine File aus allen wichtigen logs erzeugt. Diese File hab ich dann den Jungs wieder zurückgesendet und warte nun auf deren Antwort.

Das Ergebniss werde ich - klaro - hier auch posten......

Vorerst mal Danke an Eu alle .... und schönes Weekend :bounce:
 
softkick

softkick

Jungspund
damager schrieb:
hmmm....was passiert wenn du den hostnamen wieder
auf den alten änderst ... funtzt es dann?
just for a test...

hab schon config-files gesehen die den hostnamen tragen ...aber in dem fall muss es ja nicht sein :-)


---------> natürlich steht die IP und der Hostname auch in der hosts Datei drin - Habe nur nicht die ganze Datei gepostet ,-)
 
D

damager

Moderator
missverständniss :-)
ich meine nicht das der hostname > in < einer datei drinnen steht ....sondern das es config-files gibt deren name auch den hostnamen enthält.
nur als beispiel: /etc/kde.softkick

verstehst du nun was ich meine?
 

Ähnliche Themen

KDE Startet nach NVIDIA-Treiberinstallation nicht mehr.

Linux startet nicht mehr mit KDE

KDE startet nicht mehr

Oben