iSight-Kamera&Ubuntu - Treiberprobleme auf MacBook Pro (Late 2006) (MA609LL)

daboss

daboss

Kaiser
Heyho (ich hoff mal, das passt hierher...),

ich bin zur Zeit dabei auf obigem MacBook Pro (15,4", 2,16GHz) zusätzlich zum MacOS Ubuntu 7.10 zu installieren.

Grundinstallation mit Gnome / Grafik / WLan / Sound (Micro noch ungetestet) funktioniert soweit ohne Probleme, allerdings beiß ich mir an der eingebauten iSight-Webcam bissl die Zähne aus.

lsusb gibt mir als dazu passende ID's 05ac:8501 aus.

Bisher vorgegangen bin ich nach diesem älteren Thread aus dem Ubuntuforum. Komischerweise zuerst nach dem Abschnitt "older Quickinstall" und erst später über das Script, das ganz oben beschrieben ist. Unter anderem mit Hilfe von den Built-in iSight Firmware Tools (Im Script aus dem Ubuntuforum selber musst ich die Zeile "cd against-revision-100" mit "....140" ersetzen.)

Das ganze, obwohl der LinuxUVC laut Liste eher fuer die ID 05ac:8502 gelistet ist. Sollte aber egal sein, was ich wo anders gelesen habe (find die Quelle allerdings nicht mehr, im Moment). Und ausserdem habe ich keine anderen "Versionen" gefunden. Alle Google-Ergenisse, die ich gefunden habe, liefen mit diesem Treiber und dieser Art der Installation.

Fehlermeldungen hatte es dabei keine gegeben, der Treiber ließ sich mit
Code:
sudo modprobe uvcvideo
laden.

Aber: Weder cheese, noch Ekiga, noch das aktuelle Skype, noch GStreamer erkennen die Kamera.

Irgendwie habe ich dann noch gemerkt, das es (auf dem Book) noch ein Modul isight...(war da noch ein Zusatz dabei? Ich weiß es gerade nicht) gibt. Nach einem entladen von uvccvideo und laden des isight-Moduls hat sich aber nicht wirklich was geändert. (Beide Module waren laut lsmod auch geladen)

Hat hier jemand obige Kamera erfolgreich am Laufen und kann mir sagen, was bei mir falsch läuft (oder auch sonst jemand ;) )?

Viele Grüße und Danke schonmal,
Alex

Wenn was an Informationen fehlt, reiche ichs gerne nach :)

(Wenn auch so Sachen wie dmesg-Ausgaben, genauer Kernel (2.6.22.14.21 generic, denk ich. (Also generic is klar, die genaue Nummer aber ausm Hinterkopf. Aktuellst-möglichen halt.)), genaueres lsusb, genaueres lsmod usw. erst am Abend nach er Arbeit ;) )
 
devilz

devilz

Pro*phet
Kannst mal das syslog posten, nachdem du die Treiber händisch geladen hast?
 
daboss

daboss

Kaiser
Okay, kann ich gerne machen. (Wenn auch, wie gesagt, leider erst gegen Abend ;) )

/Edit:

So, dann jetzt mal:
Code:
alex@bondi:~$ sudo modprobe uvcvideo 
[sudo] password for alex:
alex@bondi:~$ tail /var/log/syslog
(...)
Mar 17 17:57:42 bondi kernel: [  264.636000] usbcore: registered new interface driver uvcvideo
Mar 17 17:57:42 bondi kernel: [  264.636000] USB Video Class driver (v0.1.0)
alex@bondi:~$

Das oben genannte andere Modul isight_usb kann man (hier) vernachlaessigen. Gibt keine Ausgaben im Syslog...

Code:
alex@bondi:~$ sudo gst-launch-0.10 v4l2src ! video/x-raw-yuv,format=\(fourcc\)UYVY,width=640,height=480 ! ffmpegcolorspace ! ximagesink
[sudo] password for alex:
Pausiere Leitung ...
Leitung ist aktiv und brauch nicht gestartet werden ...
Setze Pipeline zum Abspielen...
New clock: GstSystemClock
Caught interrupt -- handling interrupt.
Interrupt: Setting pipeline to PAUSED ...
Execution ended after 4990432000 ns.
Pausiere Leitung ...
Setze Pipeline auf BEREIT...

alex@bondi:~$

spasseshalber mal mit sudo aufgerufen sorgt jetzt immerhin schonmal dafuer, das die gruene LED neben der Kamera leuchtet (mehr aber auch nicht), sudo ekiga findet jetzt auch eine Kamera, meldet aber, das diese das geforderte Format nicht unterstuetzt.
Ohne sudo existiert die Kamera aber weiterhin nicht.

/dev/video0 existiert auch, allerdings nur als root. (Ist das so richtig, oder passen hier die Rechte nicht?)

Code:
alex@bondi:~$ sudo ls -lah /dev/ | grep video
crw-rw----  1 root   video    81,   0 2008-03-17 17:53 video0

/Edit2
Okay, ich hab jetzt eine Gruppe video erstellt und und die relevanten Benutzer hinzugefuegt.

Ekiga erkennt jetzt die Build-In iSight. Und mit V4L2 als Plug-In seh ich mich jetzt :)

Allerdings bleibt cheese immer noch kommentarlos haengen. (Bzw. bleibt jetzt kommentarlos haengen. Vorher startete cheese ja mit der Meldung, keine Kamera zu finden).

Beim Skype Kameratest bleibt das Testbild auch schwarz...
 
Zuletzt bearbeitet:
Oben