dhcp, arpwatch, flip-flop, iPhone

L

lauchhammer

Grünschnabel
Moin alle zusammen,

ich habe da mal folgendes Problem. Ich habe einen Linuxrechner mit centos 6, der als DHCP-Server fungiert. Alles läuft soweit wunderbar. Ich habe zwei Rechner feste IPs über die dhcpd.conf vergeben, ein Rechner hat von sich aus eine feste IP und dann habe ich noch eine IP-Bereich für die WLAN-Geräte vergeben. Seit kurzem darf sich über WLAN ein weiteres iPhone einhängen und da beginnen die Probleme. Ich habe arpwatch am laufen, was mir eine e-mail sendet wenn etwas "schlimmes" passiert. Jetzt bekomme ich laufend mails, dass sich das iPhone wahllos IP-Adressen klaut (flip-flop). Selbst die Server-IP schnappt sich das Teil, meldet zumindest arpwatch. Die Verbindung zum Server wird aber nicht unterbrochen. Ich habe ein Programm zum Test gestartet, da werden laufend Daten ausgetauscht und da gab es keine Störungen.

Ich habe dem iPhone schone über die dhcpd.conf eine feste IP verpasst, bringt aber nichts. Das mit dem IP gewechsel würde mich ja nicht stören, so lange das Teil im range-Bereich bleiben würde, es sucht sich aber immer Adressen die schon vergeben sind. Das ganze dauert nur 1 bis ca 20 Sekunden, dann holt der beklaute Rechner sich die IP zurück und das iPhone geht wieder zu seiner festvergebenen IP.

Ich habe schon mit anderen Programmen das Netzwerk gescannt, da hatte das iPhone aber immer die richtige Adresse, allerdings, wenn der Diebstahl nur ne Sekunde dauert, ist es auch schwer den Zeitpunkt zum scannen zu erwischen.

Ja, wat läuft sonst noch. Router ist ne Fritzbox 7270 mit abgeschalteten dhcp. Auch hier taucht das iPhone nur mit der richtigen, der fest vergebenen IP auf. Über das WLAN hängen sich auch noch zwei weiter iPhone ins netz, bei denen kommen aber von arpwatch keine Meldungen, sie bleiben bei Ihren IPs.

Wo kann man hier ansetzen?

Grüße aus dem Norden

Harry

Code:
#
# DHCP Server Configuration file.
#   see /usr/share/doc/dhcp*/dhcpd.conf.sample
#   see 'man 5 dhcpd.conf'
#
authoritative;

default-lease-time 3600;  # 1 Stunde
max-lease-time 7200;      # 2 Stunden
option subnet-mask 255.255.255.0;
option domain-name "technik.nbg";
option domain-name-servers 192.168.1.2;
option routers 192.168.1.21;
ddns-update-style none;

# technik
group {
	subnet 192.168.1.0 netmask 255.255.255.0 {
		range 192.168.1.50 192.168.1.150;
		}
	# Zeichenstudio
	host studio {
		hardware ethernet 00:23:11:64:17:35;
		fixed-address 192.168.1.9;
		}
	# windowsxp
	host windowsxp {
		hardware ethernet 08:e0:27:B3:A5:32;
		fixed-address 192.168.1.253;
		}

	}
# Apple
group {
	# iPhone
	host iPhone {
		hardware ethernet bc:3c:ac:34:b2:cf;
		fixed-address 192.168.1.156;
		}
	}
 
L

lauchhammer

Grünschnabel
Oh, toll, da hat jemand genau die gleiche Frage gestellt wie ich ;-)

Ja, ich hatte gestern schon auf linuxforen.de gefragt, aber leider noch keine Antwort erhalten. Heute habe ich es hier versucht. Ich hoffe das gleiche Fragen in unterschiedliche Foren erlaubt sind :-|
 
M

marce

Kaiser
Klar sind sie erlaubt. Es wäre nur schön gewesen, wenn Du von Dir aus darauf hingewiesen hättest. Stichwort Multiposts / Crossposts / ...

Außerdem - gerade ist Ferien- und Urlaubszeit und da steigt die (eh nicht garantierte) Antwortzeit oftmals naturgemäß an, so daß es durchaus mal dauern kann, bis sich jemand ausreichend tief dem Problem widmen kann...
 
L

lauchhammer

Grünschnabel
Ja, eigentlich nichts, werde ich mal ausprobieren. Wenn ich das richtig verstanden habe, sagt diese Einstellung, wie lange ein Client die IP zugeordnet bekommt, bis er wieder eine neue Anforderung stellen muss. Das Problem ist, dass das iPhone sich eine IP außerhalb des dynamischen Bereich klaut. Das macht das Teil, oder wer auch immer ihm die IP verpasst, in unregelmäßigen Abständen. Und diese Abstände sind mit unter nur 1-2 Minuten. Da kann es mit dieser Einstellung eigentlich nichts zu tun haben.

Kann da irgend etwas an der dhcpd.conf nicht stimmen? Denn, eigentlich ist doch der dhcp-Server der jenige der die IPs vergibt. Nur ganz pöse Purschen halten sich nicht daran. Es sei denn, dem Gerät wurde in den Einstellungen eine fest IP eingetragen, was in diesem Fall nicht so ist.
 

Ähnliche Themen

Adressvergabe in anderen Subnets

Debian Routing Problem

Debian Gateway

OpenVPN - Server kann clients nicht erreichen.

dovecot und postfix Konfiguration Problem

Sucheingaben

arpwatch für fritzbox

Oben