Debian Router...problem IPTABLES

Diskutiere Debian Router...problem IPTABLES im Debian/Ubuntu/Knoppix Forum im Bereich Linux Distributionen; Hi, versuche gerade mein Debian Server als Router zu programmieren. Dachte, wenn ich den rest schaffe, dann schaff ich das auch noch. Nur jetzt...

  1. XET!C

    XET!C Tripel-As

    Dabei seit:
    02.08.2006
    Beiträge:
    191
    Zustimmungen:
    0
    Ort:
    Alfter / Bonn
    Hi,

    versuche gerade mein Debian Server als Router zu programmieren. Dachte, wenn ich den rest schaffe, dann schaff ich das auch noch. Nur jetzt lieg ich fest. Habe iptables installiert:
    Code:
    apt-get install iptables
    so alles super. Nur jetzt find ich nicht den pfad zu iptables...

    Bin so vorgegangen wie ich es hier vorgefunden habe:
    http://hilfe.exception.at/linux-router-howto.html
    Vielleicht kennt ich was besseres???
     
  2. Anzeige

    Anzeige

    Wenn du mehr über Linux erfahren möchtest, dann solltest du dir mal folgende Shellkommandos anschauen.


    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. MrBoe

    MrBoe Routinier

    Dabei seit:
    13.06.2006
    Beiträge:
    399
    Zustimmungen:
    0
    Ort:
    braunschweig/nds/de/world
    Steht doch in deiner Anleitung drin:

    IPTABLES=`which iptables` # pfad zu iptables
     
  4. #3 bitmuncher, 31.05.2007
    Zuletzt bearbeitet: 31.05.2007
    bitmuncher

    bitmuncher Foren Gott

    Dabei seit:
    08.05.2007
    Beiträge:
    3.180
    Zustimmungen:
    3
  5. XET!C

    XET!C Tripel-As

    Dabei seit:
    02.08.2006
    Beiträge:
    191
    Zustimmungen:
    0
    Ort:
    Alfter / Bonn
    Oh danke probier ich mal gleich aus. Ach noch ein kleines problem. Der Server lädt irgendwie nicht direkt beide
    netzwerkkarten, nur die eth0 und die eth1 nicht.
    interface:
    Code:
    auto lo
    iface lo inet loopback
    
    auto eth0
    iface eth0 inet dhcp
    
    auto eth1
    iface eth1 inet static
    address 192.168.0.1
    netmask 255.255.255.0
    gateway 192.168.0.2
    
     
  6. MrBoe

    MrBoe Routinier

    Dabei seit:
    13.06.2006
    Beiträge:
    399
    Zustimmungen:
    0
    Ort:
    braunschweig/nds/de/world
    Hast du denn einen DHCP Server?
     
  7. #6 bitmuncher, 31.05.2007
    bitmuncher

    bitmuncher Foren Gott

    Dabei seit:
    08.05.2007
    Beiträge:
    3.180
    Zustimmungen:
    3
    Wenn er keinen hätte, würde nur die eth1 geladen werden. ;)

    Schau in die /var/log/messages, was dort zum Netzwerk beim Booten drin steht.
     
  8. MrBoe

    MrBoe Routinier

    Dabei seit:
    13.06.2006
    Beiträge:
    399
    Zustimmungen:
    0
    Ort:
    braunschweig/nds/de/world
    Ich denke die wird geladen?

    Hab mich wohl verlesen, ich dachte die eth1 wird nicht nicht geladen, also doppelt verneint.

    Auf jeden Fall kann ein broadcast Eintrag bei eth1 nicht schaden.
     
  9. #8 XET!C, 31.05.2007
    Zuletzt bearbeitet: 01.06.2007
    XET!C

    XET!C Tripel-As

    Dabei seit:
    02.08.2006
    Beiträge:
    191
    Zustimmungen:
    0
    Ort:
    Alfter / Bonn
    ja nix...da wird nur eth1 erwähnt


    naja bleiben wir beim thema: Habe es mit dem Script versucht, wie es im Link ist.
    Code:
    #!/bin/bash
    
    echo "Starting firewall"
    
    LOGLIMIT=20
    IPTABLES=/sbin/iptables
    
    case "$1" in
    start)
    	# alle alten Regeln entfernen
    	echo "Loesche alte Regeln"
    	$IPTABLES -F
    	$IPTABLES -X
    	$IPTABLES -t nat -F
    	# Routing
    	echo 1 > /proc/sys/net/ipv4/ip_forward
    	$IPTABLES -A FORWARD -m state --state ESTABLISHED,RELATED,NEW -j ACCEPT
    	$IPTABLES -t nat -A POSTROUTING -o eth0 -j MASQUERADE
    	### ERSTELLE NEUE KETTEN ###
    	# Chain to log and reject a port by ICMP port unreachable 
    	$IPTABLES -N LOGREJECT 
    	$IPTABLES -A LOGREJECT -m limit --limit $LOGLIMIT/minute -j LOG \
              --log-prefix "FIREWALL REJECT " --log-level notice --log-ip-options --log-tcp-options 
    	$IPTABLES -A LOGREJECT -j REJECT --reject-with icmp-port-unreachable 
    	
    	### PROC MANIPULATION ###
    	# auf Broadcast-Pings nicht antworten
    	echo 1 > /proc/sys/net/ipv4/icmp_echo_ignore_broadcasts
    	# halt die Klappe bei komischen ICMP Nachrichten
    	echo 0 > /proc/sys/net/ipv4/icmp_ignore_bogus_error_responses
    	# Kicke den ganzen IP Spoofing Shit
    	# (Source-Validierung anschalten)
    	echo 1 > /proc/sys/net/ipv4/conf/all/rp_filter
    	# Setze Default-TTL auf 61 (Default fuer Linux ist 64)
    	echo 61 > /proc/sys/net/ipv4/ip_default_ttl
    	# sende RST-Pakete wenn der Buffer voll ist
    	echo 1 > /proc/sys/net/ipv4/tcp_abort_on_overflow
    	# warte max. 30 secs auf ein FIN/ACK
    	echo 30 > /proc/sys/net/ipv4/tcp_fin_timeout
    	# unterbreche Verbindungsaufbau nach 3 SYN-Paketen
    	# Default ist 6
    	echo 3 > /proc/sys/net/ipv4/tcp_syn_retries
    	# unterbreche Verbindungsaufbau nach 3 SYN/ACK-Paketen
    	# Default ist 6
    	echo 3 > /proc/sys/net/ipv4/tcp_synack_retries
    	
    	### MAIN PART ###
    	$IPTABLES -P INPUT DROP
    	$IPTABLES -P FORWARD DROP
    	$IPTABLES -P OUTPUT ACCEPT
    	$IPTABLES -A INPUT -m state --state ESTABLISHED,RELATED -j ACCEPT
    	$IPTABLES -A FORWARD -m state --state ESTABLISHED,RELATED -j ACCEPT
    	# im Loopback koennen wir jedem trauen 
    	$IPTABLES -A INPUT -i lo -j ACCEPT
    	# ebenso im LAN
    	$IPTABLES -A INPUT -i eth1 -j ACCEPT
    	# erlaube Pings
    	$IPTABLES -A INPUT -p icmp --icmp-type echo-request -j ACCEPT
    
    	# Alle TCP Packete, die bis hier hin kommen, werden 
            # geloggt und rejected 
            # Der Rest wird eh per Default Policy gedroppt... 
    	$IPTABLES -A INPUT -p tcp -j LOGREJECT 
    	$IPTABLES -A FORWARD -p tcp -j LOGREJECT
    	;;
    *)
    	echo "Usage: `basename $0` {start}" >&2
    	exit 64
    	;;
    esac
    
    exit 0
    Habe das dann als routing.sh gespeichert und mit
    Code:
    sh routing.sh start 
    ausgeführt
    Daraufhin kommt dann direkt die Meldung Starting firewall und Loesche alte Regeln.
    Direkt kommt auch ne Meldung von ip_tables, dass es gestartet ist.
    Aber ich kriege noch immer kein Internet auf mein anderen Rechner.
    Der SERVER ist im Internet und die NK sind richtig configuriert.
     
Thema:

Debian Router...problem IPTABLES

Die Seite wird geladen...

Debian Router...problem IPTABLES - Ähnliche Themen

  1. Debian GNU/Linux 9.12 und 10.3 freigegeben

    Debian GNU/Linux 9.12 und 10.3 freigegeben: Das Debian-Projekt hat am Wochenende die dritte Aktualisierung des stabilen Zweiges Debian 10 »Buster« freigegeben. Zeitgleich wurde der Vorgänger...
  2. Debian diskutiert weiter über Systemd

    Debian diskutiert weiter über Systemd: Debian stellt das Logging-System standardmäßig von Rsyslog auf Journald aus dem Systemd-Paket um. Weiterlesen...
  3. Debian erlaubt Booten vom F2FS-Dateisystem

    Debian erlaubt Booten vom F2FS-Dateisystem: Debian-Entwickler Roman Perier arbeitet an der Umsetzung der Unterstützung des Dateisystems F2FS in GRUB und Initramfs, um der Distribution das...
  4. Keine grafische Oberfläche (Debian Installation)

    Keine grafische Oberfläche (Debian Installation): Hallo zusammen, vorne weg: Ich bin Linux-Neuling und hoffe, hier im richtigen Forenbereich zu schreiben, falls nicht, bitte verschieben. Bisher...
  5. Debian-Abstimmung klärt Status der Init-Systeme

    Debian-Abstimmung klärt Status der Init-Systeme: Die Debian-Entwickler haben die Frage der Init-Systeme einstweilen geklärt. Demnach bleibt Systemd das Standard-Init-System, und die paketierte...
  1. Diese Seite verwendet Cookies um Inhalte zu personalisieren. Außerdem werden auch Cookies von Diensten Dritter gesetzt. Mit dem weiteren Aufenthalt akzeptierst du diesen Einsatz von Cookies.
    Information ausblenden