[Debian] Probleme mit Eggdrop

P

P4r4

Jungspund
Nabend,

hab eigentlich alles soweit ausm weg geschafft was ich an fehlern bisher hatte nur jetzt henge ich ...
und zwar kann ich starten das sieht dann so aus :

Eggdrop v1.6.17 (C) 1997 Robey Pointer (C) 2004 Eggheads
[03:44] --- Loading eggdrop v1.6.17 (Fri Sep 8 2006)
[03:44] Listening at telnet port 3333 (all).
[03:44] Module loaded: dns
[03:44] Module loaded: channels
[03:44] Module loaded: server
[03:44] Module loaded: ctcp
[03:44] Module loaded: irc
[03:44] Module loaded: notes (with lang support)
[03:44] Module loaded: console (with lang support)
[03:44] Module loaded: blowfish
[03:44] Module loaded: uptime
[03:44] Userinfo TCL v1.07 loaded (URL BF GF IRL EMAIL DOB PHONE ICQ).
[03:44] use '.help userinfo' for commands.
[03:44] Creating channel file
[03:44] Couldn't create channel file: test0r.chan. Dropping


STARTING BOT IN USERFILE CREATION MODE.
Telnet to the bot and enter 'NEW' as your nickname.
OR go to IRC and type: /msg tes0r hello
This will make the bot recognize you as the master.

[03:44] === test0r channels, 0 users.
* Warning! Could not write pid.test0r file!
Launched into the background (pid: 3443)


weiss nicht ob es bis hier her richtig ist, ich denke mal das der das userfile erstellt nachdem ich mich angemeldet habe oder ?? ???

genau da ist jetzt das problem, wenn ich übers telnet drauf will kommt nur ein leeres fenster, würde mal behaupten das ich connected bin nur wiedergeben tut er mir nichts, kann das die firewall sein ???
falls ja wie confe ich die ? bzw wo ist diese zu finden :)


(server 4 you , debian plesk)



Gruss P4r4
 
defcon

defcon

Kaiser
Moderator
hast Du dich mit
Code:
$ telnet <ip> 3333
verbunden?
 
grey

grey

-=[GHOST]=-
P4r4 schrieb:
Nabend,
hab eigentlich alles soweit ausm weg geschafft was ich an fehlern bisher hatte nur jetzt henge ich ...
und zwar kann ich starten das sieht dann so aus :
[...]
[03:44] Creating channel file
[03:44] Couldn't create channel file: test0r.chan. Dropping
[...]
[03:44] === test0r channels, 0 users.
* Warning! Could not write pid.test0r file!
[...]
Kurze Frage: Wo möchtest du das Channel-Phile und das Pid-Phile erstellen lassen und hat der Eggdrop-Bot dort auch Schreibrechte?
Für mich schaut es so aus, als ob ihm die Rechte fehlen würden.
 
P

P4r4

Jungspund
also ich hab mal rechte gesetzt und zumindest bin ich jetzt die eine meldung los.. aber jetzt hänge ich schon wieder :

Eggdrop v1.6.17 (C) 1997 Robey Pointer (C) 2004 Eggheads
[16:21] --- Loading eggdrop v1.6.17 (Sat Sep 9 2006)
[16:21] Listening at telnet port 3333 (all).
[16:21] Module loaded: dns
[16:21] Module loaded: channels
[16:21] Module loaded: server
[16:21] Module loaded: ctcp
[16:21] Module loaded: irc
[16:21] Module loaded: notes (with lang support)
[16:21] Module loaded: console (with lang support)
[16:21] Module loaded: blowfish
[16:21] Module loaded: uptime
[16:21] Userinfo TCL v1.07 loaded (URL BF GF IRL EMAIL DOB PHONE ICQ).
[16:21] use '.help userinfo' for commands.


STARTING BOT IN USERFILE CREATION MODE.
Telnet to the bot and enter 'NEW' as your nickname.
OR go to IRC and type: /msg botname hello
This will make the bot recognize you as the master.

[16:21] === botname: 0 channels, 0 users.
Launched into the background (pid: 14508)


irgendwie connected der einfach nicht, also im efnet wo er eigentlich sein soll isser nicht, und das schlimme per telnet komm ich auch nicht drauf... habe immer leeres fenster und kann eintippen was ich will, sehr komische als ob da was ist und ich doch nicht alles bekomme... :(
 
Zuletzt bearbeitet:
grey

grey

-=[GHOST]=-
Wie verbindest du dich mit dem Eggdrop?

Vielleicht hilft das
Code:
grey@mod-001:~$ telnet 127.0.0.1 3333
Trying 127.0.0.1...
Connected to 127.0.0.1.
Escape character is '^]'.


localBot  (Eggdrop v1.6.17 (C) 1997 Robey Pointer (C) 2004 Eggheads)

Please enter your nickname.
NEW

This is the telnet interface to localBot, an eggdrop bot.
Don't abuse it, and it will be open for all your friends, too.
You now get to pick a nick to use on the bot,
and a password so nobody else can pretend to be you.
Please remember both!
Enter the nickname you would like to use.
grey
*** POOF! ***
You are now a master on this bot.
### POOF! ###
You are now a botnet master on this bot.
@@@ POOF! @@@
You are now an OWNER of this bot.

YOU ARE THE MASTER/OWNER ON THIS BOT NOW
From now on, you don't need to use the -m option to start the bot.
Enjoy !!
Okay, now choose and enter a password:
(Only the first 15 letters are significant.)
*********

Remember that!  You'll need it next time you log in.
You now have an account on localBot...



Connected to localBot, running eggdrop v1.6.17
     ____                __
    / __/___ _ ___ _ ___/ /____ ___   ___
   / _/ / _ `// _ `// _  // __// _ \ / _ \
  /___/ \_, / \_, / \_,_//_/   \___// .__/
       /___/ /___/                 /_/

Hey grey!  My name is localBot and I am running eggdrop v1.6.17, on Linux 2.6.8-3-k7.

Local time is now 17:52
You are an owner of this bot. Only +n users can see this! For more info,
see .help set motd. Please edit the motd file in your bot's 'text'
directory.
Use .help for basic help.
Use .help <command> for help on a specific command.
Use .help all to get a full command list.
Use .help *somestring* to list any help texts containing "somestring".

Have fun.

Commands start with '.' (like '.quit' or '.help')
Everything else goes out to the party line.

### You have the following note(s) waiting:
   1. localBot (Sep 09 17:51)
### Use '.notes read' to read it.
*** grey joined the party line.
 
P

P4r4

Jungspund
hmm richtig komisch das ganze, früher unter win hab ichs auch zum laufen bekommen, jetzt bin ich schon soweit das er startet aber dann hängt er :

habs mal so gemacht wie du oben geschrieben hast also direkt auf der kiste über den localhost , obwohl es ja von aussen auch gehen müsste. hier mal das log


user@echo563:/root/eggdrop$ telnet 127.0.0.1 3333
Trying 127.0.0.1...
Connected to 127.0.0.1.
Escape character is '^]'.



ab da steht er ....


ahh nu hab ichs am laufen :) , hatte was vergessen in der config .. man man man wer suchet der findet :D

komm zwar von aussen immer noch nicht mit telnet drauf aber das kann ich auch über die console local machen....


vielen dank für die hilfe .... -_-
 
Zuletzt bearbeitet:
B

breaker

Gast
Und welche Klamotte hast du in der Config vergessen ? Ich hänge an dem gleichen Punkt fest.

bei mir habe ich diese Meldung :

breaker@server-drop:~/eggdrop$ ./eggdrop -m eggdrop.conf

Eggdrop v1.6.17 (C) 1997 Robey Pointer (C) 2004 Eggheads
[02:33] --- Loading eggdrop v1.6.17 (Fri Sep 15 2006)
[02:33] Listening at telnet port 3333 (all).
[02:33] Module loaded: dns
[02:33] Module loaded: channels
[02:33] Module loaded: server
[02:33] Module loaded: ctcp
[02:33] Module loaded: irc
[02:33] Module loaded: notes (with lang support)
[02:33] Module loaded: console (with lang support)
[02:33] Module loaded: assoc (with lang support)
[02:33] Module loaded: uptime
[02:33] Userinfo TCL v1.07 loaded (URL BF GF IRL EMAIL DOB PHONE ICQ).
[02:33] use '.help userinfo' for commands.


STARTING BOT IN USERFILE CREATION MODE.
Telnet to the bot and enter 'NEW' as your nickname.
OR go to IRC and type: /msg MKSecurity hello
This will make the bot recognize you as the master.

Und das habe ich, wenn ich danach mit Telnet connecten will :

breaker@server-drop:~/eggdrop$ telnet 127.0.0.1 3333
Trying 127.0.0.1...
telnet: Unable to connect to remote host: Connection refused
breaker@server-drop:~/eggdrop$
 
Zuletzt bearbeitet von einem Moderator:
T

Topper

Gast
Hi


Ich hab genau das selbe Problem beim connecten per telnet auf den eggdrop.

Es wäre echt cool wenn du sagen könntest was du in der config verändert hast damit das geht.
 
B

Brainbug

Grünschnabel
Viele Jahre später hänge ich auch gerade an diesem Problem. Wie kann ich es lösen ?
 
S

Sauerland

Doppel-As
Sollte man aber evtl. mal drüber nachdenken:
Telnet is an old protocol for logging into remote systems. It is
rarely used, since the transfer is not encrypted (ssh is mostly used
these days). The telnet client is often used for debugging other
network services. The command

telnet localhost 25

connects to the local smtp server, for example.

Und einen 14 Jahre alten Beitrag.......
 

Ähnliche Themen

X startet nichtmehr

Samba 4.1.3 auf falschen Netzwerkinterface

Samba 4 Gast Zugang unter Ubuntu funktioniert nicht

JBidWatcher: Problem bei loading Auctions in Verbindung mit mySQL

Fedora: selinux Berichtungsproblem mit Apache

Oben