Dateisystem defekt, kein Start von Openfiler möglich. Error 22. Bitte um Hilfe

D

dallas

Grünschnabel
Hallo Community ,

Ich bin noch kein Linux-Profi, sondern noch Anfänger, aber ein paar Sachen habe ich mit Debian schon gemacht. Hab ich bisher immer irgendwie hinbekommen,aber jetzt stecke ich fest (aber nicht bei Debian, sondern RedHat als "Operfiler").

Deswegen brauche ich bitte eure Hilfe.


Ich versuche seit 1 Woche Openfiler zu installieren, und komme dabei
auf kein lauffähiges System.

Ausgangslage ist ein neuer Rechner mit 4 x 2 TB SATA Samsung HDs.
Diese sollen zu einem Software-RAID5 zusammengebaut
werden. Beriebssysten soll Openfiler sein.

Openfiler soll dabei von einem USB Stick laufen (weil ich die Platten ja für das RAID benötige.Der Stick ist bootfähig und er bootet auch, aber eben nicht erfolgreich)

Habe die installation auf USB abgeschlossen, aber 1 Platte war statt msdos leider GPT.
Ließ sich nicht ändern, also alles neu. Ging nicht.
Zuletzt dann mit GPARTED alle Platten/Partitionen gelöscht und OF auf Platte sda neu installiert.
Boot von USB ging dann plötzlich auch, ind ich konnten von SDA oder USB booten.
Alles wieder super.
ALso von USB gebootet und wollte auch sda ins Raid einbinden.
Ging nicht, weil dort ein Betriebssystem drauf war. Ließ sich über das WEBinterface nicht entfernen.
Und dann kam mein Fehler: Konsole und FDISK und dann sda per "D" und "W" gelöscht.
Das System war hin. Nach Reboot , steht das System immer auf Fehler (siehe unten).

Inzwischen habe ich mehrere Neuinstallationen versucht.
Der Stick wurde von mir zwischen den einzelnen Installationen immer wieder gelöscht (Windows-Formatierung).

Der Witz war, das sobald OF auf der sda war, auch der Stick ging (ohne was gemacht zu haben). Sobald sda wieder leer war, ist der Fehler wieder da.

Die Platten haben inzwischen alle das Softwareraid Format, aber ich kann noch immer nicht vom USBStick erfolgreich booten.
Egal was ich mache:
Der Stick bootet (soweit o.k.) aber dann kommt:

ERROR Loading Journal
mount:Error 22 mounting ext3
ERROR opening /dev/console!!!!

Kernel panic . . . . . .

Also reparaturkonsole an, und jetzt ?
fdisk -l zeigt alles korrekt an.
Der USB Stick wird auch korrekt als sde gemountet:

Jetzt sind mir die Ideen ausgegangen.

Aber ich brauche sda für das Raid. Insofern muss die Kombi aus Stick und Raid doch irgendwie gehen.

Wie bekomme ich diesen Filesystemerror 22 weg und den Stick zum laufen ?
Ich werd noch wahnsinnig und bitte um hilfe.

Danke

Dallas
 
bitmuncher

bitmuncher

Foren Gott
Ein mount error 22 weist darauf hin, dass der Superblock nicht korrekt gelesen wird oder die Festplatten-Parameter nicht korrekt eingetragen sind. Kannst du denn ein fsck problemlos über die Partition laufen lassen? Sprichst du die Partition, die du mounten willst über ein Label oder direkt über's Device an? Ansonsten kannst du dir mal über die MagicSysRq-Keys einen Backtrace vom Kernel holen und schauen, ob du dadurch evtl. ermitteln kannst in welcher Funktion des Kernels es zum Crash kommt. Auch wäre es noch interessant zu wissen welchen Kernel du nutzt und welche CPU verbaut ist. Die Meldung "ERROR opening /dev/console" gefolgt von einer Kernel Panic tritt nämlich aufgrund eines Kernel-Bugs gern mal mit AMD-Prozessoren auf, sollte aber meines Wissens nach im aktuellsten Kernel gefixt sein.
 
M

marce

Kaiser
Poste besser mal Fakten anstatt Prosa... - also konkrete Ausgaben von fdisk -l, ...

Für die Lesbarbeit der Ausgaben wäre dann noch die Verwendung von
Code:
-Tags angeraten...
 
D

dallas

Grünschnabel
Guten Morgen, und Danke für die Antwort.
Ich habe leider schon wieder rumgefrickelt.
fsck hat mir keine Probleme angezeigt. Ich würde ja einen fdisk auszug machen, aber ich kommen mit der
Windowskiste ja nicht an die Ausgabe auf dem USB Stick ran.
Prozessor ist ein AMD 3 Kern 2,8.
Die Hardware (mit ausnahmen der Platten schließe ich mal aus, weil es ja schon ging).
Ich habe gestern alle Platten abgezogen, den USB per FDISK gelöscht, neue Partitionen angelegt, und
mit mkfs.ext2 formatiert. Alles sauber, sogar neue Superblocks wurde erzeugt.
Dann OPENFILER mit EXT2 installiert (ohnen Platten dran). Also nur der USB Stick.
Beim Boot vermisst er dann Label /1 (das was eine Plattenbezeichnung unter FREEBDS das vorher auf dem Stick war) und GRUB hat schon wieder ext3 am Wickel. Dabei habe ich doch alles gelöscht.
Irgendwo schreibt sich das System was weg, ich ich komme da nicht ran.

Das mit Labelmount, oder Device hab ich nicht verstanden und STRG-DRUCK als MagSysRequest hat auch nicht funktioniert.

Ob es was bringt, den Stick (die Platten sind ja überhaupt nicht dran) per dd if=zero of= /dev/sde mal zu nullen? Muss ich dabei was beachten ?
 
Zuletzt bearbeitet:
D

dallas

Grünschnabel
Geklärt:

OpenFiler kann einfach nicht mit USB Geräten beim Start.
Er kann zwar auf USB installieren, aber die Installation ist nicht startfähig.
Hab das jetzt mit div. USB Sticks und Platte probiert.
Habe auch schon das hier ausprobiert:

https://forums.openfiler.com/viewtopic.php?pid=3119

Aber nicht hinbekommen. Die Aneitung ist auch älter:
VI ist jetzt joe,
Die dort genannten Dateien sind in der INIT vorhanden.
Also wohl ein anderes Problem.
Egal. Ich habs jetzt per SATA Festplatte gelöst.
Das klappt sofort.

Beitrag geschlossen.
 
Zuletzt bearbeitet:

Ähnliche Themen

Bootpartition von CentOS7 auf USB-Stick vergrößern

Grub reparieren

Hardware RAID-0 kaputt / wird nicht mehr erkannt

System hängt nach: JDB: barrier-based sync failed on md1-8 - disabling barriers

LVM reparieren? Benötige Hilfe

Oben