Bios bootet kein AHCI?

Cdh

Cdh

Mitglied
Hi,
Jetzt war ich mir doch sehr unsicher, wo das hinkommt, also erstmal hier.

Zum Problem: Ich konnte den AHCI Modus für S-ATA Platten mit zwei PCs mit zwei verschiedenen Festplatten noch nie benutzen...

Ich hatte mir damals :) noch einen Mediamarkt PC gekauft, in der Voreinstellung stand die Festplatte im Bios auf dem IDE Compability Modus, das hat es auch soweit getan.
Jetzt - mittlerweile auch mit mit neuem Mainboard und neuer Festplatte, genau das Gleiche Problem - hätte ich aber gerne AHCI aktiviert.
Das Problem: Wenn ich das mache, dann bootet er nicht mal mehr grub, das Bios meldet, ich solle doch einen geeigneten Datenträger einlegen blablub.
Im Bios selber sehe ich die Festplatte noch, ich kann auch das Bios Bootmenü aufrufen und ihm sagen, er solle doch von der Festplatte booten. Datenträger einlegen blablub.
Wenn ich mit einer LiveCD starte, dann sehe ich die Festplatte kann problemlos darauf zugreifen, das boot flag ist auch gesetzt, aber das Bios bootet sie eben nicht. grub neu schreiben mit grub-install hat auch nichts gebracht.

Auf zwei verschiedenen Mainboards hat das jetzt nicht geklappt, das eine ist ein Noname Board, das jetzige ein Asus p5dgc Deluxe.
Gemeinsam haben sie, das ein Intel 910er Chipsatz drauf ist. (Beim jetzigen genauer: 910GL)

Code:
-SCSI Disks-
ATA WDC WD5000KS-00M
_NEC DVD_RW ND-2510A
Das DVD Laufwerk ist ein IDE Laufwerk, die Festplatte eine S-ATA Platte.

So... Hat jemand eine Ahnung, was zu tun ist? Hilft vielleicht ein Bios Update? Habe ich noch nie gemacht und würde ich auch nur ungern machen...
 

Ähnliche Themen

Keine grafische Oberfläche (Debian Installation)

grub iso boot

Reihenfolge der Platten wird beim Booten verändert

UDMA Fehler? Bootet nicht mehr (SUSE 10.3)

Notebook Install Boot-Freeze: Athlon 1600+ ,256MB Ram, Via KT333, Radeon 9000

Oben