ASUS p4p800 Netzwerktreiber

Cra$H

Cra$H

Grünschnabel
Ich bin neu hier also Tachauch.

Ich hab mir nen neuen PC gekauft, mit obengenanntem Mainboard.
Dazu wollte Ich mal Linux ausprobieren, also hab ich Redhat 9.0 Installiert.
Es laeuft soweit auch alles Prima, bis auf die Onboard Netzwerkkarte.

Diese ist gemaess ASUS eine 3COM Gigabyte Netzwerkkarte.
Der auf der CD und im Internet bereitgestellte Treiber funzt auch nicht,
die ganze Sache mit dem Laden des Moduls
(/sbin/insmod irgendetwas.o ) gemaes readme hat net gefunzt (das modul wird dann aufgelistet bei lsmod, aber i-net funzt trotzdem net),,,

und seit neustem sagt er dann beim eth0 up er haette keine solche Schnittstelle....

Ich bin bald am Ende. Falls einer dieses Problem kennt, bitte alles schreiben was funzen koennte!

greets Cra$H
 
Zuletzt bearbeitet:
devilz

devilz

Pro*phet
probier mal nach laden des treibers ..

ifconfig eth 192.168.0.9

und dann mit "ifconfig" schauen ob er ne eth0 gelistet hatt.

vielleicht scheitert es nur an deinen Internet Einstellungen ?
 
Cra$H

Cra$H

Grünschnabel
Sorry das ich das sage aber ich hab Linux seit knapp 6 Stunden auf meinem Rechner und hab noch NIE mit Linux gearbeitet also bitte erklär mir die sachen in schritten.... :P


edit//:bei dem was du mir sagst kommt immer : unknow comand und wenn ich ifconfig eth 192.168.0.9 eingebe komme das er kein Gerät oder das es keine Schnittstelle geben würde.....
 
Zuletzt bearbeitet:
devilz

devilz

Pro*phet
UPS :)

Mein Fehler ....

ifconfig eth0 192.168.0.9

NICHT eth sondern eth0 :)

Mein Fehler - kann mal passieren *g*
 
Cra$H

Cra$H

Grünschnabel
Hat auch nix geholfen er sagt immernoch das es die Schnittstelle nicht gibt.....
 
M

meinblauesich

Grünschnabel
Hi,

habe gestern auf der Arbeit auch das gleiche Board installiert. Ich habe den auf der CD beigelegten Treiber (3c2000) genommen. Das lief alles perfekt. Mein Weg war folgender:

# cp 3c2000.tar.gz /usr/src
# tar -xzf 3c2000.tar.gz
# cd 3c2000
# make load
# cp -a 3c2000.o /lib/modules/`uname -r`/kernel/drivers/net
# echo "3c2000" >>/etc/modules.autoload

Sollte das make fehlschlagen, installiere Dir die Kernelsources zu Deinem aktuellen Kernel.

>die ganze Sache mit dem Laden des Moduls
>(/sbin/insmod irgendetwas.o ) gemaes readme hat net gefunzt (das modul >wird dann aufgelistet bei lsmod, aber i-net funzt trotzdem net),,,

???
Wenn ein Treiber geladen wird (modprobe 3c2000) dann (Fallunterscheidung):
- klappt das und (Fallunterscheidung):
- der Treiber findet entsprechende Hardware -> 3Com 940 blah blub found... Ein lsmod zeigt Dir dann für das Modul unter Used eine 1 an.
- der Treiber findet nix. Unter Used steht dann eben eine 0.
- klappt es nicht. z.B. weil Kernelversion nicht stimmt, die Datei wird nicht gefunden (3c2000.o) usw... Ein lsmod listet Dir in dem Fall auch nicht das entsprechende Modul.

Ist das Modul geladen, startest Du das Device am besten mit einem
# /etc/init.d/net******* start
(die Zeile ist abhängig von der Distribution, daher weiss nicht, wie das bei RH9 ausschaut)

ein # ifconfig spuckt Dir dann die Einstellungen aus. Wie man die Netzwerkarte (eth0 - bei einer Karte) bei RH9 konfiguriert (wahrscheinlich das eigentliches Problem) findest du mit google.
Hint: Früher gab es bei RH ein Tool namens linuxconf. Mit dem konnte man bequem die Netwerkkarte(n) konfigurieren. Keine Ahnung ob es das noch gibt.

Viel Spaß mit Deinem GB-LAN ;)

Gruß, mbi
 
M

meinblauesich

Grünschnabel
Man sollte noch erwähnen, dass sich der Treiber nicht mit den std. Windowstreibern der Realtek 8139, sowie VIA vt82** verträgt.
Die Windowstreiber der genannten Chipsätze muss man in dem Fall auf den aktuellen Stand bringen.

mbi
 
H

hmb

Gast
Meine Lösung

Nachdem ich mich mit demselben Problem einen halben Tag rumgeschlagen habe und so ziemlich alles zum Thema gelesen habe, was die verschiedenen Boards so hergeben, habe ich folgende Lösung gefunden:

Mein System:
- Board ASUS P4P800 mit angeblich einer 3C2000-Netzwerkkarte
- Debian Woody mit Kernel 2.4.18

Hinweis 1:
Wer sich die Treiber unter Debian kompilieren will, muß nicht (nur) das Paket kernel-sources-2.4.18-5 sondern kernel-headers-2.4.18-bf2.4 installieren. Hier sind die Dateien wie version.h und autoconf.h enthalten.

Hinweis 2:
Mit den Treiberpaketen von ASUS konnte zwar ein Modul 3c2000.o kompiliert werden, das konnte aber die Karte nicht ansprechen. Wer das trotzdem probieren will, muß nach dem Auspacken der 3c2000.tar.gz die Makefile-Datei editieren und die Pfade zu den Headern und das Zielverzeichnis für die Installation anpassen.

Der Versuch, mit
#insmod 3c2000

oder
#/etc/init.d/networking start

die Karte zu starten, schlug fehl mit der Meldung "No such device" fehl.

Hinweis 3:
Die Überprüfung der Hardware verlief positiv und brachte den entscheidenden Hinweis:
#lspci
listet vorhandene Komponenten auf. In dieser Liste sollte etwas Ähnliches stehen wie:
...
02:05.0 Ethernet controller:BROADCOM Corporation: Unkown device 4401 (rev 01)
...

Die Treiber habe ich auf der Broadcom-Seite nicht finden können. Wohl aber hier:

http://www.xs4all.nl/~haanjdj/broadcom.html

Der Rest ist dann einfach:
Die von dieser Adresse heruntergeladene Datei bcm4400-2.0.5.tar.gz
in einem temporären Verzeichnis auspacken, kompiliern und installieren:
#tar xvzf bcm4400-2.0.5.tar.gz
#make
#make install
#insmod bcm4400

Hinweis 4:
Da die Karte bisher nicht erkannt wurde, müssen wir dem System noch mitteilen, daß da eine ist.

Hierzu die Datei /etc/network/interfaces editieren:
Die Eintäge zum loopback unverändert lassen und dahinter etwas in der Art eintragen:
...
auto eth0
iface eth0 inet dhcp
...
Das funktioniert natürlich nur, wenn ein DHCP-Server in Reichweite ist. Ansonsten mal nach Beispielen für diese Datei suchen.

Jetzt nur noch das Netzwerk starten:
#/etc/init.d/networking start

Je nach Distirbution kann das woanders liegen.


Hinweis 5:
Bei dieser Vorgehensweise ist noch nicht dafür gesorgt, daß beim nächsten Systemstart, das Modul auch wieder geladen wird.

Dazu muß es noch in /etc/modules eingetragen werden.
 
L

latissimus

Jungspund
Hi,

habe es nun doch gechafft, und mir Redhat mit der Option "alles" beim Setup auf die Platte gebügelt.

Blöderweise habe ich eine Internetverbindung eingerichtet, mit dem sk98lin Treiber, da ich ein P4P800 habe, mit dem 3C940. Nun kann ich nicht mehr Linux starten.

Werde also zur Bootdiskette greifen und es entfernen.

Wer mir, als absoluter Anfänger in Sachen Linux (der keine Ahnung von irgendwas hat) mal ein HowTo ganz detailliert geben kann, darf dies tun.

Ich bin Euch zu tiefst dankbar.

Edit: Ich habe den Treiber der P4P800-CD auf /home/mein name entpackt

Danach habe ich make install eingegeben. Es läuft auch alles prima, bis es zu depmod -a kommt. Depmod kennt Redhat nicht. Kann mir da jemand weiterhelfen?

MfG
latissimus
 
Zuletzt bearbeitet:
L

latissimus

Jungspund
Nachtrag:
Habe mal den Linux Treiber der CD für den E1000 von Intel genommen. Dieser wird durch make install wohl korrekt eingebunden, Linux zeigt mir keine Fehlermeldung an.

Ich möchte mit dem Onboard Lan per DSL ins Netz. Da ich absoluter Newbee bin, brauche ich ne gute Step-by-Step Anleitung.

RedHat kennt bei mir kein ifconfig oder modprobe.
 
codc

codc

/dev/null
Depmod kennt Redhat nicht.

RedHat kennt bei mir kein ifconfig oder modprobe.

Tut mir leid aber dass kann nicht sein. Bei mir kennt RH 9 sehr wohl diese elementaren Kommandos.

Nur mal so ins blaue rein - du musst als root eingeloggt sein um solche Dinge zu tun. Für normale User sind viele Pfade für administrative Befehle gar nicht gesetzt.

Ich möchte mit dem Onboard Lan per DSL ins Netz. Da ich absoluter Newbee bin, brauche ich ne gute Step-by-Step Anleitung.
Dass hätte sich jeder am Anfang gewünscht aber ich glaube da musst du alleine durch. ;)

Übrigens gibt es von O'Reilly einen Satz toller Bücher zu Linux und wie du dass System administrierst.
 
L

latissimus

Jungspund
@codc

1. bin ich als root angemeldet und

2. werden die Eingaben mit "commando not found" dokumentiert. Da du ja keine Probleme hast, kannst Du mir ja mal locker weiterhelfen!

Also, wenn in einem der vielen Linux-Bücher drin steht, wie ich diesen 3C940 zum Laufen bekomme, kaufe ich mir sofort das Buch!

Ich warte!
 
codc

codc

/dev/null
Also, wenn in einem der vielen Linux-Bücher drin steht, wie ich diesen 3C940 zum Laufen bekomme, kaufe ich mir sofort das Buch!
Das wirst du sicher nicht in einem Buch finden.

Bei mir liegen alle Befehle in /sbin/ wo sie hingehören. Dieser Pfad muss in $PATH gesetzt sein.

Kann kaum sein aber ist das ein gekauftes RH oder iso runtergeladen. Also ohne ifconfig kommst du mit dem Netz nicht weit.

Ach ja ist das ein orginal Kernel oder ein kompilierter ?
 
L

latissimus

Jungspund
Es ist ein normaler kernel, habe ihn nicht kompiliert. Es ist die Download-Version.

Muss ich in dem makefile also /sbin Pfade angeben, wenn ja, wo?

Ich kenne mich doch überhauüt nicht aus.
 
codc

codc

/dev/null
was sagt denn "echo $PATH"

da sollte u.a. /sbin/ drinstehen. Bzw. ist ifconfig in diesem Verzeichnis

Poste mal "ls -la /sbin/ifconfig" vielleicht ist das ja auch nicht ausführbar. Ist zwar alles unwahrscheinlich aber vielleicht ......
 
L

latissimus

Jungspund
Ja, ifconfig liegt auch unter sbin und unter src/share blablabla

Das Problem ist, dass ich nicht die Meldungen kopieren kann, da der Drucker nicht läuft und ich keine Dateien übertragen kann :(

Werde das mal checken


Edit: Habe die Befehle in der Konsole als root eingegeben
Hier das Ergebnis

echo $path --> Es wurde nur mein Ort im Verzeichnis angegeben, wo ich mich befand -- meinname@localhost meinname

ls -la /sbin/ifconfig --> Es kam eine lange Liste mit Dateien, hier mal die Zeile mit ifconfig -- -rwxr-xr-x 1 root 51672 11. Feb. 2003 ifconfig in grün
 
Zuletzt bearbeitet:
codc

codc

/dev/null
Zunächst einmal $PATH also groß Linux achtet wie Unix darauf.

Bei mir sieht das ganze so aus:

[root@Marvin root]# echo $PATH
/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin:/usrX11R6/bin:/root/bin

Die Rechte sind richtig und die Datei ausführbar.

Um den Pfad einzutragen musst du die Config deiner Shell ändern bzw. das mal so eintragen.

Ansonsten mit set ersteinmal manuell setzten und schauen ob es jetzt tut.

Übrigens unter /usr/share/man blabla liegen die man-Pages also Manuals
 
L

latissimus

Jungspund
Hi,

der Treiber ist im Kernel, ich Depp habe vergessen, den Kernel zu kopieren und zu installieren? Kann mir da jemand helfen? mit dem bzimage etc.?
 

Ähnliche Themen

ASUS CUR-DLS (Serverworks) IDE-Laufwerk sehr langsam

ASUS M2N1394 Mainboard und kein Sound unter SUSE 10.2

Wine Soundprobleme mit SoundMAX AD1986A unter Linux (Asus M2NPV-VM)

Oben