apache2-mod_php5 will nicht.

Diskutiere apache2-mod_php5 will nicht. im SuSE / OpenSuSE Forum im Bereich Linux Distributionen; Hi, ich habe hier einen apache2 mit installiertem PHP5 und Apache-Modul unter SuSE 10. PHP selbst funktioniert zwar, jedoch spuckt mir der...

  1. #1 Fallout, 22.03.2010
    Fallout

    Fallout Doppel-As

    Dabei seit:
    02.03.2007
    Beiträge:
    120
    Zustimmungen:
    0
    Hi,

    ich habe hier einen apache2 mit installiertem PHP5 und Apache-Modul unter SuSE 10. PHP selbst funktioniert zwar, jedoch spuckt mir der Webserver bei der Anforderung einer .php-Seite trotzdem immer den Download der Datei aus anstatt den HTML-Inhalt zu generieren und anzuzeigen.

    Meiner Meinung nach sollte laut Konfiguration alles passen - aber er tut's trotzdem nicht:
    Code:
    [b]/etc/sysconfig/apache2[/b]
    APACHE_MODULES="authz_host actions alias auth_basic authz_groupfile authn_file authz_user autoindex cgi dir include log_config mime negotiation setenvif status userdir asis charset_lite imagemap rewrite ssl php5 perl"
    Code:
    [b]apache2ctl -t -D DUMP_MODULES |grep -i php[/b]
     php5_module (shared)
    
    Code:
    [b]/etc/apache2/mod_mime-defaults.conf[/b]
    AddType application/x-php .php
    
    Code:
    [b]echo -e '<?php phpinfo(); ?>'|php|grep -i version[/b]
    PHP Version => 5.2.5
    "Olson" Timezone Database Version => 2007.9
    DOM/XML API Version => 20031129
    libxml Version => 2.6.23
    iconv library version => 2.4
    json version => 1.2.1
    libXML Version => 2.6.23
    Client API version => 5.0.26
    Client API library version => 5.0.26
    Client API header version => 5.0.26
    OpenSSL Version => OpenSSL 0.9.8a 11 Oct 2005
    PCRE Library Version => 7.3 2007-08-28
    PDO Driver for MySQL, client library version => 5.0.26
    PECL Module version => (bundled) 1.0.1 $Id: pdo_sqlite.c,v 1.10.2.6.2.2 2007/03/23 14:30:00 wez Exp $
    Version => $Id: php_reflection.c,v 1.164.2.33.2.47 2007/10/28 13:47:14 iliaa Exp $
    PECL Module version => 2.0-dev $Id: sqlite.c,v 1.166.2.13.2.9 2007/05/19 17:58:22 iliaa Exp $
    libxml2 Version => 2.6.23
    
    Code:
    [b]telnet myip 80
    Trying myip...
    Connected to myip.
    Escape character is '^]'.
    GET /phpinfo.php[/b]
    <?php
    
    phpinfo();
    
    ?>
    
    Fällt jemand von Euch vielleicht noch etwas ein was ich übersehen habe? Ich komme hier leider auf keinen grünen Zweig :-(

    Gruß Daniel
     
  2. #2 bitmuncher, 22.03.2010
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.175
    Zustimmungen:
    3
    Wird die /etc/apache2/mod_mime-defaults.conf korrekt in die httpd.conf inkludiert?
     
  3. #3 Fallout, 22.03.2010
    Fallout

    Fallout Doppel-As

    Dabei seit:
    02.03.2007
    Beiträge:
    120
    Zustimmungen:
    0
    Hi,

    vielen Dank für die schnelle Antwort. Mittlerweile hat sich das Problem erledigt - auch wenn ich nicht sagen kann was letztendlich der Fehler war.

    Die Mimetypes wurden schon ordentlich eingebunden. Es hatte sich auch herausgestellt daß PHP mal über die Namensauflösung und mal über IP-Adresse funktioniert hat bzw. mal nicht und daß es auch noch einen Unterschied machte ob das PHP-Skript im Document_Root lag oder in einem Unterverzeichnis.

    Letztendlich half bei mir eine Neuinstallation des RPM und ich habe auf Basis der Default-apache2-Configfiles meine Anpassungen eingebaut. Nun generiert er zumindest sauber die Seiten.

    Danke für die Aufmerksamkeit - Hauptsache es funktioniert jetzt endlich wieder ;-)

    Gruß Daniel
     
Thema:

apache2-mod_php5 will nicht.

Die Seite wird geladen...

apache2-mod_php5 will nicht. - Ähnliche Themen

  1. Unix Shell Funktionen funktionieren nicht

    Unix Shell Funktionen funktionieren nicht: Guten Tag Ich hoffe sehr, dass Sie mir weiterhelfen können, denn ich habe ein riesiges Problem: Zurzeit arbeite ich mit meinem Server an einem...
  2. Nvidia Hybrid-Grafikkarte: 3D Beschleunigung will nicht

    Nvidia Hybrid-Grafikkarte: 3D Beschleunigung will nicht: Ich verwende Lubuntu 16.04. und ein Notebook mit NVIDIA GeForce GT 540 M. Aus PPA (ppa:graphics-drivers/ppa) habe ich den Treiber "NVIDIA binary...
  3. [SOLVED][CentOS 7] Samba server nicht erreichbar trotz firewall regeln.

    [SOLVED][CentOS 7] Samba server nicht erreichbar trotz firewall regeln.: Hallo zusammen, ich habe auf einem XenServer (CentOS 7) einen Samba Server installiert und eingerichtet. Ich habe auch entsprechende Regeln in...
  4. Bios erkennt das CDROM nicht (Laptop ASUS)

    Bios erkennt das CDROM nicht (Laptop ASUS): Hallo liebe Forenmitglieder, ich habe das Problem, dass mein Laptop im Bios das CD-Laufwerk nicht mehr anzeigt....Das CD-Laufwerk läuft unter...
  5. User sollen Dateien speichern und ändern, aber nicht neu anlegen dürfen

    User sollen Dateien speichern und ändern, aber nicht neu anlegen dürfen: Hallo liebe Helfer, welche Einstellungen muss ich in der smb.conf bzw. unter Linux vornehmen, damit User vorhandene Dateien öffnen und speichern...