apach2 mod install error ?!

Diskutiere apach2 mod install error ?! im Installation & Basiskonfiguration Forum im Bereich Linux/Unix Allgemein; Hi Leute, ich versuche gerade ein Modul zu installieren für Apache2. Modulname xsendfile. apxs2 -cia mod_xsendfile.c...

  1. #1 foexle, 18.05.2009
    Zuletzt bearbeitet: 18.05.2009
    foexle

    foexle Kaiser

    Dabei seit:
    02.05.2007
    Beiträge:
    1.104
    Zustimmungen:
    0
    Ort:
    Saarbrücken
    Hi Leute,
    ich versuche gerade ein Modul zu installieren für Apache2.
    Modulname xsendfile.

    Code:
    apxs2 -cia mod_xsendfile.c
    
    
    /usr/share/apr-1.0/build/libtool --silent --mode=compile --tag=disable-static x86_64-linux-gnu-gcc -prefer-pic -DLINUX=2 -D_GNU_SOURCE -D_REENTRANT -I/usr/include/apr-1.0 -I/usr/include/openssl -I/usr/include/postgresql -I/usr/include/xmltok -pthread     -I/usr/include/apache2  -I/usr/include/apr-1.0   -I/usr/include/apr-1.0 -I/usr/include/postgresql  -c -o mod_xsendfile.lo mod_xsendfile.c && touch mod_xsendfile.slo
    /usr/share/apr-1.0/build/libtool --silent --mode=link --tag=disable-static x86_64-linux-gnu-gcc -o mod_xsendfile.la  -rpath /usr/lib/apache2/modules -module -avoid-version    mod_xsendfile.lo
    /usr/share/apache2/build/instdso.sh SH_LIBTOOL='/usr/share/apr-1.0/build/libtool' mod_xsendfile.la /usr/lib/apache2/modules
    /usr/share/apr-1.0/build/libtool --mode=install cp mod_xsendfile.la /usr/lib/apache2/modules/
    cp .libs/mod_xsendfile.so /usr/lib/apache2/modules/mod_xsendfile.so
    cp .libs/mod_xsendfile.lai /usr/lib/apache2/modules/mod_xsendfile.la
    PATH="$PATH:/sbin" ldconfig -n /usr/lib/apache2/modules
    ----------------------------------------------------------------------
    Libraries have been installed in:
       /usr/lib/apache2/modules
    
    If you ever happen to want to link against installed libraries
    in a given directory, LIBDIR, you must either use libtool, and
    specify the full pathname of the library, or use the `-LLIBDIR'
    flag during linking and do at least one of the following:
       - add LIBDIR to the `LD_LIBRARY_PATH' environment variable
         during execution
       - add LIBDIR to the `LD_RUN_PATH' environment variable
         during linking
       - use the `-Wl,--rpath -Wl,LIBDIR' linker flag
       - have your system administrator add LIBDIR to `/etc/ld.so.conf'
    
    See any operating system documentation about shared libraries for
    more information, such as the ld(1) and ld.so(8) manual pages.
    ----------------------------------------------------------------------
    chmod 644 /usr/lib/apache2/modules/mod_xsendfile.so
    apxs:Error: Activation failed for custom /etc/apache2/httpd.conf file..
    apxs:Error: At least one `LoadModule' directive already has to exist..
    
    die Libdir für den Linker ist aber gestezt in /etc/ld.so.conf.d/ dieser pfad ist included in /etc/ld.so.conf

    Was mache ich falsch ? Habe ich etwas übersehen ?

    Greetz



    edit: Problem gelöst, manuell angelegtes Load vom Modul.
     
  2. Anzeige

    Schau dir mal diesen Ratgeber an. Dort findest du bestimmt etwas.
    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. foexle

    foexle Kaiser

    Dabei seit:
    02.05.2007
    Beiträge:
    1.104
    Zustimmungen:
    0
    Ort:
    Saarbrücken
    hmm ok das manuelle anlegen des Modules hat es wohl doch nicht gebracht.

    Hat da wer ne lösung für ?

    Gruß
     
  4. #3 bitmuncher, 19.05.2009
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.175
    Zustimmungen:
    3
    Code:
    apxs:Error: Activation failed for custom /etc/apache2/httpd.conf file..
    apxs:Error: At least one `LoadModule' directive already has to exist..
    
    Das Problem dürfte nicht sein, dass das Modul nicht installiert werden kann, sondern dass deine Apache-Konfiguration keine einzige LoadModule-Direktive enthält oder sonst ein Fehler in /etc/apache2/httpd.conf existiert.
     
  5. foexle

    foexle Kaiser

    Dabei seit:
    02.05.2007
    Beiträge:
    1.104
    Zustimmungen:
    0
    Ort:
    Saarbrücken
    httpd.conf ist leer. Da die Modul-Load-Skripte in /etc/apache2/mod-available/ stehen bzw enabled wenn sie aktiviert wurden.
     
  6. #5 bitmuncher, 19.05.2009
    bitmuncher

    bitmuncher Der Stillgelegte

    Dabei seit:
    08.05.2007
    Beiträge:
    3.175
    Zustimmungen:
    3
    Wird denn /etc/apache2/mods-enabled/* irgendwo inkludiert? Scheinbar ja nicht, sonst würden diese Fehler nicht kommen.
     
Thema:

apach2 mod install error ?!

Die Seite wird geladen...

apach2 mod install error ?! - Ähnliche Themen

  1. Apach22 mit mod_bw

    Apach22 mit mod_bw: Moin Ich habe vor 2 Tagen meinen Apache13+mod_ssl auf Apache22 umgestellt. Auf dem Apache13 hatte ich eine Upload Bandbreite von 100K mit...
  2. Arch Installierung - Grub-Installations-Error

    Arch Installierung - Grub-Installations-Error: Hallo Community :), Mein Problem: Ich habe nun seit einiger Zeit schon ein Problem bei meiner Arch-Installation mit Grub, welches sich nicht...
  3. Squid einrichten und installieren?

    Squid einrichten und installieren?: Hi Ich kenne mich 0 aus mit irgend welchen Linux Distributionen. Klar am Router rennt ein angepasstes OS und Android auch aber der "normale"...
  4. Bootprobelem nach Installtion von obrevenge

    Bootprobelem nach Installtion von obrevenge: [gelöst]Hallo ich habe ein blödes Problem, das m.W. schon mehrfach bei Installationen (afaik nur bei Arch) von einer HDD installation per Livecd...
  5. Installation von COM Ports unter Unix

    Installation von COM Ports unter Unix: Hallo, vorne weg, ich habe von Linux nur Grundkenntnisse und bitte daher etwas um Rücksicht, wenn ich doofe fragen stelle;). Zum Problem: Es gibt...