Alt-Gr-Taste reagiert nicht mehr

Diskutiere Alt-Gr-Taste reagiert nicht mehr im Eingabegeräte Forum im Bereich Hardware; Hallo. Ich habe gerade feststellen, dass nach dem durch startx folgenden Start von Fluxbox meine Alt-Gr-Taste nicht mehr geht. Wenn ich sie vor...

  1. n00bie

    n00bie GESPERRT

    Dabei seit:
    25.04.2003
    Beiträge:
    90
    Zustimmungen:
    0
    Hallo.
    Ich habe gerade feststellen, dass nach dem durch startx folgenden Start von Fluxbox meine Alt-Gr-Taste nicht mehr geht. Wenn ich sie vor startx benutze, dann funktioniert sie einwandfrei.

    loadkeys de-latin1 und und das umstellen der keymap auf de in der /etc/rc.conf bringt alles nichts. Das komische ist eben, dass ausschliesslich diese Taste betroffen ist.
    Manchmal, wenn ich starte, kann ich nichtmal mehr das "sz" schreiben, da (so wie jetzt) die Alt-Gr-Taste dauerhaft gedrueckt zu sein scheint und ich deshalb nur den backslash schreiben kann. Hinzu kommt dann noch, dass als meine Umlaute mit anderen Zeichen belegt sind.

    Es ist einfach nur r]tselhaft f@r mich (so sieht das aus wenn ich ae und ue druecke), dass scheinbar ein vollkommen falsches charset gesetzt wird, bei dem ich nichtmal die Alt-Gr-Taste benutzen kann, und ausserdem das charset auch nciht aendern kann.

    Waere hilfreich wenn jemand eine Idee zur Loesung haette, so lang werde ich noch ae, ue, oe tippen :)

    Danke und sch[nen Abend noch.
     
  2. Anzeige

    Anzeige

    Wenn du mehr über Linux erfahren möchtest, dann solltest du dir mal folgende Shellkommandos anschauen.


    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
  3. n00bie

    n00bie GESPERRT

    Dabei seit:
    25.04.2003
    Beiträge:
    90
    Zustimmungen:
    0
    *schieb*
     
  4. Cyber

    Cyber .:DISTORTED:.

    Dabei seit:
    16.05.2003
    Beiträge:
    999
    Zustimmungen:
    0
    So, ich hab mittlerweile das gleiche Problem und es suckt !!!
     
  5. #4 qmasterrr, 21.10.2004
    qmasterrr

    qmasterrr Foren Gott

    Dabei seit:
    01.01.2004
    Beiträge:
    2.735
    Zustimmungen:
    0
    bei mir klappt alles noch.... was habt ihr den zuletzt gemacht? irgendwelche updates?
     
  6. fossy

    fossy - dead -

    Dabei seit:
    26.03.2004
    Beiträge:
    274
    Zustimmungen:
    0
    mit sicherheit die 105. taste ;)

    reconfiguriert mal euren xserver.

    gruss, fossy.
     
  7. #6 qmasterrr, 21.10.2004
    qmasterrr

    qmasterrr Foren Gott

    Dabei seit:
    01.01.2004
    Beiträge:
    2.735
    Zustimmungen:
    0
    also denn ich zuwenige tasten eingestellt habe klappen bei mir die > < tasten auch nicht und das fällt ja doch recht schnell auf.
     
  8. Cyber

    Cyber .:DISTORTED:.

    Dabei seit:
    16.05.2003
    Beiträge:
    999
    Zustimmungen:
    0
    Das ganze hatte vor kurzem angefangen als ich den Rechner gebootet hab, ohne dass vorher updates oder installationen liefen.
    Auf den Consolen funktioniert die die ALT+GR Taste, nur unter X nicht. Ich werd mal ne reconfig machen. Ich hatte gestern auch mal spassehalber im yast nachgeschaut was da für ein Layout eingetragen ist. Witzigerweisse war das Feld leer und ich konnte auch nix einstellen. Werd das heute aber nochmals probieren.
     
  9. fossy

    fossy - dead -

    Dabei seit:
    26.03.2004
    Beiträge:
    274
    Zustimmungen:
    0
    kommt drauf an, wieviel <html> man schreibt ;)

    @[n00bie|Cybermarc]: geht die <, >, | -taste?

    und lasst mal raten... debian sid, oder?

    gruss, fossy.
     
  10. #9 Lord Kefir, 21.10.2004
    Lord Kefir

    Lord Kefir König

    Dabei seit:
    10.06.2004
    Beiträge:
    945
    Zustimmungen:
    0
    Welchen X-Server benutzt ihr eigentlich?
     
  11. #10 fossy, 21.10.2004
    Zuletzt bearbeitet: 21.10.2004
    fossy

    fossy - dead -

    Dabei seit:
    26.03.2004
    Beiträge:
    274
    Zustimmungen:
    0
    gib uns mal nen ...
    Code:
    grep -Hn Xkb /etc/X11/XF86Conf*
    fossy.
     
  12. Cyber

    Cyber .:DISTORTED:.

    Dabei seit:
    16.05.2003
    Beiträge:
    999
    Zustimmungen:
    0
    Nö, SuSE 9.0 ideal standard !
    Es gehen alle Tasten, ausser die ALT+GR, d.h. ich kann keine Sonderzeichen wie @,|, µ, @, [, ], {, } machen. Ich hab mir die Zeichen jetzt alle schon in ne datei geschrieben die ich dann per copy&paste da einfüge wo ich sie brauche.

    Bin grad noch im Büro, kann deshalb nicht gleich auf meiner Kiste nachschauen.
     
  13. Cyber

    Cyber .:DISTORTED:.

    Dabei seit:
    16.05.2003
    Beiträge:
    999
    Zustimmungen:
    0
    Code:
    /etc/X11/XF86Config:90:  Option       "XkbLayout" "de"
    /etc/X11/XF86Config:91:  Option       "XkbModel" "pc105"
    /etc/X11/XF86Config:92:  Option       "XkbRules" "xfree86"
    /etc/X11/XF86Config:93:  Option       "XkbVariant" "nodeadkeys"
    
    /etc/X11/XF86Config-azrael:90:  Option       "XkbLayout" "de"
    /etc/X11/XF86Config-azrael:91:  Option       "XkbModel" "pc105"
    /etc/X11/XF86Config-azrael:92:  Option       "XkbRules" "xfree86"
    /etc/X11/XF86Config-azrael:93:  Option       "XkbVariant" "nodeadkeys"
    
    So schauts aus in der XF86 config.
     
  14. #13 Luzifer, 21.10.2004
    Luzifer

    Luzifer Schachspieler

    Dabei seit:
    09.03.2004
    Beiträge:
    540
    Zustimmungen:
    0
    ihr könnt anstatt alt gr auch strg + alt benutzen ;)
     
  15. fossy

    fossy - dead -

    Dabei seit:
    26.03.2004
    Beiträge:
    274
    Zustimmungen:
    0
    sieht doch gesund aus.

    dann bitte noch mal nen cat /var/log/XFree86* | grep keymap

    glaube, dann haben wir das problem eingekreist ;)

    gruss, fossy.
     
  16. Cyber

    Cyber .:DISTORTED:.

    Dabei seit:
    16.05.2003
    Beiträge:
    999
    Zustimmungen:
    0
    Couldn't load XKB keymap, falling back to pre-XKB keymap ;)
     
  17. fossy

    fossy - dead -

    Dabei seit:
    26.03.2004
    Beiträge:
    274
    Zustimmungen:
    0
    bingo !

    Code:
    xmodmap -e "keycode 113 = Mode_switch"  #AltGr als Mode_switch
    xmodmap -e "keycode 16 = 7 slash braceleft" #geschweifte Klammer auf
    xmodmap -e "keycode 17 = 8 parenleft bracketleft" #eckige Klammer auf
    xmodmap -e "keycode 18 = 9 parenright bracketright" #eckige Klammer zu
    xmodmap -e "keycode 19 = 0 equal braceright" #geschweifte Klammer zu
    xmodmap -e "keycode 20 = ssharp question backslash" #Backslash
    xmodmap -e "keycode 24 = q Q at" #@
    xmodmap -e "keycode 26 = e E currency" #Euro
    xmodmap -e "keycode 35 = plus asterisk asciitilde" #Tilde
    xmodmap -e "keycode 54 = c C cent" #¢
    xmodmap -e "keycode 94 = less greater bar" #bar
    
    dann nen strg + alt + backspace.

    neu anmelden -> und geht?
     
  18. #17 fossy, 22.10.2004
    Zuletzt bearbeitet: 22.10.2004
    fossy

    fossy - dead -

    Dabei seit:
    26.03.2004
    Beiträge:
    274
    Zustimmungen:
    0
    ... und in bad und wc ist alles ok ! *rofl*

    [​IMG]

    p.s.: diesen beitrag darf man bei niedrigem reitzpegel gerne ignorieren.
     
  19. Cyber

    Cyber .:DISTORTED:.

    Dabei seit:
    16.05.2003
    Beiträge:
    999
    Zustimmungen:
    0
    rofl, jo. Aber ich glaub ich nehm gleich ma nen zöllisches Rohr und hau auf die Kiste.

    Jedenfalls ist da am System was nicht koscher, denn nachdem ich per xmodmap die Sachen reingeklopft und den X-Server neu gestartet hab (auch mal direkt ueber runlevel-wechsel) braucht er (also der X-Server :) ) ewig lange um zu starten. Das Ergebnis: geht immer noch nicht. Nochmals nachgeschaut, immer noch "Couldn't load XKB keymap, falling back to pre-XKB keymap".
     
  20. fossy

    fossy - dead -

    Dabei seit:
    26.03.2004
    Beiträge:
    274
    Zustimmungen:
    0
    nen neues xmodmap oder so. seit xfree 4.3 gibts die probleme

    vergleich mal den absatz in der /usr/X11R6/lib/X11/xkb/keymap/xfree86
    Code:
    xkb_keymap "de" {
        xkb_keycodes        { include "xfree86"             };
        xkb_types           { include "default"             };
        xkb_compatibility   { include "default"             };
        xkb_symbols         { include "en_US(pc105)+de"     };
        xkb_geometry        { include "pc(pc102)"           };
    };
     
  21. Cyber

    Cyber .:DISTORTED:.

    Dabei seit:
    16.05.2003
    Beiträge:
    999
    Zustimmungen:
    0
    Das sieht bei mir genauso aus, keine differenz. Du sagst seit xfree 4.3 gibts die probleme. Ist das tatsächlich so, das es vom einen auf den anderen Tag nicht mehr geht oder eher von Anfang an?
     
Thema:

Alt-Gr-Taste reagiert nicht mehr

Die Seite wird geladen...

Alt-Gr-Taste reagiert nicht mehr - Ähnliche Themen

  1. Canonical reagiert auf den Unmut zur Abmahnung von »Fix Ubuntu«

    Canonical reagiert auf den Unmut zur Abmahnung von »Fix Ubuntu«: Mark Shuttleworth hat sich in einer Verlautbarung entschuldigt, das Unternehmen sei in Sachen »Fix Ubuntu« über das Ziel hinausgeschossen....
  2. Die erste Zeile der Buchstabentasten reagiert nicht.

    Die erste Zeile der Buchstabentasten reagiert nicht.: Hallo, Ich habe Probleme mit der Tastatur meines MACs. Diese Mail musste ich mit viel copy+paste schreiben. Die Tasten...
  3. Die erste Zeile der Buchstabentasten reagiert nicht.

    Die erste Zeile der Buchstabentasten reagiert nicht.: :brav:Hallo, Ich habe Probleme mit der Tastatur meines MACs. Diese Mail musste ich mit viel copy+paste schreiben. Die Tasten...
  4. Speedlink Keyboard reagiert nicht mehr ...

    Speedlink Keyboard reagiert nicht mehr ...: Hallo, ich habe ein Problem mit meinem Speedlink USB Keyboard. Es hat einfach ploetzlich aufgehoert zu funktionieren. Die Batterien sind...
  5. /etc/init.d/interfaces reagiert nicht

    /etc/init.d/interfaces reagiert nicht: Hallo Nach einenm Neustart sind meine Netzwerkadapter nicht mehr vorhanden, weder lo noch eth0. Vorher hat alles funktioniert! Es ist ein...
  1. Diese Seite verwendet Cookies um Inhalte zu personalisieren. Außerdem werden auch Cookies von Diensten Dritter gesetzt. Mit dem weiteren Aufenthalt akzeptierst du diesen Einsatz von Cookies.
    Information ausblenden