3 Soundkarten - Probleme mit Soundwiedergabe in Amarok, KDE, und co.

mightymike1978

Grünschnabel
Beiträge
4
+ + + + GELÖST + + + +

Hi Leute,

ich habe untenstehendes Problem durch eingehende Durchforstung der Documentation von www.alsa-project.org lösen können.

Leider stand es nicht dort, wo es hätte stehen sollen... ;-)

Das Problem lag an einer falschen Einstellung in der /usr/share/alsa/alsa.conf

Bei mir soll ja die Soundkarte hw:0,0 laufen.

In der alten Fassung meiner '"alsa.conf" stand dort im Abschnitt: " # defaults "
defaults.ctl.card 1
defaults.pcm.card 1
defaults.pcm.device 1
defaults.pcm.subdevice -1
(...)
sic!!!

Nach Änderung in:
defaults.ctl.card 0
defaults.pcm.card 0
defaults.pcm.device 0
defaults.pcm.subdevice -1
funktioniert alles reibungslos!

ROMA VICTOR!!!

Achtung: Ich habe allerdings auch noch in den Verzeichnissen "/root/" und "/home/<benutzername>" eine .asoundrc mit folgendem Inhalt:
pcm.ice1712 {
type hw
card 0
}

ctl.ice1712 {
type hw
card 0
}
angelegt.

Ich vermute aber, dass die Änderung der alsa.conf mein Problem letztlich gelöst hat.

-----

Trotzdem hier meine Support-Anfrage:

Hi Leute,

ich setze Kubuntu Dapper Drake 6.0.6 LTS ein.

Ich habe Probleme mit dem Sound!

ich habe drei Soundkarten:

snd-ice1712 M-Audio Delta 24/96
snd-cs46xx Terrortec DMX 1024fire
snd-via8235 onboard AC'97 Chip

Allesamt für sich korrekt installiert ("# aplay <soundkarte Nr. 1 bis 3> wavedatei.wav" funktioniert bei jeder Karte!)

Die Reihenfolge habe ich schon geändert. Die M-Audio wird nun im Programm "Infozentrum" nun korrekt als "Device 0" angezeigt.

Aber irgendwie scheint sich Amarok gezielt immer die Onboard-Karte zu grapschen.

Auch bei "# amixer"erscheint immer die Drecksonboard-Karte.

Ich habe versucht in der "/etc/modprobe.d/alsa-base" die Reihenfolge zu erzwingen, aber das funktioniert nicht.

Die Soundkarten funktionieren - jede für sich betrachtet - korrekt.

Es kann auch kein Konflikt vorliegen, da lediglich eine einzige Andwendung auf den Sound zugreift.

KMix zeigt die M-Audio als Hauptkarte an.

Bitte teilt mir doch mal mit,
in welcher Abhängigkeit
in welchen Dateien ALSA-Module für KDE geladen werden.

D.h. wo kann ich ALSA (bestenfalls system- und nicht nur nutzerweit) konfigurieren???

Ich bin als erfahrener Windows-User und absoluter Linux Anfänger doch ein wenig irritiert...:think:

Notfalls sagt mir, wie ich diese anderen Scheiss-Soundkarten deaktivieren kann!
(Ich brauche sie aber unter Windows!!! Die Holzhammer-Methode Marke "Rausrupfen" ist nicht! :) )

BTW: Im BIOS die Onboard-Karte zu deaktivieren würde mir bei 3 Soundkarten leider nix nutzen...

Die m.E. relevanten Dateien habe ich Euch angehängt.

Beste Grüße

Michael

PS:
Zusatzfrage:
Wieso kann ich in "Amarok" die Xine-Engine-Parameter nicht so umfassend ändern wie in "Kaffeine"?

Für Suchmaschinen, falls Leute dasselbe Problem haben:
Midiman delta-series, audiophile 2496, Amarok, Kaffeine, ALSA, XINE, Kubuntu, Arts, stumm, kein sound,
 

Anhänge

  • modules.txt
    218 Bytes · Aufrufe: 1
  • modprobe_conf.txt
    275 Bytes · Aufrufe: 0
  • alsa_base.txt
    1,6 KB · Aufrufe: 2
Zuletzt bearbeitet:

theborg

KBitdefender Programierer
Beiträge
688
bei amarok kanste es mit der xine engin machen da auft alsa stellen oder oss dann kanste die soundkarte angeben z.b. /dev/dsp1
 

Ähnliche Themen

PulseAudio sound nur bei MPD

Pulseaudio unter Debian multiple Output

HDMI Soundausgabe 2

HDMI Soundausgabe

HDMI Audio macht Probleme

Oben