3 Probleme/Fehlermeldungen wo ich nicht mehr weiter kommen tu! (glib, xmms, autoconf)

Diskutiere 3 Probleme/Fehlermeldungen wo ich nicht mehr weiter kommen tu! (glib, xmms, autoconf) im Anwendungen Forum im Bereich Linux/Unix Allgemein; hi... gleich vorweg, ich gehöre auch zu den newbies, die nix peilen hab mein linux erst seit zwei tagen drauf und deshalb ... SORRY!!!!...

  1. Yoel

    Yoel Grünschnabel

    Dabei seit:
    05.02.2006
    Beiträge:
    2
    Zustimmungen:
    0
    hi...

    gleich vorweg, ich gehöre auch zu den newbies, die nix peilen hab mein linux erst seit zwei tagen drauf und deshalb ... SORRY!!!!

    jetzt zum ersten problem / fehlermeldung:

    mein hauptproblem hängt eigentlich mit glib zusammen... ich hab die mandriva 10.1 distri drauf und schaff es einfach nicht glib richtig zu installieren! als erstes hab ich die "glibc-2.3.3-21mdk.i586.rpm" verwendet... da wird aber irgendwie keine glib-2.0.pc datei installiert... jedenfalls kann ich unter locate glib-2.0.pc nix finden... also hab ich mir eine tar.gz geholt glib-2.8.5.tar.gz die hab ich dann extrahiert und per dreisatz installiert... so... jetzt ist die glib-2.0 auch im pkgconfig ordner drin! trotzdem bekomme ich diese fehlermeldung bei installationen die glib-2.0 abhängig sind (z.B. XMMS)

    Code:
    checking for BASE_DEPENDENCIES... Package glib-2.0 was not found in the pkg-config search path.
    Perhaps you should add the directory containing `glib-2.0.pc'
    to the PKG_CONFIG_PATH environment variable
    No package 'glib-2.0' found
    configure: error: Package requirements (glib-2.0 >= 2.8.5    atk >= 1.0.1    pango >= 1.9.0    cairo >= 0.9.2) were not met.
    Consider adjusting the PKG_CONFIG_PATH environment variable if you
    installed software in a non-standard prefix.
    
    Alternatively you may set the BASE_DEPENDENCIES_CFLAGS and BASE_DEPENDENCIES_LIBS environment variables
    to avoid the need to call pkg-config.  See the pkg-config man page for
    more details.
    
    ich habe dann mit export PKG_CONFIG_PATH=adresse/zur/glib-2.0.pc/ auch den search path mit eingegeben... hat aber auch nix gebracht... kommt genau das gleiche wie oben... er sagt, dass er kein glib-2.0 package gefunden hat... ?(

    da man glib aber ja bei vielen vielen programmen benötigt, wär ich um schnelle hilfe sehr dankbar... kann nix installieren auf meinem system!!! :(

    das zweite problem

    wenn ich glib-1.0 per glib-1.2.9.tar.gz installieren will bringt er auch eine fehler meldung beim kompilieren... zuerst läuft alles gut und irgendwann dann das hier:

    Code:
    gstrfuncs.c: In function `g_printf_string_upper_bound':
    gstrfuncs.c:870: error: syntax error before string constant
    gstrfuncs.c:1037: error: syntax error before string constant
    gstrfuncs.c:1080: error: syntax error before string constant
    gstrfuncs.c:1111: error: syntax error before string constant
    make[2]: *** [gstrfuncs.lo] Fehler 1
    make[2]: Leaving directory `/home/yoel/Desktop/Linux/Library/Glib/1.2.9/glib-1.2.9'
    make[1]: *** [all-recursive] Fehler 1
    make[1]: Leaving directory `/home/yoel/Desktop/Linux/Library/Glib/1.2.9/glib-1.2.9'
    make: *** [all-recursive-am] Fehler 2
    
    kann ich auch leider gar nix mit anfangen!

    das dritte problem:

    ich möchte Autoconf 2.5-2.59 per rpm installieren... dann kommt aber diese fehlermeldung mit der ich allerdings gar nichts anfangen kann:

    Code:
    Einige der gewünschten Pakete können nicht installiert werden:
    autoconf2.5-2.59-6mdk.noarch (wegen unbefriedigter autoconf2.1 )
    Sind Sie einverstanden? 
    hmmm... sehr strange... ich habe diese fehlermeldung hier im forum schonmal gesehen aber da habe ich nicht verstanden, wie ich das problem anpacken kann...

    ich hoffe (ich weiß ihr könnt :D ) ihr könnt mir helfen!!!!

    vielen dank :))
     
  2. Anzeige

    Anzeige

    Wenn du mehr über Linux erfahren möchtest, dann solltest du dir mal folgende Shellkommandos anschauen.


    Registrieren bzw. einloggen, um diese und auch andere Anzeigen zu deaktivieren
Thema:

3 Probleme/Fehlermeldungen wo ich nicht mehr weiter kommen tu! (glib, xmms, autoconf)

Die Seite wird geladen...

3 Probleme/Fehlermeldungen wo ich nicht mehr weiter kommen tu! (glib, xmms, autoconf) - Ähnliche Themen

  1. PHP7.3 - cURL 7.0 Backport nicht möglich nach Debian Upgrade

    PHP7.3 - cURL 7.0 Backport nicht möglich nach Debian Upgrade: Guten Morgen Gemeinde, ich habe auf einem prduktiven Webserver ein step by step Upgrade von der oldstable zur stable Ausgabe von Debian...
  2. Aktualisierung nicht möglich

    Aktualisierung nicht möglich: Hallo an alle ich habe momentan Probleme mit der neuen Version 2019.2. Wenn ich das System auf meine VM setzte habe ich erst mal keine Probleme...
  3. Zugriff Ubuntu 16.04. auf Freigabe 18.04. LTS nicht möglich

    Zugriff Ubuntu 16.04. auf Freigabe 18.04. LTS nicht möglich: Hallo, ich habe meinen Fileserver erneuern müssen, Umstellung auf 18.04. LTS! Ich habe eine Freigabe auf dem Fileserver A = FreigabeServer...
  4. "dnsmasq" als relay einrichten, jedoch nicht als prim. DNS verwenden?

    "dnsmasq" als relay einrichten, jedoch nicht als prim. DNS verwenden?: Hallo zusammen! Weiss jemand von euch, wie man "dnsmasq" als relay einrichten, jedoch nicht als prim. DNS verwenden kann? Also so einrichten,...
  5. Menüs von vielen Programmen werden nach Aufrufen nicht angezeigt

    Menüs von vielen Programmen werden nach Aufrufen nicht angezeigt: Hallo Forum, lange ist es her, dass ich eure Hilfe brauchte. Jetzt habe ich aber ein Problem, dass ich mit Hilfe von Suchmaschinen und Foren nicht...
  1. Diese Seite verwendet Cookies um Inhalte zu personalisieren. Außerdem werden auch Cookies von Diensten Dritter gesetzt. Mit dem weiteren Aufenthalt akzeptierst du diesen Einsatz von Cookies.
    Information ausblenden