Seite 1 von 2 12 LetzteLetzte
Ergebnis 1 bis 15 von 27

Thema: Sapphire RADEON 9600 und Linux Treiber

  1. #1
    Jungspunt
    Registriert seit
    02.05.2004
    Beiträge
    10

    Sapphire RADEON 9600 und Linux Treiber

    Hallo!

    Da im Suse-Plugger unter anderem meine Sapphire Radeon 9600 Grafikkarte noch als "Unbekannt" gelistet ist,und wohl nur der 2D Grafiktreiber installiert ist,wollte ich nun den Treiber auf der ATI Homepage runterladen.

    Hier stehen 3 Versionen zur Verfügung,je nachdem was man für eine Xfree86 Version hat.

    Hab mir gedacht,nimm einfach einen und gut ist *g*

    Leider war das genau falsch,system kaputt.
    Da es aber eh frisch installiert war,habe ich 20 Minuten geopfert und eine Neuinstallation durchgeführt.

    Nun habe ich per Kommando "XFree86 -version" herausgefunden das ich unter Suse Linux 9.1 die Version "XFree86 Version 4.3.99.902 (4.4.0 RC 2)" habe.

    Nun meine Frage,welche Driver nehme ich da genau?

    Den 4.3.0 denke ich mal ?!

    Frage nur so vorsichtig,weil ich nicht noch einmal Lust auf Neuinstall habe *g*

  2. #2
    Pro*phet Avatar von devilz
    Registriert seit
    01.05.2002
    Ort
    Hessen
    Beiträge
    12.242
    Hmmm .. hatt SuSE den Ati Treiber nich auf dem FTP liegen ?

    Mom- ich schau mal nach ...

    Edit :

    ftp://ftp.suse.com/pub/suse/i386/sup.../X/XFree86/ATI

    Hmm .. ok für die 9.1er mußte wohl die Treiber von der ATI seite nehmen. Für 4.3 sollte laufen.

  3. #3
    Jungspunt
    Registriert seit
    02.05.2004
    Beiträge
    10
    So folgendes Problem, erstmal die Installationsanleitung:

    Installing ATI 'fglrx' driver (3.7.6) on SuSE 9.0
    -------------------------------------------------

    The following instructions explain how to install and enable release
    3.7.6 of this driver.

    The driver supports RV250, RV280, R200, RV350, R300, R350 chipsets of
    ATI. Popular boards using these chipsets are:

    - ATI Radeon 8500 / 9100
    - ATI FireGL 8700 / 8800 / E1
    - ATI FireGL T2
    - ATI Radeon 9000
    - ATI Radeon 9200
    - ATI Radeon 9500
    - ATI Radeon 9600
    - ATI Radeon 9700
    - ATI Radeon 9800
    - ATI FireGL Z1 / X1 / X2
    - ATI Mobility M9
    - ATI Mobility FireGL 9000
    - ATI Mobility M9PLUS

    HOWTO
    -----

    1) Update XFree86 drivers

    # rpm -Uhv fglrx*.rpm


    2) Update kernel module

    * prepare kernel module build

    - install 'kernel-source' package with YaST

    * install kernel module source

    # rpm -Uhv km_fglrx*.rpm

    * compile kernel module sources

    # cd /usr/src/kernel-modules/fglrx
    # make -f Makefile.module
    # make -f Makefile.module install

    Kernel 2.6 users

    * You'll need to compile and install the DRM kernel module with

    pushd /usr/src/kernel-modules/drm
    KERNEL_SOURCE=/usr/src/linux make modules
    KERNEL_SOURCE=/usr/src/linux make install
    popd

    * Please note that kernels, which are built with kernel option
    CONFIG_REGPARM (enabled in SuSE kernels since version 2.6.2-0)
    currently are not supported. You'll get the following error message
    when trying to load the kernel module:

    # modprobe fglrx
    FATAL: Error inserting fglrx
    (/lib/modules/2.6.2-3-default/kernel/drivers/char/drm/fglrx.ko): Bad address

    We are working together with ATI to provide a fix.


    3) Configure X11

    # sax2 -r -m 0=fglrx -b /usr/X11R6/lib/sax/profile/firegl


    4) Enable 3D support

    * edit /etc/X11/XF86Config with your favorite editor

    - add

    Load "dri"

    to Section "Module"

    * nforce2 systems:
    - add 'Option "UseInternalAGPGART" "no"' to 'Section "Device"' of
    "/etc/X11/XF86Config"
    - add 'pre-install fglrx /sbin/modprobe "-k" "agpgart"' to
    "/etc/modules.conf"

    5) Known Issues

    - driver only supports 24bit color depth
    - enabling of 3D support through SaX2 does not work

    !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! !!!!!!!!!!!!!!!!!!!!!!!!!!!!!

    PLEASE NOTE THAT THERE IS NO WARRANTY AND THAT WE DO NOT PROVIDE SUPPORT
    FOR THESE PACKAGES!

    PLEASE USE "http://www.suse.de/feedback" FOR ANY FEEDBACK.

    !!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! !!!!!!!!!!!!!!!!!!!!!!!!!!!!!
    Also bis hierhin hat alles geklappt :

    1) Update XFree86 drivers

    # rpm -Uhv fglrx*.rpm


    2) Update kernel module

    * prepare kernel module build

    - install 'kernel-source' package with YaST
    Aber mit dem nächsten Schritt,bzw Befehlen komme ich ehrlich gesagt nicht klar.

    Im KDE Startmenü war zu diesem Zeitpunkt schon das ATI Control Panel....
    Habe dann die Sitzung beendet und als Standard User wieder in das System geloggt....

    Zumindest wollte ich das,aber Linux startet nun im Textmodus,da der X Server nicht gefunden wird.

    Kann mir da nun jemand weiterhelfen wie ich das wieder hinbekomme ?

  4. #4
    Foren As
    Registriert seit
    15.03.2004
    Beiträge
    79
    du musst "fglrxconfig" aufrufen (ist wie xf86config, nur von ati speziell für den treiber), danach sollte alles wieder funzen!
    Ich kam, sah und traute meinen Augen nicht...

  5. #5
    Jungspunt
    Registriert seit
    18.05.2004
    Beiträge
    13
    Hallo,

    kann mir einer diesen Befehl genauer erklären? Muss ich ihn in der Konsole eingeben?

    Habe genau die selbe Grafikkarte und hatte sie nicht richtig zum laufen gebracht. Weder mit Suse, Mandrake und Redhat. Jedes mal sagte er mir es ist keine "FIRE GL..." gefunden worden. Deswegen habe ich Linux wieder gelöscht, weil das der einzige Grund ist der mich vor dem komplett umsteigen noch aufhält.

    Zur Zeit habe ich kein Linux drauf um es zu testen, installiere es aber die Tage wieder.

    Danke im vorraus!

  6. #6
    Foren As
    Registriert seit
    15.03.2004
    Beiträge
    79
    hi derevil!

    ich bin dir gerne bei der installation behilflich allerdings müsste ich dazu wissen, welche distribution du verwendest!

    cu, raphael
    Ich kam, sah und traute meinen Augen nicht...

  7. #7
    Jungspunt
    Registriert seit
    18.05.2004
    Beiträge
    13
    Hi,

    danke schonmal für deine Hilfe. Werde demnächste Redhat Enterprise Linux ES v3.0 benutzen.

    Habe hier noch direkt Suse 8.1/9.0 und Mandrake 9.2 liegen, falls die sich besser dazu eignen.
    Geändert von derevil (19.05.2004 um 19:22 Uhr)

  8. #8
    Foren As
    Registriert seit
    15.03.2004
    Beiträge
    79
    okay, wenn du soweit bist, kannst du dich ja hier melden oder mich direkt per pm anschreiben

    cu, raphael
    Ich kam, sah und traute meinen Augen nicht...

  9. #9
    Jungspunt
    Registriert seit
    18.05.2004
    Beiträge
    13
    Habe jetzt Mandrake 9.1 installiert (War doch nur die 9.1 ;-)).
    Versuche es jetzt mal einzustellen.

    Update: Lustig, lustig.... Jetzt kann ich den Treiber noch nicht mals installieren. Wenn ich das rpm. Packet installiert möchte erscheint immer diese Fehlermeldung:

    Während der Packet installation trat ein fehler auf:

    Während der isntallation sind Fehler aufgetreten:
    /usr/X11R6/lib/libGL.so.1.2 from install of fglrx-4.3.0-3.7.6 conflicts with file from package XFree86-libs-4.3.5mdk


    Das ist eine total frische installation, nichts habe ich daran verändert. Es ist so wie Mandrake 9.1 von Haus aus ist! Mal als Root ausprobieren...
    Geändert von derevil (20.05.2004 um 23:53 Uhr)

  10. #10
    Jungspunt
    Registriert seit
    18.05.2004
    Beiträge
    13
    Ne Leute, ich habe die Schnauze voll von Linux. Habe gerade versucht die Updates zu installieren die man vom Server abrufen kann. Was ist? Eine riesen Liste mit Konflikten. Was soll der scheiss?

    Ich kann rein garnichts installieren, immer konflikte... Dann kann ich darauf auch verzichten...

  11. #11
    Jungspunt
    Registriert seit
    18.05.2004
    Beiträge
    13
    Nachdem ich den Frust über nach abgebaut habe, habe ich mich entschlossen nochmal Linux zu installierejn. Habe vorhin jetzt auch Mandrake 9.2 gefunden... Wusste ich es doch das ich es habe. Hoffe damit habe ich nicht so viele Probleme.

  12. #12
    Jungspunt
    Registriert seit
    18.05.2004
    Beiträge
    13
    Ich konnte diesmal alle Updates ohne Probleme isntallieren.
    Doch beim Grafikkartentreiber kommt wieder folgende Fehlermeldung:

    Die Installation schlug Fehl:
    file /usr/X11R6/lib/libGL.so.1.2 from install of fglrx-4.3.0-3.7.6 conflicts with file from package libxfree86-4.3-24.4.92mdk


    Was soll ich tuhen, dass eine Packet deinstallieren?


    Update: Deinstallieren ist nicht so einfach. Damit müsste ich zusätzlich 609mb entfernen, unteranderem OpenOffice etc. Was kann ich machen? Bin ratlos...
    Geändert von derevil (21.05.2004 um 12:47 Uhr)

  13. #13
    Foren As
    Registriert seit
    15.03.2004
    Beiträge
    79
    auf der seite von ati wird die installation ja eigentlich genau beschrieben:
    http://www.ati.com/support/infobase/linuxhowto-ati.html
    probier mal die befehle dort der reihe nach auszuführen und falls es probleme gibt, postest du bitte die fehlermeldung(en).
    Ich kam, sah und traute meinen Augen nicht...

  14. #14
    Jungspunt
    Registriert seit
    18.05.2004
    Beiträge
    13
    Habe die Schritte gemacht, aber er sagt mir das die Grafikkarte garnicht vorhanden ist?!

    *** Trying to install a precompiled kernel module.
    *** WARNING ***
    Tailored kernel module for fglrx not present in your system.
    You must go to /lib/modules/fglrx/build_mod subdir
    and execute './make.sh' to build a fully customed kernel module.
    Afterwards go to /lib/modules/fglrx and run './make_install.sh'
    in order to install the module into your kernel's module repository.
    (see readme.txt for more details.)

    As of now you can still run your XServer in 2D, but hardware acclerated
    OpenGL will not work and 2D graphics will lack performance.

    failed.
    *** Error: no kernel module build environment - please consult readme.
    Installed: qt3 (gcc 3.2) based control panel application
    ===
    ATI display drivers successfully installed
    please run 'fglrxconfig' now

  15. #15
    Jungspunt
    Registriert seit
    18.05.2004
    Beiträge
    13
    Bin dann in den Ordner /lib/modules/fglrx/build_mod gegangen und habe die make.sh ausgeführt und dann kam folgende Fehlermeldung:

    initializing...
    kernel includes at /usr/src/linux/include not found or incomplete
    file: /usr/src/linux/include/linux/version.h
    Wo bekomme ich die Datei her, da die anscheinend fehlt?!

    Update: Die Datei gibt es tastätlich nicht, es gibt noch nicht mals der Ordner /linux. Wo bekomme ich die Datei her, damit ich selber sie dort reinpacken kann?

Ähnliche Themen

  1. MObility M10 (mobility Radeon 9600) unter Linux
    Von Anakin77 im Forum Linux OS
    Antworten: 2
    Letzter Beitrag: 23.01.2004, 14:59
  2. Antworten: 0
    Letzter Beitrag: 05.02.2003, 12:30

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •