Ergebnis 1 bis 3 von 3

Thema: Pulseaudio unter Debian multiple Output

  1. #1
    BOFH Avatar von janis
    Registriert seit
    02.09.2007
    Ort
    Deutschland
    Beiträge
    179

    Pulseaudio unter Debian multiple Output

    Hallo,

    ich habe ein Problem mit meinem Pulseaudio Server (0.9.21-3) unter Debian Squeeze. Und zwar habe ich eine Soundkarte mit analogem und digitalem Ausgang (Intel HD Audio - Sandy Bridge). Damit ich die zum Laufen bringen konnte, habe ich mir von alsa-project.org die 1.0.25 Versionen vom Driver, den Libs und den Plugins heruntergeladen und kompilliert. Danach hatte und habe ich auch Sound über beide Ausgänge. Nun möchte ich aber mehr als nur eine Soundquelle ausgeben können (pro Ausgang) daher wollte ich mal den Pulseaudio Server probieren. Der ließ sich auch installieren, aber ich konnte im Pulse Mixer immer nur eine Soundkarte sehen und konnte dann mit den Profilen zwischen Analog und Digital wechseln. Ich möchte jetzt aber beide Ausgaben parallel mit unterschiedlichen Streams betreiben. So weit ich das verstanden habe, sollte Pulse das auch können.
    Aber wie bring ich ihm das jetzt bei?

    Meine bisherige /etc/asound.conf
    Code:
    pcm.pulse {
      type pulse
    }
    
    ctl.pulse {
      type pulse
    }
    
    pcm.!defaul {
      type hw
      card 0
      device 0
    }
    
    ctl.!default {
      type hw
      card 0
      device 0
    }
    
    pcm.digital {
      type hw
      card 0
      device 1
    }
    
    ctl.digital {
      type hw
      card 0
      device 1
    }
    Ich kann mit aplay -D {default,digital} beide Ausgaben ansprechen.

    Aber wenn ich in der /etc/pulse/default.pa folgende Zeile dekommentiere:
    Code:
    #load-module module-alsa-sink device=hw:0,1
    #load-module module-alsa-source device=hw:0,1
    Weigert sich pulse zu starten: Syslog
    Code:
    Apr 13 21:12:06 jan pulseaudio[1922]: module.c: Failed to load  module "module-alsa-sink" (argument: "device=hw:0,1"): initialization failed.
    pulseaudio[1922]: main.c: Module load failed.
    pulseaudio[1922]: main.c: Konnte Daemon nicht initialisieren.
    pulseaudio[1920]: main.c: Start des Daemons fehlgeschlagen.
    So, das waren meine Versuche bis jetzt.

    Jemand ne Idee?

    Danke
    Janis
    Mein Sysprofile

    "try and error" was sonst

  2. #2
    BOFH Avatar von janis
    Registriert seit
    02.09.2007
    Ort
    Deutschland
    Beiträge
    179
    Könnt ihr mir vielleicht sagen, wo (Forum - auch Englisch) ich Hilfe bei meinem Problem bekommen kann?
    Mein Sysprofile

    "try and error" was sonst

  3. #3
    Mitglied
    Registriert seit
    04.01.2010
    Beiträge
    28
    Zitat Zitat von janis Beitrag anzeigen
    Könnt ihr mir vielleicht sagen, wo (Forum - auch Englisch) ich Hilfe bei meinem Problem bekommen kann?
    Debianforum

Ähnliche Themen

  1. multiple definition SystemC
    Von Snafu im Forum C/C++
    Antworten: 0
    Letzter Beitrag: 16.05.2011, 13:15
  2. FritzBox 7270 Pulseaudio RTP Multicasting über WLAN
    Von CowClaw im Forum Internet, lokale Netzwerke und Wireless Lan
    Antworten: 0
    Letzter Beitrag: 19.10.2010, 23:21
  3. Flash Problem mit PulseAudio
    Von hermann4 im Forum Debian/Ubuntu/Knoppix
    Antworten: 3
    Letzter Beitrag: 28.11.2009, 10:57
  4. Output directories unter CMake
    Von jiddoo im Forum Programmieren allgemein
    Antworten: 1
    Letzter Beitrag: 15.09.2008, 10:28
  5. Xorg, Multiple X Screens
    Von bema im Forum Grafik / Video
    Antworten: 3
    Letzter Beitrag: 03.08.2006, 05:23

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •