Ergebnis 1 bis 6 von 6

Thema: Postfix und ein Relay Server

  1. #1
    Foren As
    Registriert seit
    21.11.2003
    Ort
    Germany
    Beiträge
    97

    Postfix und ein Relay Server

    Hallo Leute, ich habe da eine kleine und etwas spezielle Frage
    Es geht um den Postfix, und zwar habe ich einen vServer auf dem Postfix installiert ist. Funktioniert auch soweit alles ganz gut, aber in der Firma haben wir einen Mail-Server der die Emails an Postfix weiter geben soll zum versenden. Problematik ist, Postfix lehnt das ab.

    Ich habe im Log von unserem Server hier im Büro folgendes stehen,
    Code:
    Reporting-MTA: dns; SERVER.xxx.local
    Arrival-Date: Tue, 21 Feb 2012 13:28:45 +0100
    
    Original-Recipient: xxxx@t-online.de
    Final-Recipient: xxxx@t-online.de
    Action: failed
    Status: 5.1.1
    Remote-MTA: xxx.xxx.xxx.xxx
    Diagnostic-Code: SMTP; 554 5.7.1 <xxxx@t-online.de>: Relay access denied
    das sagt mir ja, dass Postfix nur die Mails von sich selbst und nicht über einen anderen Server annimmt. Die Frage ist, wie kann ich es denn ändern das er Emails die gültige Auth haben, immer angenommen werden? Ist das überhaupt möglich?

    Meine main.cf sieht für die restrictions wie folgt aus,
    Code:
    smtpd_helo_restrictions =
     permit_mynetworks,
     permit_sasl_authenticated,
     reject_invalid_helo_hostname,
     reject_non_fqdn_helo_hostname
    
    smtpd_sender_restrictions =
     reject_non_fqdn_sender,
     reject_unknown_sender_domain,
     permit_mynetworks,
     permit_sasl_authenticated
    
    smtpd_recipient_restrictions =
     permit_mynetworks,
     permit_sasl_authenticated,
     reject_non_fqdn_recipient,
     reject_unknown_recipient_domain,
     reject_rbl_client zen.spamhaus.org,
     reject_rbl_client ix.dnsbl.manitu.net,
     reject_rbl_client bl.spamcop.net,
     reject_unverified_recipient,
     reject_unauth_destination,
     permit
    Vielleicht hilft das ja schon ein wenig

    Mfg. Angel
    HomeServer : debian lenny (5.0) | Kernel : 2.6.26-2-amd64 | Samba | Cryptsetup | OpenVPN
    vmWare : debian lenny (5.0) | Kernel : 2.6.26-2-686

  2. #2
    Routinier Avatar von HeadCrash
    Registriert seit
    16.05.2009
    Ort
    Bayern
    Beiträge
    458
    Abend,

    was verstehst du unter gültiger Auth? Wenn euer Server im Büro sich authentifiziert sollte er, sofern es die Konfiguration, den vServer als Relay verwenden dürfen.

    Hast du ein Log vom vServer zu dem versuch?
    Was verwendet ihr als Mailserver im Büro?
    Kannst du mit einem Mailclient Mails über den Server verschicken?

    mfg
    HeadCrash
    - nothing is ever easy -

  3. #3
    Foren As
    Registriert seit
    21.11.2003
    Ort
    Germany
    Beiträge
    97
    Öhm.. Joa, also ich habe mal zwei Logs raus gezogen...
    Code:
    Feb 21 13:06:37 s02 postfix/smtpd[16530]: NOQUEUE: reject: RCPT from xxxx.dip0.t-ipconnect.de[xx.xx.xx.xx]: 554 5.7.1 <xxx@t-online.de>: Relay access denied; from=<xxx@xxx.de> to=<xxx@t-online.de> proto=ESMTP helo=<SERVER.xxx.local>
    
    Feb 21 13:09:58 s02 postfix/smtpd[16639]: NOQUEUE: reject: RCPT from xxxx.dip0.t-ipconnect.de[xx.xx.xx.xx]: 554 5.7.1 <xxx@xxx.de>: Relay access denied; from=<xxx@xxx.de> to=<xxx@xxx.de> proto=ESMTP helo=<SERVER.xxx.local>
    Und was die Fragen direkt angeht, also ich persönlich greife direkt via IMAP / SMTP auf den Server mit Thunderbird zu und das funktioniert ohne Probleme. Ich kann abrufen und Emails versenden! Da wir im Büro nur eine 1500er Leitung haben, werden die Emails erst an einen Haus internen Kerio-Server gesendet, und von dort weiter geleitet an den Postfix Server. Und von dort aus, gehen sie weiter

    Beispiel,
    - ich (Thunderbird) -> Postfix
    - Kollegen (Thunderbird) -> Kerio -> Postfix

    Mfg. Angel
    HomeServer : debian lenny (5.0) | Kernel : 2.6.26-2-amd64 | Samba | Cryptsetup | OpenVPN
    vmWare : debian lenny (5.0) | Kernel : 2.6.26-2-686

  4. #4
    Routinier Avatar von HeadCrash
    Registriert seit
    16.05.2009
    Ort
    Bayern
    Beiträge
    458
    Morgen,

    http://manuals.kerio.com -> SMTP Delivery tab ist entsprechend Konfiguriert?

    @Logs mein Fehler, dachte eher an welche die die Authentifizierung der User beinhalten, sprich die des sasl.

    mfg
    HeadCrash
    - nothing is ever easy -

  5. #5
    Foren As
    Registriert seit
    21.11.2003
    Ort
    Germany
    Beiträge
    97
    Jou, die Kerio Einstellungen sind 100% korrekt gesetzt. Das weiß ich daher, weil wir vorher schon Emails versenden konnten. Da war der MTA allerdings Qmail. Da die Telekom aber unsere IP von Server 1 geblockt hat wegen dem rDNS, habe ich die Emails alle auf Server 2 gepackt wo der MTA Postfix ist. Dieser weigert sich allerdings die Emails anzunehmen. Ich habe als Übergang erst einmal "mynetworks = 127.0.0.0/8, WAN IP der Firma" eingetragen, und damit geht es. Relaying lässt Postfix zu, da wir aber eine statische IP haben, muss ich im Moment immer die IP neu eintragen im Postfix.

    Und das kann ja nicht Sinn der Sache sein..
    Was die Logs angeht, ich habe eben mal die mail Logs (Error, Info, Log, Warn) durch geguckt. Und SASL hat sich nirgends dazu geäußert.

    Mfg. Angel
    HomeServer : debian lenny (5.0) | Kernel : 2.6.26-2-amd64 | Samba | Cryptsetup | OpenVPN
    vmWare : debian lenny (5.0) | Kernel : 2.6.26-2-686

  6. #6
    Foren As
    Registriert seit
    21.11.2003
    Ort
    Germany
    Beiträge
    97
    Okay, da ich mir selbst einen kleinen mail-Server zusammen gebaut habe und das Probleme mit dem "Relay access denied" dann auf meinem Client (Thunderbird) hatte, habe ich mal ein wenig rum gesucht und gelesen das diese Meldung auch kommen kann, wenn der Auth nicht richtig funktioniert. Ich werde das ganze doch noch einmal überprüfen müssen. Der Wurm muss ja irgendwo versteckt sein

    Was ich an meinem eigenen Server festgestellt habe (vielleicht kann man mir das genauer erklären), MTA ist Postfix und MDA ist Dovecot.. Ich habe ein "Gesendet" Verzeichnis. Auf einem anderen Server wurde dieses im Maildir wie folgt beschriftet "INBOX.sent" und jetzt in dem neuen Dovecot was ich aufgesetzt habe, heißt es nur ".sent"! Ich weiß das man bei Thunderbird einstellen kann, dass er direkt in INBOX. arbeiten soll, aber auf dem anderen Server wurde dieser Parameter übergeben und erzwungen. Kann mir das einer genauer erklären?

    Mfg. Angel

    Nachtrag: So, durch ein wenig rum probieren, hin und herstellen im Postfix etc. habe ich das Problem nun gefunden.. auch mit ein wenig Hilfe aus dem serversupportforum konnte ich das Problem eingrenzen. Der Fehler liegt darin, dass die externe echte Domain und die interne Domain gleich heißen. Wenn er nun einen User in der internen Domain nicht findet, leitet er diese einfach an einen anderen MX weiter ohne Relay etc., und da ist mein Problem. Ich habe mal einen Screenshot angefügt, damit man sich das besser anschauen kann, wo mein Problem liegt.
    Angehängte Grafiken Angehängte Grafiken
    Geändert von Angel (02.03.2012 um 09:02 Uhr)
    HomeServer : debian lenny (5.0) | Kernel : 2.6.26-2-amd64 | Samba | Cryptsetup | OpenVPN
    vmWare : debian lenny (5.0) | Kernel : 2.6.26-2-686

Ähnliche Themen

  1. Postfix: fallback relay ?
    Von foexle im Forum Web- & File-Services
    Antworten: 6
    Letzter Beitrag: 18.05.2010, 14:53
  2. Postfix - mail über bestimmtes Relay versenden
    Von softcake im Forum Web- & File-Services
    Antworten: 0
    Letzter Beitrag: 31.01.2007, 14:23
  3. postfix smtp relay Einstellungsproblem
    Von lakul im Forum Anwendungen
    Antworten: 0
    Letzter Beitrag: 30.01.2007, 22:00
  4. mich hat's erwischt: Postfix als SPAM-Relay :(
    Von Gigi666 im Forum Security Talk
    Antworten: 7
    Letzter Beitrag: 20.08.2006, 03:39
  5. Antworten: 4
    Letzter Beitrag: 29.11.2003, 14:04

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •