ZMD entfernt nach update gdm etc.(SuSe 10.0)
Ergebnis 1 bis 7 von 7

Thema: ZMD entfernt nach update gdm etc.(SuSe 10.0)

  1. #1
    Grünschnabel
    Registriert seit
    16.04.2005
    Beiträge
    6

    ZMD entfernt nach update gdm etc.(SuSe 10.0)

    hiho,

    heute gabs eine benachrichtigung von ZMD, dass es updates gäbe.. leider habe ich diese updates durchgeführt und jetzt hab ich kein gdm, kein gnome, nix mehr.. nur noch fvwm unso druff..
    Nun wollte ich gdm wieder installieren(via yast), nur gibts da jetzt haufenweise dependencies die's nicht auflösen kann etc. pp.
    Weiss jemand wie man die automatisch auflösen kann oder wie man das update rückgängig machen könnte?
    Im Anhang ist das log zmd-backend.log, was es alles entfernt hat.

    Mittlerweile hab ich rausgefunden, dass es das cmd-line tool rug gibt..aber z.B. Rollback is nich enabled :S

    Oder wie kann ich alle Pakete via commandline von einem file einlesen und installieren lassen und die Pakete die konflikte machen entfernen?
    Angehängte Dateien Angehängte Dateien
    Geändert von mix (05.10.2007 um 14:58 Uhr)




  2. Inside Anonymous - Lesetipp zum Sonderpreis


     Inside Anonymous erzählt erstmalig die Geschichte dreier Mitglieder des harten Kerns:
    ihren Werdegang und ihre ganz persönliche Motivation, die sie zu überzeugten Hackern machte.
    Basierend auf vielen exklusiven Interviews bietet das Buch einen einzigartigen und spannenden
    Einblick in die Köpfe, die hinter der virtuellen Community stehen.
    Das Buch kostet bei terrashop.de jetzt statt 22,00 EUR nur noch 4,99 EUR.




    Jetzt bei terrashop.de anschauen – Nur solange der Vorrat reicht


  3. #2
    Tripel-As
    Registriert seit
    13.07.2007
    Beiträge
    160
    Zitat Zitat von mix Beitrag anzeigen
    heute gabs eine benachrichtigung von ZMD, dass es updates gäbe..
    Vom zen-updater?
    ... unter SuSE 10.0 ...
    ... das halte ich ehrlich gesagt für ein Gerücht.
    Den ZMD gibt es erst ab SuSE Linux 10.1 ... - oder meinst du evtl. SLES/SLED 10?

    Poste
    Code:
    cat /etc/*release
    Zitat Zitat von mix Beitrag anzeigen
    leider habe ich diese updates durchgeführt und jetzt hab ich kein gdm, kein gnome, nix mehr.. nur noch fvwm unso druff..
    Selbst Schuld, wenn man einfach und ohne nachzudenken wild drauflos irgendwelche Updates installiert ...

    Aus welchen Quellen wurden überhaupt Updates installiert?

    Poste
    Code:
    rug --no-abbrev sl
    und
    Code:
    rug ca
    Zitat Zitat von mix Beitrag anzeigen
    Nun wollte ich gdm wieder installieren(via yast), nur gibts da jetzt haufenweise dependencies die's nicht auflösen kann etc. pp.
    Die wären ...?

    Zitat Zitat von mix Beitrag anzeigen
    Im Anhang ist das log zmd-backend.log, was es alles entfernt hat.
    Das scheint mir aber nicht vollständig zu sein ...

    Poste
    Code:
    rpm -qa --last
    (vom heutigen Tag)
    Geändert von b3ll3roph0n (05.10.2007 um 15:10 Uhr)
    Gruß b3ll3roph0n
    --
    Denken hilft !

    Für alle meine Beiträge gelten, außer bei Zitaten, die Creative Commons.

  4. #3
    Grünschnabel
    Registriert seit
    16.04.2005
    Beiträge
    6
    thx für die antwort.

    hab vorhin gemerkt, dass irgendwie die architektur von x86_64 auf i586 gewechselt hat, bei den paketen.. o.O

    Zitat Zitat von b3ll3roph0n Beitrag anzeigen
    Vom zen-updater?
    ... unter SuSE 10.0 ...
    ... das halte ich ehrlich gesagt für ein Gerücht.
    Mh, also auf der Packung steht da Suse 10.0..

    Poste
    Code:
    cat /etc/*release
    Code:
    # cat /etc/*release
    cat: /etc/*release: No such file or directory
    Selbst Schuld, wenn man einfach und ohne nachzudenken wild drauflos irgendwelche Updates installiert ...
    jup, ich weiss war ein bisschen unüberlegt..Kenne SuSe nicht besonders, bin Debian gewohnt..

    Aus welchen Quellen wurden überhaupt Updates installiert?

    Poste
    Code:
    rug --no-abbrev sl
    und
    Code:
    rug ca
    Code:
    # rug --no-abbrev sl
    
    # | Status | Type | Name                                      | URI
    --+--------+------+-------------------------------------------+-----------------
    1 | Active | ZYPP | SuSE-Linux-CD-i386-10.0-0-20070927-144858 | cd:///?alias=SuSE-Linux-CD-i386-10.0-0-20070927-144858
    Code:
    # rug ca
    
    Sub'd? | Name                                      | Service
    -------+-------------------------------------------+------------------------------------------
    Yes    | SuSE-Linux-CD-i386-10.0-0-20070927-144858 | SuSE-Linux-CD-i386-10.0-0-20070927-144858
    Die wären ...?
    Code:
    # rug install gdm
    Resolving Dependencies...
    
    ERROR: Dependency resolution failed:
    Unresolved dependencies:
    Installing gdm-2.8.0.4-2.i586[SuSE-Linux-CD-i386-10.0-0-20070927-144858]
    expat-1.95.8-5.i586[SuSE-Linux-CD-i386-10.0-0-20070927-144858] provides libexpat.so.0, but has another architecture.
    There are no installable providers of libexpat.so.0 for gdm-2.8.0.4-2.i586[SuSE-Linux-CD-i386-10.0-0-20070927-144858]
    libgsf-1.12.1-3.i586[SuSE-Linux-CD-i386-10.0-0-20070927-144858] needed by gdm-2.8.0.4-2.i586[SuSE-Linux-CD-i386-10.0-0-20070927-144858]
    gnome2-SuSE-10.0-9.noarch[SuSE-Linux-CD-i386-10.0-0-20070927-144858] needed by gdm-2.8.0.4-2.i586[SuSE-Linux-CD-i386-10.0-0-20070927-144858]

    Poste
    Code:
    rpm -qa --last
    (vom heutigen Tag)
    Code:
    # rpm -qa --last|more
    gnome-common-2.11.0-3                         Fri Oct  5 11:52:53 2007
    tightvnc-1.2.9-186                            Fri Oct  5 11:21:58 2007
    xorg-x11-Xvnc-6.8.2-100                       Fri Oct  5 11:21:57 2007
    das sind alle von heut.. das vnc zeuchs is weil ich vnc wieder einrichten wollte (is nurn interner server) und um diese zeit noch nicht gemerkt hatte, dass der gdm unso removed hat.
    :/

  5. #4
    Tripel-As
    Registriert seit
    13.07.2007
    Beiträge
    160
    *Ähm*

    Was genau soll das denn bitte für ein System sein?
    (Unter SuSE Linux 10.0 gab es definitiv noch keinen ZENworks Daemon)

    Poste
    Code:
    rpm -q libzypp
    Code:
    uname -a
    Code:
    arch
    ... und warum gibt es keine /etc/SuSE-release?
    Gruß b3ll3roph0n
    --
    Denken hilft !

    Für alle meine Beiträge gelten, außer bei Zitaten, die Creative Commons.

  6. #5
    Grünschnabel
    Registriert seit
    16.04.2005
    Beiträge
    6
    Zitat Zitat von b3ll3roph0n Beitrag anzeigen
    *Ähm*

    Was genau soll das denn bitte für ein System sein?
    (Unter SuSE Linux 10.0 gab es definitiv noch keinen ZENworks Daemon)
    Das frag ich mich mittlerweile auch :/

    Code:
    # rpm -q libzypp
    libzypp-1.2.0-1.21
    # uname -a
    Linux lx03 2.6.16.21-0.8-smp #1 SMP Mon Jul 3 18:25:39 UTC 2006 x86_64 x86_64 x86_64 GNU/Linux
    # arch
    x86_64
    Und wieso's kein SuSe-Release gibt weiss ich auch nicht..Den Server selber hab ich nicht aufgesetzt, hat ein Arbeitskollege gemacht.

    Mh, ich hab ihn jetzt neugestartet und es steht dass es ein SLES system ist...(beim grub)
    Allerdings wollte es die CD vom SLES Software-Paket nicht akzeptieren, als ich heute morgen das versuchte :S

    Ich frag mich einfach wieso dass der ZMD i586 pakete installiert hat :S
    Und wieso hats für alle pakete ein x86_64 aber beim gdm keins?


    //Edit: Ach nee, kann ja nich sein..sowas blödes! Im SLES CD Paket hats ein x86 und ein x86_64 ... Und ich hab da nich drauf geachtet als ich heut morgen die CD reingetan hab.. Jetzt kann ich alles installen, mal schaun wie's läuft.
    Geändert von mix (05.10.2007 um 16:52 Uhr)

  7. #6
    Tripel-As
    Registriert seit
    13.07.2007
    Beiträge
    160
    Zitat Zitat von mix Beitrag anzeigen
    Das frag ich mich mittlerweile auch :/
    Zitat Zitat von mix Beitrag anzeigen
    Den Server selber hab ich nicht aufgesetzt, hat ein Arbeitskollege gemacht.
    Dann solltest du den betreffenden "Kollegen" mal dazu befragen!

    Das ist definitiv kein SuSE Linux 10.0 System, sondern entweder ein SuSE Linux 10.1 oder eine SUSE Enterprise 10 (Desktop/Server).

    In letzterem Fall existiert doch bestimmt auch ein entsprechender Supportvertrag?
    => Support Hotline anrufen.

    Code:
    # rpm -q libzypp
    libzypp-1.2.0-1.21
    # uname -a
    Linux lx03 2.6.16.21-0.8-smp #1 SMP Mon Jul 3 18:25:39 UTC 2006 x86_64 x86_64 x86_64 GNU/Linux
    # arch
    x86_64
    Spricht dafür, dass dies ein SLES/SLED 10 ist und kein SuSE Linux 10.1.

    Allerdings wurdert es mich schon, dass nicht zumindest der Novell-Update-Server eingetragen ist.

    Zitat Zitat von mix Beitrag anzeigen
    Ich frag mich einfach wieso dass der ZMD i586 pakete installiert hat :S
    Und wieso hats für alle pakete ein x86_64 aber beim gdm keins?
    Weil der ZMD einfach nicht zwischen den Architekturen unterscheidet (andere Paketmanager wie smart übrigens auch nicht).
    Daher sollte man beim Update immer aufmerksam sein!


    Zuerst solltest du mal herausfinden was das eigentlich für eine CD ist, die dort als Quelle eingebunden ist.
    Nicht dass der "Kollege" eine SuSE 10.0 als Installationsquelle eingebunden hat.

    Anschließend:

    - Die reguläre SLES 10 CD/DVD als Installationsquelle einrichten.

    - Alle i586-Pakete finden und die nicht benötigten deinstallieren:
    Code:
    rpm -qa 'arch=i586'
    - Das Novel-Update-Repository einbinden.
    YaST > Software > Novell Customer Center Configuration

    - Die fehlenden Pakete von der regulären SLES/SLED-Quelle (DVD) bzw. dem Update-Repository einspielen.
    Siehe: man rug



    Btw: Was haben XServer, GDM & Co auf einem Server verloren?
    Und wenn das tatsächlich ein produktiver Server in einem Unternehmen ist ... was sagt euer Admin zu dem Chaos?
    Gruß b3ll3roph0n
    --
    Denken hilft !

    Für alle meine Beiträge gelten, außer bei Zitaten, die Creative Commons.

  8. #7
    Grünschnabel
    Registriert seit
    16.04.2005
    Beiträge
    6
    - Alle i586-Pakete finden und die nicht benötigten deinstallieren:
    Code:
    rpm -qa 'arch=i586'
    ok.

    - Das Novel-Update-Repository einbinden.
    YaST > Software > Novell Customer Center Configuration

    kk mach ich dann

    - Die fehlenden Pakete von der regulären SLES/SLED-Quelle (DVD) bzw. dem Update-Repository einspielen.
    Siehe: man rug
    jup.


    Btw: Was haben XServer, GDM & Co auf einem Server verloren?
    Is für die Fernwartung. Ausserdem braucht Netvault (Backup-Lösung) eine GUI..

    Und wenn das tatsächlich ein produktiver Server in einem Unternehmen ist ... was sagt euer Admin zu dem Chaos?
    Er ist nicht besonders glücklich

    //edit: funzt alles wieder..thx für deine hilfe!
    Geändert von mix (05.10.2007 um 17:24 Uhr)

Ähnliche Themen

  1. Notebookausfall nach Update/Suse 9.3
    Von dejay46 im Forum SuSE / OpenSuSE
    Antworten: 3
    Letzter Beitrag: 29.09.2007, 21:56
  2. Nach Suse-Update kde weg
    Von m.molitor im Forum SuSE / OpenSuSE
    Antworten: 5
    Letzter Beitrag: 12.07.2007, 11:05
  3. Stummfilm nach Update auf Suse 10.2 :(
    Von frafi im Forum SuSE / OpenSuSE
    Antworten: 6
    Letzter Beitrag: 31.12.2006, 14:34
  4. Textmode nach Suse 9.0 update
    Von fbmfr im Forum Installation & Basiskonfiguration
    Antworten: 4
    Letzter Beitrag: 08.01.2006, 23:22
  5. Update von Suse x.x nach x.x
    Von kaiser im Forum SuSE / OpenSuSE
    Antworten: 2
    Letzter Beitrag: 06.11.2005, 21:49

Lesezeichen

Lesezeichen

Berechtigungen

  • Neue Themen erstellen: Nein
  • Themen beantworten: Nein
  • Anhänge hochladen: Nein
  • Beiträge bearbeiten: Nein
  •