PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Apache installation unter linux



CRypi
10.09.2004, 13:29
HI,ich verscueh Apahe unter linux zu installieren, bei $ make bekommt er jedoch einen error,

creating support/Makefile
creating srclib/pcre/Makefile
config.status: error: invalid argument: src/Makefile.global
make: *** [src/Makefile.global] Error 1

kann mir jemand sagen was ich tun muss um das zu beheben?

Hofef jemand weiß rat!
Danke!
Crypi

devilz
10.09.2004, 13:42
Wäre nett wenn du weitere Infos hinzufügen könntest.

Distro/gcc version/apache version/ vielleicht ein längere fehlermeldung ... etc.

danke

CRypi
10.09.2004, 13:50
ich nutz suse linux 8.2, apache 2.0.5.0.
ich bin noch sehr neu sowohl bei linux als auch bei apache.
kannst du mir bitte erklären was distro und gccd ist? dann werd ich versuchen das rauszubekommen.

die fehlermeldung war nicht länger, das ist alles was er an fehler ausgespuckt hat, darüber war nur das was funktioniert hat.

Crypi

qmasterrr
10.09.2004, 13:55
....hast du die anleitung gelesen?

gcc == gnu compiler colection
das ist ein packet das sogut wie alle nötigen compiler enthält um so ziemlich jede anwendung zu übersetzen

CRypi
10.09.2004, 14:03
welche anleitung meinst du?
wenn du die installationsanleitung von apache meinst, ja die hab ich gelesen und wenn ich mich nicht verlesen habe steht dort nichts von einer speziellen anforderung an die gcc.
klär mich bitte auf wenn ich mich irre.

Crypi
PS: danke für die erkärung, und wo finde ich meine version?

avaurus
10.09.2004, 14:21
http://httpd.apache.org/docs-2.0/install.html

CRypi
10.09.2004, 14:35
*räusper*
ich entschuldige mich, hatte ich doch glatt überlesen.
mal sehen obs hilft.

Crypi

devilz
10.09.2004, 15:39
*räusper*
ich entschuldige mich, hatte ich doch glatt überlesen.
mal sehen obs hilft.

Crypi

Kann jemdem mal passieren :)

CRypi
13.09.2004, 12:52
supi!
apache ist installiert, obwohl die installation des gcc ewig gedauert hat.
Danke für eure hilfe!

gleich weiter zum nächsten problem*g*.

nein ehrlich ich versuch jetzt gerade php zu installieren und bekomme das hier

Configuring extensions
checking whether to enable LIBXML support... yes
checking libxml2 install dir... no
configure: error: xml2-config not found. Please check your libxml2 installation.

wo kann ich die libxml2 checken bzw installieren oder das tun das hier angebracht wäre.

verzeiht es einem neuling das er keine ahnung hat!

Crypi

PS: bevor ichs vergesse: php5.0.1, suse linux 8.2, apache 2.0.5 braucht ihr noch was?

CRypi
14.09.2004, 09:17
über diese stelle komme ich jetzt hinweg, --disable-libxml hat den gewünschten erfolg erzielt.

allerdings bekomme bei make sofort eine fehler meldung:

cd . && ./config.status src/Makefile.global
Usage: ./config.status [--recheck] [--version] [--help]
make: *** [src/Makefile.global] Error 1

das klingt wie ein allgemeiner fehler, kann mir jemand sagen was ich falsch gemacht habe?

Gruß Crypi

CRypi
14.09.2004, 10:36
oka auch das ist gelöst.

danke für euer hilfe!
Crypi