PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Abstürze mit ut2004



kingdom
30.06.2004, 15:30
Hallo

Ich habe ein Problem mit meinem Unreal Tournament 2004. Das Spiel startet ersteinmal normal. Wenn ich dann aber ein Spiel starte, dann hängt er sich beim laden der Karte auf. Genauso hängt er sich auf, wenn ich in den Optionen was an der Grafik ändere, wie zum Beispiel die Farbtiefe. Außerdem hängt er sich noch auf, wenn ich das Spiel verlasse. Ich hab keine Ahnung mehr, woran es liegen könnte. In Foren etc hab ich auch nichts gefunden.
Das Logfile war tollerweise seit den letzten Abstürzen auch noch leer. Ich werde mal versuchen, ob ich nochwas reinbekomme. Wenn ja, dann werde ich es noch posten.

Clemens

kingdom
30.06.2004, 15:43
passeck@pong:~/.ut2004/System> cat UT2004.log
Log: Log file open, Wed Jun 30 15:30:49 2004
Init: Name subsystem initialized
Init: Version: 3236 (127.29)
Init: Compiled: Jun 14 2004 03:42:58
Init: Command line:
Init: (This is Linux patch version 3236.0)
Init: Character set: Unicode
Init: Base directory: /home/passeck/ut2004/System/
Init: Ini:UT2004.ini UserIni:User.ini
Init: Build label: UT2004 Build UT2004_Patch_[2004-06-11_16.51]
Init: Object subsystem initialized
Warning: Missing Class Class Editor.TransBuffer
Log: Initializing OpenGLDrv...
Log: binding libGL.so.1
Log: Game class is 'GameInfo'
Log: Bringing Level Entry.myLevel up for play (0) appSeconds: 11.895304...
ScriptLog: GameInfo::InitGame : bEnableStatLogging Falsch
Log: Browse: NvidiaLogo.ut2?Name=Kingdom?Class=Engine.Pawn?Char acter=Jakob?team=255
Log: Collecting garbage
Log: Purging garbage
Log: Garbage: objects: 33206->33205; refs: 343609
Log: Game class is 'CinematicGame'
Log: Bringing Level NvidiaLogo.myLevel up for play (0) appSeconds: 14.044816...
ScriptLog: GameInfo::InitGame : bEnableStatLogging Falsch
Log: Created and initialized a new SDL viewport.
ScriptLog: New Player Kingdom id=5505dc9aa23e3ea2f49384ae49ed4f47
Log: TTS: No output filename specified.
Log: Enter SetRes: 800x600 Fullscreen 1
Log: OpenGL
Log: GL_VENDOR : ATI Technologies Inc.
Log: GL_RENDERER : RADEON 8500 DDR Generic
Log: GL_VERSION : 1.3 (X4.3.0-3.7.6)
Log: OpenGL: Device supports: GL
Log: OpenGL: Device supports: GL_EXT_bgra
Log: OpenGL: Device supports: GL_ARB_texture_compression
Log: OpenGL: Device supports: GL_EXT_texture_compression_s3tc
Log: OpenGL: Device supports: GL_ARB_texture_cube_map
Log: OpenGL: Device supports: GL_ARB_texture_env_combine
Log: OpenGL: Device supports: GL_ATIX_texture_env_combine3
Log: OpenGL: Device supports: GL_ATI_texture_env_combine3
Log: OpenGL: Device supports: GL_ARB_texture_env_crossbar
Log: OpenGL: Device supports: GL_EXT_texture_lod_bias
Log: OpenGL: Device supports: GL_ARB_multitexture
Log: OpenGL: Device supports: GL_ATI_vertex_array_object
Log: OpenGL: Device supports: GL_ATI_element_array
Log: OpenGL: Device supports: GL_ATI_map_object_buffer
Log: OpenGL: Device supports: GL_EXT_texture_filter_anisotropic
Log: OpenGL: Device supports: GL_ARB_vertex_buffer_object
Log: OpenGL: C32 RGB888 Z24 S0
Log: OpenGL: Level of anisotropy is 1.000000 (max 16.000000).
Log: OpenGL: Not using multisample
Log: Startup time: 15.848547 seconds
Log: Precaching: NvidiaLogo.LevelInfo0
Log: Static mesh batches: 508608 vertex bytes, 110460 index bytes
Log: Allocating 32768 byte dynamic index buffer.
Log: Allocating 65536 byte dynamic vertex buffer.
Log: Finished precaching geometry in 0.109 seconds
Log: Finished precaching textures in 0.311 seconds
Debug: UT2k4MainMenu.Opened() Sender:Package.UT2k4MainMenu
Log: URL: Adding default option Name=Kingdom
Log: URL: Adding default option Class=Engine.Pawn
Log: URL: Adding default option Character=Jakob
Log: URL: Adding default option team=255
Log: Browse: Index.ut2?disconnect?Name=Kingdom?Class=Engine.Paw n?Character=Jakob?team=255
Log: Gescheitert; zur Eingabe
ScriptLog: UT2k4MainMenu NotifyLevelChange PendingConnection:Falsch
Log: GP=FALSE
Log: Spawning new actor for Viewport SDLViewport
ScriptLog: New Player Kingdom id=5505dc9aa23e3ea2f49384ae49ed4f47
Log: Static mesh batches: 0 vertex bytes, 0 index bytes
Log: EndFullscreen
Log: Enter SetRes: 640x480 Fullscreen 0
Log:
Developer Backtrace:
Log: [ 1] ./ut2004-bin [0x86d2f9c]
Log: [ 2] /lib/libpthread.so.0 [0x4003a895]
Log: [ 3] /lib/libc.so.6 [0x401355c8]
Log: [ 4] /usr/X11R6/lib/modules/dri/fglrx_dri.so(fglX11CMMReleaseTexSurface+0x60) [0x42d81d40]
Log: [ 5] /usr/X11R6/lib/modules/dri/fglrx_dri.so(__FGLTexMgrFree+0x9d) [0x42d9267d]
Log: [ 6] /usr/X11R6/lib/modules/dri/fglrx_dri.so(fglX11FreeManagedSurface+0x8c) [0x42d8a96c]
Log: [ 7] /usr/X11R6/lib/modules/dri/fglrx_dri.so(fgl_x11_VmmFreeSurface+0x198) [0x42d8b1a8]
Log: [ 8] /usr/X11R6/lib/modules/dri/fglrx_dri.so [0x42a56fda]
Log: [ 9] /usr/X11R6/lib/modules/dri/fglrx_dri.so [0x42a5680c]
Log: [10] /usr/X11R6/lib/modules/dri/fglrx_dri.so(

Diesemal war es Abgestürzt, als ich versuchte mit Alt+Enter aus dem Fullscreen rauszukommen, um es mal ohne Absturz zu beenden. Leider war mit Alt+Enter schon Ende, da der Rechner nicht mehr wollte.

Clemens

damager
30.06.2004, 15:55
nur ne idee: evtl neuen ati trieber verwenden ... 3.9.0 ist der aktuelle.

kingdom
30.06.2004, 15:58
Hab ich versucht. Problem:
Ich hab in ner Anleitung mal was von nem anderen Treiber gefunden (fglrx-gc22....). Wenn ich jetzt das rpm mit der 3.9.0 draufmachen will, sagt er, geht nicht, weil das andere benötigt wird. Ich mag es aber nicht brutal runterschmeißen. So gut, dass ich mir das getraue kenne ich mich auch nicht aus. Jedenfalls müßte es doch auch so gehen. Die anderen Spielen es doch auch mit dem 3.7.6 'er und anderen. Und den 3.7.6 'er hatte ich auch schon (erfolglos). Mein 3D läuft auch, also wird es daran nicht liegen.

kingdom
30.06.2004, 22:59
Ich hab jetzt den 3.9.0 Treiber zu laufen. Es will trotzdem nicht. Also war es das auch nicht. Hat irgendjemand noch Ideen?

Clemens

Zico
11.07.2004, 14:32
Ich würd einfachst mal versuchen das Spiel zu patchen. Es sind bereits 2 Linux Patches draussen.
Bei mir war das Spiel vorher auch extrem instabil. Jetzt nicht mehr