PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : KDEInit konnte "Java" nicht starten



User
04.06.2004, 18:35
ich benutze linux suse 8.2 und habe mir aus einer Heft-CD OpenOffice 1.1 installiert. Seither bekomme ich beim Start von muffin oder Jap die Fehlermeldung KDEInit konnte "Java" nicht starten. Could not find ´java´ executable. Bei der Installation von OpenOffice wurde ich aufgefordert den Pfad für Java anzugeben. Gab /usr/lib/java an...was es akzeptierte und auch installierte. Seither jedoch die Fehlermeldung bei muffin und jap.
kann mir jemand weiterhelfen?

devilz
08.06.2004, 13:32
Es hatt wenig Sinn alle 4 tage dein Problem erneut zu posten !
Habe dein Doppelpost gelöscht !

Cyber
08.06.2004, 14:31
Gab /usr/lib/java an...was es akzeptierte und auch installierte

Ich kann mir nicht vorstellen, dass das binary unter /usr/lib/... liegen soll. Hier wär wohl eher /usr/bin oder besser /usr/local/bin gewesen. Wenn es aber unterhalt von /usr/lib/... liegt, dann solltest Du im environment Deine Pfade anpassen. Sollten tatsächlich libs von java unterhalb des pfades /usr/lib/java/.. liegen, dann schau mal in Deine ld.so.conf, ob der pfad zu den libs aufgeführt ist. Falls nicht, entsprechend eintragen und ldconfig ausführen.

Kann mich jetzt auch absolut täuschen, aber mich hat halt Dein pfad etwas irritiert.

User
10.06.2004, 21:44
Sorry an den Admin...war mir eben nicht sicher ob es eher unter java..oder KDE fällt...
und dank dir cybermarc...werd dein Tipp mal versuchen....hab nochmal gekuckt...aber java lag bei mir glaub ich unter file:/usr/lib/BlackdownJava2-1.4.1/jre/bin/java
auch Sunjava...etc. Aber vorerst mal vielen Dank, mach mich mal auf die Suche nach ld.so.conf

User
11.06.2004, 00:19
hab ld.so.conf gefunden..aber weiß nicht ob ich da was ändern muss ... schick mal ein Auszug von ld.so.conf mit:
/usr/X11R6/lib/Xaw95
/usr/X11R6/lib/Xaw3d
/usr/X11R6/lib
/usr/i486-linux/lib
/usr/i486-linux-libc5/lib=libc5
/usr/i486-linux-libc6/lib=libc6
/usr/i486-linuxaout/lib
/usr/i386-suse-linux/lib
/usr/local/lib
/usr/openwin/lib
/opt/kde/lib
/opt/kde2/lib
/opt/kde3/lib
/opt/gnome/lib
/opt/gnome2/lib
/opt/mozilla/lib
unter opt/kde3/lib...war ein Verzeichnis Java aber wie gesagt.. die Datei Java selbst glaub ich ist unter /usr/lib/BlackdownJava/jre/bin/java oder usr/lib/SunJava/jre/bin/java
Vor der Installation von OpenOffice1.1.1 lief ja auch alles einwandfrei. Da funktionierte der muffin ja auch noch. Die Fehlermeldung kam erst nach der Installation von OpenOffice.

User
22.06.2004, 18:39
hab das Problem gelöst, ein link zu /bin hat Abhilfe geschaffen jetzt funzt java jap und konsorten wieder...dennoch vielen Dank
cu
user