PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : NVIDIA-Treiber und Kernel 2.6.6-rc1



Phate
25.05.2004, 20:28
Hallo,

von Debian auf Gentoo umgestiegen, gefällts mir hier eigenlich ganz gut. :D Nur ein Problem habe ich noch: Ich bekomme das nvidia-modul per modprobe nicht geladen.

Mein Sys:
AMD Athlon XP, NV GForce FX 5200
Kernel 2.6.6-rc1, XFree4.3

Der XServer läuft mit nv wunderbar... ich hätte aber natürlich gerne 3D Unterstützung und die volle Power der Graka. ;)

emerge nvidia-glx nvidia-kernel erstellt ein Modul nvidia.ko in lib/modules/2.6.6-rc1/video, aber dieses Modul kann nicht geladen werden:
FATAL: Error inserting nvidia (/lib/modules/2.6.6-rc1/video/nvidia.ko): Invalid module format.

Wenn ich die neueren Treiber nehme mittels ACCEPT_KEYWORDS="~x86" emerge nvidia-glx, bricht er mit folgender Fehlermeldung die Kompilierung ab:
ACCESS DENIED: open_wr: /usr/src/linux-2.6.6-rc1/.__modpost.cmd

Ich habe auch schon versucht den Treiber von www.nvidia.com zu installieren, er kompiliert auch das Modul, aber es läßt sich wieder nicht laden, siehe oben.

An der HW kanns nicht liegen, weil der NVIDIA-Treiber unter Debian einwandfrei läuft.

Was kann ich noch versuchen?

Gruß, Phate

devilz
25.05.2004, 20:54
- du rufst einfach nur "modprobe nvidia" auf ?
- den 2.6.6er Kernel hast du per emerge installiert ?

Phate
25.05.2004, 21:43
Ja tue ich. :) Und den 2.6.6er Kernel habe ich per emerge installiert.

Aber das Proble hat sich gerade gelöst: ich habe den 2.6.5er installiert mit emerge, dann emerge nvidia-kernel und et voila.. modprobe nvidia lädt das modul. :)

Laut Google und #gentoo benutzt der 2.6.6er Kernel neue module API ... da kann man die binary treiber von nvidia nur mit irgendwelche finstren hacks laden. Und weil ich echt kein bock auf basteln gerade habe, den "alten" kernel installiert.

Gruß