PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : JBuilderX / Exception in thread



icy_wiener
18.05.2004, 20:39
Hi,

ich hab folgendes Problem:
Wenn ich im Jbuilder ein Programm schreib und es ausführen soll erhalte ich folgende Fehlermeldung: "/usr/local/share/JbuilderX/jdk1.4/bin/java -classpath "/home/maverick/jbproject/Java-Buch/classes:/usr/local/share/JbuilderX/jdk1.4/demo/jfc/Java2D/Java2Demo.jar:/usr/local/share/JbuilderX/jdk1.4/demo/plugin/jfc/Java2D/Java2Demo.jar:/usr/local/share/JbuilderX/jdk1.4/jre/lib/ext/sunjce_provider.jar:/usr/local/share/JbuilderX/jdk1.4/jre/lib/ext/dnsns.jar:/usr/local/share/JbuilderX/jdk1.4/jre/lib/ext/ldapsec.jar:/usr/local/share/JbuilderX/jdk1.4/jre/lib/ext/localedata.jar:/usr/local/share/JbuilderX/jdk1.4/jre/lib/sunrsasign.jar:/usr/local/share/JbuilderX/jdk1.4/jre/lib/jce.jar:/usr/local/share/JbuilderX/jdk1.4/jre/lib/im/indicim.jar:/usr/local/share/JbuilderX/jdk1.4/jre/lib/im/thaiim.jar:/usr/local/share/JbuilderX/jdk1.4/jre/lib/jsse.jar:/usr/local/share/JbuilderX/jdk1.4/jre/lib/charsets.jar:/usr/local/share/JbuilderX/jdk1.4/jre/lib/plugin.jar:/usr/local/share/JbuilderX/jdk1.4/jre/lib/rt.jar:/usr/local/share/JbuilderX/jdk1.4/jre/javaws/javaws.jar:/usr/local/share/JbuilderX/jdk1.4/lib/dt.jar:/usr/local/share/JbuilderX/jdk1.4/lib/htmlconverter.jar:/usr/local/share/JbuilderX/jdk1.4/lib/tools.jar" java
Exception in thread "main" java.lang.NoClassDefFoundError: java"

Kann damit leider nix anfangen. Hab zwar schon gegoogelt, find aber nur Lösungsvorschlage für Windows. Da ist häufig vom setzen eines CLASSPATH die Rede, aber das wird ja schon beim Aufruf des Compillers erledigt.
Fehler im Programm können es nicht sein, wenn ich den Quelltext in Kate oder mit Eclipse ausführe, geht alles gut.

Grüße icy_wiener

ma-games
18.05.2004, 23:27
Exception in thread "main" java.lang.NoClassDefFoundError: java"
Das ist eigentlich die einzige wichtige Zeile der Fehlermeldung. Das bedeutet das er irgendeine Klasse braucht, die aber nicht findet. Vielleicht hast du in der Laufzeit-Konfiguration irgendwelche benötigten Bibliotheken oder Packages nicht angegeben. Ich kann mich erinnern das ich diese Fehlermeldung auch schon das ein oder andere mal hatte. Ich weiß aber leider nicht mehr in welchen Zusammenhang und was dann die Lösung des Problems war. Ich denke aber das es nichts Linux-spezifisches ist. Schreibe dein Problem vielleicht mal bei http://www.java-forum.org/de/ . Wenn du dort ne Lösung bekommts, kannst du sie ja auch hier posten.

icy_wiener
19.05.2004, 00:33
ok, danke!
Ich werds mal versuchen!