PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Could not load XKB keymap



CheckHero
29.04.2004, 22:51
Hi,

Ich bin Gentoo-User und machte gestern ein komplett Update meines System (emerge -UD world) und jetzt hab ich das Problem, dass ich X nicht mehr zum Laufen bringe! Erst kam ein Fehler mit der Schrift, dann hatte ich den behoben (hoffe/denke ich) und jetzt liegt es an der Keymap, da diese bei meinem Update aktualisiert wurde.
Der Fehler beim Starten von X:


Error loading keymap /var/tmp/server-0.xkm
Couldn't load XKB keymap, falling back to pre-XKB keymap
Could not init font path element unix/:-1, removing from list!
Fatal server error Coudl not open default font 'fixed'

Nachdem ich in meienr XF86Config einfach den Teil mit

FontPath "unix/:-1"
auskommentiert hatte und dann dann Kommentar bei

FontPath "/usr/X11R6/lib/X11/fonts/TrueType/"
wegmachte, schien es so, als würde es gehen! Sagen wir mal XDM startete und beim Einloggen als normaler User, stürzt dann X ab, nur wenn ich per root reingehen (auch per startx aus der Konsole) bekomm ich X zum laufen, aber "nur" als root zu arbeiten, ist ja auch nicht gerade das, was man machen sollte!

Hoffentlich kann mit jemand helfen, wäre sehr dankbar!

Greetz CheckHero

liquidnight
22.10.2005, 22:43
Der Fehler beim Starten von X:

Couldn't load XKB keymap, falling back to pre-XKB keymap

dieses Problem hab ich grad auch:



(II) Initializing built-in extension RANDR
(II) Initializing built-in extension COMPOSITE
(II) Initializing built-in extension DAMAGE
(II) Initializing built-in extension XEVIE
(**) Option "Protocol" "auto"
(**) Mouse0: Device: "/dev/input/mice"
(**) Mouse0: Protocol: "auto"
(**) Option "CorePointer"
(**) Mouse0: Core Pointer
(**) Option "Device" "/dev/input/mice"
(**) Option "Buttons" "3"
(**) Option "Emulate3Buttons" "false"
(**) Option "ZAxisMapping" "4 5"
(**) Mouse0: ZAxisMapping: buttons 4 and 5
(**) Mouse0: Buttons: 5
(**) Mouse0: SmartScroll: 1
(**) Option "CoreKeyboard"
(**) Keyboard0: Core Keyboard
(**) Option "Protocol" "standard"
(**) Keyboard0: Protocol: standard
(**) Option "AutoRepeat" "500 30"
(**) Option "XLeds" "1 2 3"
(**) Option "XkbRules" "xorg"
(**) Keyboard0: XkbRules: "xorg"
(**) Option "XkbModel" "pc105"
(**) Keyboard0: XkbModel: "pc105"
(**) Option "XkbLayout" "de"
(**) Keyboard0: XkbLayout: "de"
(**) Option "XkbVariant" "nodeadkeys"
(**) Keyboard0: XkbVariant: "nodeadkeys"
(**) Option "XkbKeycodes" "xorg"
(**) Keyboard0: XkbKeycodes: "xorg"
(**) Option "CustomKeycodes" "off"
(**) Keyboard0: CustomKeycodes disabled
(II) XINPUT: Adding extended input device "Keyboard0" (type: KEYBOARD)
(II) XINPUT: Adding extended input device "Mouse0" (type: MOUSE)
(EE) Couldn't load XKB keymap, falling back to pre-XKB keymap
(--) Mouse0: PnP-detected protocol: "ExplorerPS/2"
(II) Mouse0: ps2EnableDataReporting: succeeded
(II) VIA(0): [drm] Freeing agp memory
(II) VIA(0): [drm] Releasing agp module
(II) VIA(0): [drm] removed 1 reserved context for kernel
(II) VIA(0): [drm] unmapping 8192 bytes of SAREA 0xf8a3e000 at 0xb59bb000
(II) VIA(0): [drm] Irq handler uninstalled.




Hab mein Xorg-x11 auf die Version 6.8.99 hochgezogen, um unichrome-drm drinzuhaben. hängt das irgendwie mit den konfig-Dateien zusammen ?



(EE) VIA(0): [dri] DRIScreenInit failed. Disabling DRI.
The XKEYBOARD keymap compiler (xkbcomp) reports:
> Error: Can't find file "xorg" for keycodes include
> Exiting
> Abandoning keycodes file "default"
Errors from xkbcomp are not fatal to the X server
(EE) Couldn't load XKB keymap, falling back to pre-XKB keymap


bin grad unter meinem alten windoof, den google macht net wirklich spaß unter links2 :)


update: später werd' ich erstmal das xorg-x11 re-emergen, dann sehen wir weiter.

//Edit:

soooodele, gelöst !

x11-xorg neu emergt, vorher ein paar verzeichnisse beiseite gelegt, bildschirm war schon wieder schwarz. wenigstens weiß ich jetzt, wie das modul "via" geladen wird, und wieso vorher nicht. das hauptproblem war aber eine komische einstellung in meiner xorg.conf. nachdem ich das hier deaktiviert hatte, ging es endlich:


> # Option "TVType" "NTSC"
> # Option "TVOutput" "S-Video"
> # Option "ActiveDevice" "LCD,TV"
> Option "ActiveDevice" "LCD"