PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Probleme mit emerge -UD world bei installierten maskieren Packeten



Aracon
25.04.2004, 20:05
root@server server # emerge -UDp world
>>> --upgradeonly implies --update... adding --update to options.

These are the packages that I would merge, in order:

Calculating world dependencies |
!!! all ebuilds that could satisfy ">=x11-libs/pango-1.4" have been masked.
!!! possible candidates are:
- x11-libs/pango-1.4.0 (masked by: ~keyword)
!!! (dependency required by "x11-libs/gtk+-2.4.0-r1" [ebuild])

!!! Problem with ebuild net-p2p/giftoxic-0.0.9
!!! Possibly a DEPEND/*DEPEND problem.

!!! Depgraph creation failed.

Hab Gnome 2.6 mit ACCEPT_KEYWORDS="~x86" installiert. Jetzt bekomme ich immer das. Ich könnte das zeugs un-emergen aber vielleicht gibt es ja einen Weg das zu umgehen.
Jemand nen tipp?

thorus
25.04.2004, 23:44
- x11-libs/pango-1.4.0 (masked by: ~keyword)
Hmm, schreib doch mal in deine ACCEPT_KEYWORDS auch mal ~keyword rein.
Evtl. kleiner Fehler von Gentoo.

Locke
26.04.2004, 02:16
sinnvoller ist, wenn du in /etc/portage eine datei namens package.keywords anlegst und dort:
=x11-libs/pango-1.4.0 ~x86

einträgst. dann unmasked emerge es.