PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : 2.6.6-rc2 && nvidia



hinne
22.04.2004, 11:22
HI,
ich hab mal wieder ein Problem mit meinem Nvidia Modul. Irgendwie werd ich das Gefühl nicht los, das ich wieder was dummes gemacht hab.

Also:
Ich hab mir die neuen Development-Sources gemerged. Als ich dann den neuen Kernel gestartet habe, habe ich den /usr/src/linux link angepasst und hab auch den nvidia-kernel && nvidia-glx neu gemerged. Sogar mit ACCEPT_KEYWORDS="~x86". Jeweils alles erfolgreich.
Wenn ich jetzt das Modul laden möchte, bekomm ich immer den Fehler

FATAL: Error inserting nvidia (/lib/modules/linux-2.6.6-rc2/video/nvidia.o): invalid module format

Kann mir jemand weiterhelfen?

Moritz
22.04.2004, 11:35
wie so überhaupt nvidia.o und nicht nvidia.ko?

hinne
22.04.2004, 11:38
Ich weiß nicht ?!
Ich hab beide files im video verzeichnis drin. Aber warum .o und nicht .ko ... keine Ahnung.

Moritz
22.04.2004, 12:18
lösch doch mal die .o, denn die ist bestimmt nicht die, die Du brauchst (2.4er Modul)

hinne
22.04.2004, 12:26
Dann bekomm ich einen anderen Fehler.

FATAL: Could not open `/lib/modules/2.6.6-rc2/video/nvidia.o`: No such file or directory
Hab auch versucht die nvidia.ko nach nvidia.o umzubenennen, dann kommt aber der alte Fehler.

Moritz
22.04.2004, 12:53
Du benutzt doch den 2.6er Kernel, oder? Da braucht man das neue Modul-Format .ko
Schreib doch mal genauer, was Du eigentlich getan hast. Von welchem Kernel upgradest Du? Lief da alles? Warum baust Du das Modul nicht mit dem Installer neu? (BTW: Warum benutzt Du überhaupt entwicklerversionen des Kernels?)

thorus
22.04.2004, 12:58
Da ist irgendwo ein Fehler passiert.
Check deine aktuell laufende Kernelversion (uname -a) und nochmal den Link /usr/src/linux.
Normal müsste Gentoo beim emergen den Nvidia-Treiber automatisch richtig patchen, damit alles läuft. Bei mir gibts und hats auch niemals Probleme damit gegeben.

Das umbenennden von nvidia.o nach nvidia.ko bringt nichts, weil das ein neues Modulformat ist, das während des Entwicklungsprozesses des 2.5er eingeführt wurde. Das kann man nicht so einfach umbenennen.

Moritz
22.04.2004, 13:10
was ist schon normal... *grins*

hinne
22.04.2004, 13:11
also ich hatte vorher den 2.6.3er kernel (development-sources) und habe dann den kernel lange nicht geupdated. Jetzt hab ichs einfach mal gemacht. Vorher ging alles. Ich hab alles gemacht,wie ich es vorher auch gemacht habe.
Erst Kernel gebaut und gestartet. Danach den nvidia-kernel und den nvidia-glx gemerged und "opengl-update nvidia" eingegeben. Danach einfach "modprobe nvidia" eingegeben, xfree gestartet und alles ging.
Jetzt läd er einfach dieses modul nicht. Warum modprobe das .o und nicht das .ko modul laden will, weiss ich auch nicht. wie gesagt: mit dem 2.6.3 kernel hat es mit genau der selben reihenfolge funktioniert.

Den installer hab ich noch nicht ausprobiert, weil ich das mergen viel angenehmer finde. Aber eigendlich könnte ich das trotzdem mal testen.
Im Prinzip weiß ich auchnicht, warum ich die dev-sourcen benutze. Mach ich eigendlich schon lange und hab bisher auch noch nie Probleme damit gehabt.


********** EDIT ***********

Jetzt hab ich mal meinen video ordner im modul verzeichnis gelöscht und neue module erstellt. Jetzt hab ich zwar nurnoch eine .ko datei, aber wenn ich das modul laden möchte ist es immernoch ein falsches format.

Moritz
22.04.2004, 17:05
Hmm... ich hab keine Ahnung von Gentoo (mag's nicht so wirklich):
kann es sein, dass Dein "modprobe" für 2.4 kompeliert wurde? Bei Arch gibt's modprobe.old für 2.4 und modprobe für 2.6.
Wenn dein modprobe jetzt für 2.4 ist, dann kanns natürlich nicht mit der nvidia.ko umgehen...
nur ein Gedanke.

hinne
23.04.2004, 08:29
Die überlegung ist garnicht schlecht. Das Ding ist nur, dass ich nie einen 2.4er Kernel drauf hatte. Das System ist noch nicht so alt. Ich hab es direkt mit dem 2.6.3 ins leben gerufen.

Ich hab jetzt übergangsweise, bis mir eine Lösung zufliegt, den alten kernel wieder laufen.

Naja.
Never change a running system. :)

Moritz
23.04.2004, 08:52
Ich denke mal Dein Problem wird irgendwo in den Gentoo-Packeten liegen (k.A. wie das richtig heißt bei GT), denn bei mir hab ich mal das Kernelpacket von kernel.org mit dem Installer von nvidia.com ausprobiert und es ging...

hinne
23.04.2004, 09:11
Ich werd bei gelegenheit mal ausprobieren, ob ich das Problem auch mit dem Nvidia-Installer bekomme.
Wenn ja, hab ich ja immerhin einen Kernel der Stabil läuft. Den behalt ich dann erstmal.

Locke
26.04.2004, 01:25
im kernel wurden ab 2.6.5 einige änderungen am modulaufbau vorgenommen, insbesondere beim stackaufbau. du musst leider ins gras beissen und den kernel patchen, grmpf finde den patch grad net, für den 2.6.5er hatte ich zumindest einen, aber beim 2.6er könnteste ja mal googlen.

Moritz
26.04.2004, 08:10
Was muss denn wohin gepatched werden?
Ich will doch nicht meinen neuen Kernel wieder auf altes Niveau bringen, dann warte ich doch lieber auf n neues Modul von nVidia und upgrade erst dann von 2.6.4 auf 2.6.5
Oder verstehe ich das jetzt falsch?

Locke
26.04.2004, 18:46
auch ne möglichkeit

blue
26.04.2004, 20:58
Moin!
hatte ein ähnliches Problem.
Bei mir lag es daran, dass ich den Kernel mit CONFIG_4KSTACKS kompiliert habe.
Nachdem ich diese Option deaktiviert hatte, lief alles wieder ohne Probleme.

mfg

LiWiz
27.04.2004, 09:38
Ahoi,
ab 2.6.5 solltest Du dir den Streß nicht geben das Modul mit emerge bauen zu lassen. Nimm den Installer von der NVidia-Seite, bau das Modul neu und Du hast normalerweise Ruhe....

Just my 2 euro-cents,

LiWiz