PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Mandrake 9.2 & Asus P4P800 Deluxe



JABEZ
15.02.2004, 13:59
Hallo an alle :)

Hab mir heute morgen Mandrake 9.2 installiert. Die installation hat wunderbar geklappt doch beim Netzwerk komm ich einfach nicht mehr weiter.Beim P4P800 Board gibts ein onboard LAN von 3Com (treiber 3c2000), auf der treiber cd gibts auch eine linux datei 3c2000.tar.gz.

Folgendes hab ich dann gemacht:

ich hab die tar datei auf den desktop kopiert per console die datei entpackt, dann in den Ordner gewechselt und "make load" eingegeben (so stehts auch in der readme.txt auf der CD)

Allerdings kommt bei mir dann eine seitenlange Fehlermeldung (siehe unten).

Ich hab danach im Kontrollzentrum alle Packete die was mit kernel zu tun haben installiert, hat aber trotzdem nichts geholfen.

Was mir bei der Fehlermeldung aufgefallen ist, dass es sagt, dass ich die kernel sourcen installiert haben soll. In der txt auf der Treiber CD steht dann noch, dass ich den kernel source im Ordner /usr/src/linux oder /usr/src/linux-2.4 installiert haben soll

Jetzt bitte ich um eure Hilfe, da ich wirklich nicht mehr weiter weiß.

Grüße JABEZ

Fehlermeldung:

[root@localhost 3c2000]# make load
gcc: /usr/src/linux-2.4/include/linux/version.h: No such file or directory
gcc: no input files
gcc: /usr/src/linux-2.4/include/linux/autoconf.h: No such file or directory
gcc: no input files
gcc -D__KERNEL__ -Wall -Wstrict-prototypes -O2 -DMODULE -I. -DSK_USE_CSUM -I /us
r/src/linux-2.4/include -c -o skge.o skge.c
In file included from /usr/include/linux/prefetch.h:13,
from /usr/include/linux/list.h:6,
from /usr/include/linux/module.h:11,
from skge.c:344:
/usr/include/asm/processor.h:55: error: `CONFIG_X86_L1_CACHE_SHIFT' undeclared h
ere (not in a function)
/usr/include/asm/processor.h:55: error: requested alignment is not a constant
In file included from /usr/include/linux/module.h:297,
from skge.c:344:
/usr/include/linux/version.h:2:2: #error "======================================
================="
/usr/include/linux/version.h:3:2: #error "You should not include /usr/include/{l
inux,asm}/ header"
/usr/include/linux/version.h:4:2: #error "files directly for the compilation of
kernel modules."
/usr/include/linux/version.h:5:2: #error ""
/usr/include/linux/version.h:6:2: #error "glibc now uses kernel header files fro
m a well-defined"
/usr/include/linux/version.h:7:2: #error "working kernel version (as recommended
by Linus Torvalds)"
/usr/include/linux/version.h:8:2: #error "These files are glibc internal and may
not match the"
/usr/include/linux/version.h:9:2: #error "currently running kernel. They should
only be"
/usr/include/linux/version.h:10:2: #error "included via other system header file
s - user space"
/usr/include/linux/version.h:11:2: #error "programs should not directly include
<linux/*.h> or"
/usr/include/linux/version.h:12:2: #error "<asm/*.h> as well."
/usr/include/linux/version.h:13:2: #error ""
/usr/include/linux/version.h:14:2: #error "To build kernel modules please do the
following:"
/usr/include/linux/version.h:15:2: #error ""
/usr/include/linux/version.h:16:2: #error " o Have the kernel sources installed"
/usr/include/linux/version.h:17:2: #error ""
/usr/include/linux/version.h:18:2: #error " o Make sure that the symbolic link"
/usr/include/linux/version.h:19:2: #error " /lib/modules/`uname -r`/build exis
ts and points to"
/usr/include/linux/version.h:20:2: #error " the matching kernel source directo
ry"
/usr/include/linux/version.h:21:2: #error ""
/usr/include/linux/version.h:22:2: #error " o Now copy /boot/vmlinuz.version.h t
o"
/usr/include/linux/version.h:23:2: #error " /lib/modules/`uname -r`/build/incl
ude/linux/version.h"
/usr/include/linux/version.h:24:2: #error ""
/usr/include/linux/version.h:25:2: #error " o When compiling, make sure to use t
he following"
/usr/include/linux/version.h:26:2: #error " compiler option to use the correct
include files:"
/usr/include/linux/version.h:27:2: #error ""
/usr/include/linux/version.h:28:2: #error " -I/lib/modules/`uname -r`/build/in
clude"
/usr/include/linux/version.h:29:2: #error ""
/usr/include/linux/version.h:30:2: #error " instead of"
/usr/include/linux/version.h:31:2: #error ""
/usr/include/linux/version.h:32:2: #error " -I/usr/include/linux"
/usr/include/linux/version.h:33:2: #error ""
/usr/include/linux/version.h:34:2: #error " Please adjust the Makefile accordi
ngly."
/usr/include/linux/version.h:35:2: #error "=====================================
=================="
In file included from skge.c:344:
/usr/include/linux/module.h:299: error: syntax error before "UTS_RELEASE"
In file included from /usr/include/linux/mm.h:12,
from /usr/include/linux/slab.h:14,
from /usr/include/linux/proc_fs.h:5,
from skge.c:346:
/usr/include/linux/mmzone.h:44: error: `CONFIG_X86_L1_CACHE_SHIFT' undeclared he
re (not in a function)
/usr/include/linux/mmzone.h:44: error: requested alignment is not a constant
In file included from h/skdrv1st.h:96,
from skge.c:347:
/usr/include/linux/version.h:2:2: #error "======================================
================="
/usr/include/linux/version.h:3:2: #error "You should not include /usr/include/{l
inux,asm}/ header"
/usr/include/linux/version.h:4:2: #error "files directly for the compilation of
kernel modules."
/usr/include/linux/version.h:5:2: #error ""
/usr/include/linux/version.h:6:2: #error "glibc now uses kernel header files fro
m a well-defined"
/usr/include/linux/version.h:7:2: #error "working kernel version (as recommended
by Linus Torvalds)"
/usr/include/linux/version.h:8:2: #error "These files are glibc internal and may
not match the"
/usr/include/linux/version.h:9:2: #error "currently running kernel. They should
only be"
/usr/include/linux/version.h:10:2: #error "included via other system header file
s - user space"
/usr/include/linux/version.h:11:2: #error "programs should not directly include
<linux/*.h> or"
/usr/include/linux/version.h:12:2: #error "<asm/*.h> as well."
/usr/include/linux/version.h:13:2: #error ""
/usr/include/linux/version.h:14:2: #error "To build kernel modules please do the
following:"
/usr/include/linux/version.h:15:2: #error ""
/usr/include/linux/version.h:16:2: #error " o Have the kernel sources installed"
/usr/include/linux/version.h:17:2: #error ""
/usr/include/linux/version.h:18:2: #error " o Make sure that the symbolic link"
/usr/include/linux/version.h:19:2: #error " /lib/modules/`uname -r`/build exis
ts and points to"
/usr/include/linux/version.h:20:2: #error " the matching kernel source directo
ry"
/usr/include/linux/version.h:21:2: #error ""
/usr/include/linux/version.h:22:2: #error " o Now copy /boot/vmlinuz.version.h t
o"
/usr/include/linux/version.h:23:2: #error " /lib/modules/`uname -r`/build/incl
ude/linux/version.h"
/usr/include/linux/version.h:24:2: #error ""
/usr/include/linux/version.h:25:2: #error " o When compiling, make sure to use t
he following"
/usr/include/linux/version.h:26:2: #error " compiler option to use the correct
include files:"
/usr/include/linux/version.h:27:2: #error ""
/usr/include/linux/version.h:28:2: #error " -I/lib/modules/`uname -r`/build/in
clude"
/usr/include/linux/version.h:29:2: #error ""
/usr/include/linux/version.h:30:2: #error " instead of"
/usr/include/linux/version.h:31:2: #error ""
/usr/include/linux/version.h:32:2: #error " -I/usr/include/linux"
/usr/include/linux/version.h:33:2: #error ""
/usr/include/linux/version.h:34:2: #error " Please adjust the Makefile accordi
ngly."
/usr/include/linux/version.h:35:2: #error "=====================================
=================="
In file included from h/skdrv1st.h:147,
from skge.c:347:
/usr/include/linux/version.h:2:2: #error "======================================
================="
/usr/include/linux/version.h:3:2: #error "You should not include /usr/include/{l
inux,asm}/ header"
/usr/include/linux/version.h:4:2: #error "files directly for the compilation of
kernel modules."
/usr/include/linux/version.h:5:2: #error ""
/usr/include/linux/version.h:6:2: #error "glibc now uses kernel header files fro
m a well-defined"
/usr/include/linux/version.h:7:2: #error "working kernel version (as recommended
by Linus Torvalds)"
/usr/include/linux/version.h:8:2: #error "These files are glibc internal and may
not match the"
/usr/include/linux/version.h:9:2: #error "currently running kernel. They should
only be"
/usr/include/linux/version.h:10:2: #error "included via other system header file
s - user space"
/usr/include/linux/version.h:11:2: #error "programs should not directly include
<linux/*.h> or"
/usr/include/linux/version.h:12:2: #error "<asm/*.h> as well."
/usr/include/linux/version.h:13:2: #error ""
/usr/include/linux/version.h:14:2: #error "To build kernel modules please do the
following:"
/usr/include/linux/version.h:15:2: #error ""
/usr/include/linux/version.h:16:2: #error " o Have the kernel sources installed"
/usr/include/linux/version.h:17:2: #error ""
/usr/include/linux/version.h:18:2: #error " o Make sure that the symbolic link"
/usr/include/linux/version.h:19:2: #error " /lib/modules/`uname -r`/build exis
ts and points to"
/usr/include/linux/version.h:20:2: #error " the matching kernel source directo
ry"
/usr/include/linux/version.h:21:2: #error ""
/usr/include/linux/version.h:22:2: #error " o Now copy /boot/vmlinuz.version.h t
o"
/usr/include/linux/version.h:23:2: #error " /lib/modules/`uname -r`/build/incl
ude/linux/version.h"
/usr/include/linux/version.h:24:2: #error ""
/usr/include/linux/version.h:25:2: #error " o When compiling, make sure to use t
he following"
/usr/include/linux/version.h:26:2: #error " compiler option to use the correct
include files:"
/usr/include/linux/version.h:27:2: #error ""
/usr/include/linux/version.h:28:2: #error " -I/lib/modules/`uname -r`/build/in
clude"
/usr/include/linux/version.h:29:2: #error ""
/usr/include/linux/version.h:30:2: #error " instead of"
/usr/include/linux/version.h:31:2: #error ""
/usr/include/linux/version.h:32:2: #error " -I/usr/include/linux"
/usr/include/linux/version.h:33:2: #error ""
/usr/include/linux/version.h:34:2: #error " Please adjust the Makefile accordi
ngly."
/usr/include/linux/version.h:35:2: #error "=====================================
=================="
In file included from h/skdrv1st.h:154,
from skge.c:347:
/usr/include/linux/version.h:2:2: #error "======================================
================="
/usr/include/linux/version.h:3:2: #error "You should not include /usr/include/{l
inux,asm}/ header"
/usr/include/linux/version.h:4:2: #error "files directly for the compilation of
kernel modules."
/usr/include/linux/version.h:5:2: #error ""
/usr/include/linux/version.h:6:2: #error "glibc now uses kernel header files fro
m a well-defined"
/usr/include/linux/version.h:7:2: #error "working kernel version (as recommended
by Linus Torvalds)"
/usr/include/linux/version.h:8:2: #error "These files are glibc internal and may
not match the"
/usr/include/linux/version.h:9:2: #error "currently running kernel. They should
only be"
/usr/include/linux/version.h:10:2: #error "included via other system header file
s - user space"
/usr/include/linux/version.h:11:2: #error "programs should not directly include
<linux/*.h> or"
/usr/include/linux/version.h:12:2: #error "<asm/*.h> as well."
/usr/include/linux/version.h:13:2: #error ""
/usr/include/linux/version.h:14:2: #error "To build kernel modules please do the
following:"
/usr/include/linux/version.h:15:2: #error ""
/usr/include/linux/version.h:16:2: #error " o Have the kernel sources installed"
/usr/include/linux/version.h:17:2: #error ""
/usr/include/linux/version.h:18:2: #error " o Make sure that the symbolic link"
/usr/include/linux/version.h:19:2: #error " /lib/modules/`uname -r`/build exis
ts and points to"
/usr/include/linux/version.h:20:2: #error " the matching kernel source directo
ry"
/usr/include/linux/version.h:21:2: #error ""
/usr/include/linux/version.h:22:2: #error " o Now copy /boot/vmlinuz.version.h t
o"
/usr/include/linux/version.h:23:2: #error " /lib/modules/`uname -r`/build/incl
ude/linux/version.h"
/usr/include/linux/version.h:24:2: #error ""
/usr/include/linux/version.h:25:2: #error " o When compiling, make sure to use t
he following"
/usr/include/linux/version.h:26:2: #error " compiler option to use the correct
include files:"
/usr/include/linux/version.h:27:2: #error ""
/usr/include/linux/version.h:28:2: #error " -I/lib/modules/`uname -r`/build/in
clude"
/usr/include/linux/version.h:29:2: #error ""
/usr/include/linux/version.h:30:2: #error " instead of"
/usr/include/linux/version.h:31:2: #error ""
/usr/include/linux/version.h:32:2: #error " -I/usr/include/linux"
/usr/include/linux/version.h:33:2: #error ""
/usr/include/linux/version.h:34:2: #error " Please adjust the Makefile accordi
ngly."
/usr/include/linux/version.h:35:2: #error "=====================================
=================="
In file included from /usr/include/asm/hardirq.h:6,
from /usr/include/linux/interrupt.h:46,
from h/skdrv1st.h:161,
from skge.c:347:
/usr/include/linux/irq.h:65: error: `CONFIG_X86_L1_CACHE_SHIFT' undeclared here
(not in a function)
/usr/include/linux/irq.h:65: error: requested alignment is not a constant
In file included from /usr/include/linux/interrupt.h:46,
from h/skdrv1st.h:161,
from skge.c:347:
/usr/include/asm/hardirq.h:16: error: `CONFIG_X86_L1_CACHE_SHIFT' undeclared her
e (not in a function)
/usr/include/asm/hardirq.h:16: error: requested alignment is not a constant
In file included from h/skdrv1st.h:161,
from skge.c:347:
/usr/include/linux/interrupt.h:129: error: `CONFIG_X86_L1_CACHE_SHIFT' undeclare
d here (not in a function)
/usr/include/linux/interrupt.h:129: error: requested alignment is not a constant
In file included from h/skdrv1st.h:166,
from skge.c:347:
/usr/include/linux/netdevice.h:165: error: `CONFIG_X86_L1_CACHE_SHIFT' undeclare
d here (not in a function)
/usr/include/linux/netdevice.h:165: error: requested alignment is not a constant
In file included from h/skdrv1st.h:166,
from skge.c:347:
/usr/include/linux/netdevice.h:517: error: `CONFIG_X86_L1_CACHE_SHIFT' undeclare d here (not in a function)
/usr/include/linux/netdevice.h:517: error: requested alignment is not a constant
In file included from skge.c:347:
h/skdrv1st.h:172:26: net/checksum.h: No such file or directory
skge.c: In function `skge_probe':
skge.c:525: warning: integer constant is too large for "long" type
skge.c:644: error: `proc_net' undeclared (first use in this function)
skge.c:644: error: (Each undeclared identifier is reported only once
skge.c:644: error: for each function it appears in.)
skge.c:791:42: missing binary operator before token "("
skge.c: In function `skge_cleanup_module':
skge.c:986: error: `proc_net' undeclared (first use in this function)
skge.c:2039:41: missing binary operator before token "("
skge.c:2143:41: missing binary operator before token "("
skge.c:2199:41: missing binary operator before token "("
skge.c:2351:41: missing binary operator before token "("
skge.c:2442:41: missing binary operator before token "("
skge.c:2842:41: missing binary operator before token "("
skge.c:2936:41: missing binary operator before token "("
make: *** [skge.o] Fehler 1
[root@localhost 3c2000]#

JABEZ
15.02.2004, 15:40
also in der zwischenzeit hab ich rausgefunden, dass es bei der mdk 9.2 final version keinen kernel source gibt, hab den dann per google gefunden, gedownloaded und installiert.

Jetzt kommt nur noch eine "kleine" Fehlermeldung.

fehlermeldung kommt gleich, muss kurz nochmal linux starten

latissimus
16.02.2004, 16:00
also in der zwischenzeit hab ich rausgefunden, dass es bei der mdk 9.2 final version keinen kernel source gibt, hab den dann per google gefunden, gedownloaded und installiert.

Jetzt kommt nur noch eine "kleine" Fehlermeldung.

fehlermeldung kommt gleich, muss kurz nochmal linux starten

Hi, habe dasseöbe Problem, nur kann ich nicht von Linux auf Windows und umgekehrt zugreifen.

kannst Du mir weiterhelfen, habe das P4P800 Deluxe und ebenfalls diesen 3c2000. Besonders unter der Konfiguration mit dem Drakeconfig.

Bin am Überlegen, ob ich nicht die Powerpack-Version mit Handbuch kaufen soll, habe momentan die Download-Version.

P.S.: Hallo an alle :)

Wieso habe ich kein /usr/src/linux?

Ist das so anders als bei SuSe? Was ist denn jetzt diesbezüglich konform?