PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Samba Freigaben



Der Ritter
30.01.2004, 17:58
Hallo Leute

Ich habe auf meinem Server neben Windows XP jetzt seit 3 Wochen Suse 9.0 installiert. Ich habe vor Windows damit ab zu lösen, wenn Suse voll Konfiguriert ist. So wie ich es schon mit Windows XP gemacht habe. Wenn ich Suse gebootet habe und dann von meinem Windows XP Client darauf zu greifen will bekomme ich immer die Meldung:
Auf \\Server kann nicht zugegriffen werden. Sie haben eventuell keine Berechtigung, diese Netzwerkresource zu verwenden. Wenden Sie sich an den Administrator des Servers um herauszufinden, ob Sie über Berechtigung verfügen.

Ich versuche das schon seit 2 Wochen in den Griff zu kriegen. Ich habe etliche Anleitungen zur Konfiguration des Netzwerkes gelesen. Aber nichts hat geholfen, die Meldung ist immer die selbe.
Ich habe User namens Administrator unter Linux eingerichtet und in Samba mittels Webmin eingetragen. Auf dem Client bin ich auch mit Administrator eingelogt. Vielleicht könnt ihr mir hier weiter helfen. Jetzt noch meine smb.conf

Samba config file created using SWAT
# from 0.0.0.0 (0.0.0.0)
# Date: 2004/01/29 17:43:16

# Global parameters
[global]
workgroup = MSHEIMNETZ
netbios name = LINUX
server string = Samba Server
interfaces = eth0
bind interfaces only = Yes
security = SHARE
encrypt passwords = Yes
username map = /etc/samba/smb.users
time server = Yes
os level = 2
local master = No
wins support = Yes
lock dir = /var/lock/samba
guest ok = Yes

[homes]
comment = Heimatverzeichnis
path = /home/Administrator
username = Administrator
browseable = yes
writeable = yes
public = yes
guest only = no
directory mask = 777
create mask = 666

[cdrom]
comment = Linux CD-ROM
path = /cdrom
browseable = yes
locking = No

[printers]
comment = All Printers
path = /tmp
create mask = 0700
printable = Yes
browseable = No

Gruß

Der Ritter

damager
30.01.2004, 18:00
blöde frage:
ist den winxp rechner mitglied in der workgroup MSHEIMNETZ ?

Der Ritter
30.01.2004, 19:18
Hast Recht is ne blöde Frage.

Der Windows XP Client ist in der Workgroup MSHEIMNETZ.

Gruß

Der Ritter

damager
30.01.2004, 19:24
sorry aber ich kenne die M$ defaults nicht ...
aber anhand des names hätte ich drauf schließen sollen...

schon mal mit security-level "user" probiert?

Der Ritter
30.01.2004, 19:39
Ja das hatte ich schon mal versucht und habe es eben noch mal ausprobiert.

Gruß

Der Ritter

dalex
30.01.2004, 21:32
Gut die Benutzer sind gleich eingerichtet. Aber benutzt du auch die gleichen Paßwörten? Auf Groß- und Kleischreibung achten.

Gruß dalex

Der Ritter
30.01.2004, 22:25
Ja ich benutze die selben Passwörter und ich habe auch auf die Groß- und Kleinschreibung geachtet.

Gruß

Der Ritter

fahrino
02.02.2004, 19:08
Ich weis nicht genau was du vorhast, aber du solltest dir auf jeden Fall mal diesen Thread hier:http://www.rootboard.de/vb3/showthread.php?t=97 angucken. Da geht es um Samba als Domänencontroller.

dalex
02.02.2004, 19:53
Vielleicht das noch:

Bei mir hat erst Samba einwandfrei funktioniert, als ich Suse als Server (Firewalleinstellung) konfiguriert habe. Davor hatte ich auch keinen Zugriff auf die Samba-Freigaben.

Gruß dalex

damager
02.02.2004, 20:18
die suse firewall schreibt doch auch los ...
weiss zwar nicht genau wo aber das dürfte evtl weiterhelfen ... evtl werden nur die zugriffe reject'd.

Der Ritter
04.02.2004, 18:31
Hallo

Den Thread Samba als Domän Controller hatte ich bereits ausprobiert. Und Die Firewall hatte ich auch schon entsprechend eingestellt. Die Log Datei der Firewall habe ich zwar noch nicht gefunden, aber ich habe die log.smbd gefunden und folgendes Entdeckt.

[2004/02/04 18:07:54, 0] smbd/server.c:main(791)
smbd version 2.2.8a-SuSE started.
Copyright Andrew Tridgell and the Samba Team 1992-2002
[2004/02/04 18:07:54, 0] param/loadparm.c:map_parameter(2094)
Unknown parameter encountered: "* directory mode"
[2004/02/04 18:07:54, 0] param/loadparm.c:lp_do_parameter(2782)
Ignoring unknown parameter "* directory mode"
[2004/02/04 18:07:54, 0] param/loadparm.c:map_parameter(2094)
Unknown parameter encountered: "* username map"
[2004/02/04 18:07:54, 0] param/loadparm.c:lp_do_parameter(2782)
Ignoring unknown parameter "* username map"
[2004/02/04 18:07:54, 0] param/loadparm.c:map_parameter(2094)
Unknown parameter encountered: "* encrypt passwords"
[2004/02/04 18:07:54, 0] param/loadparm.c:lp_do_parameter(2782)
Ignoring unknown parameter "* encrypt passwords"
[2004/02/04 18:07:54, 0] param/loadparm.c:map_parameter(2094)
Unknown parameter encountered: "* socket options"
[2004/02/04 18:07:54, 0] param/loadparm.c:lp_do_parameter(2782)
Ignoring unknown parameter "* socket options"
[2004/02/04 18:07:54, 0] param/loadparm.c:map_parameter(2094)
Unknown parameter encountered: "* keepalive"
[2004/02/04 18:07:54, 0] param/loadparm.c:lp_do_parameter(2782)
Ignoring unknown parameter "* keepalive"
[2004/02/04 18:07:54, 0] param/loadparm.c:map_parameter(2094)
Unknown parameter encountered: "* time server"
[2004/02/04 18:07:54, 0] param/loadparm.c:lp_do_parameter(2782)
Ignoring unknown parameter "* time server"

Könnt Ihr damit was anfangen? Bitte helft mir.

Gruß

Der Ritter

Vincent_Vega
20.01.2005, 17:30
habe vor kurzem auch einen samba-server unter suse 9.0 eingerichtet ...

probiers mal mit diesem link
http://www.id.unizh.ch/services/pc-mac-support/IL/D_Stamatelatos/ethernet/samba.html

und schreibe bei [homes]
mal folgendes hinzu


available = yes

damit wird der dienst fürs zugreifen erst verfügbar ...

p.s.: schau mal unter im forum unter samba .. und dann den beitrag vom zico rein .. der beginnt mit "versteckte ... "

da haben wir das prob mit unserem samba-server gelöst ... [siehe links dort]

cia