PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Von Win NT auf Samba Freigabe zugreifen.



Nicemice
06.01.2004, 14:26
Hallo

Ich bin voll der suse NOOB und hab fast keine Ahnung!!! :-)

Also ich hab einen nt40 rechner der in einer windows Domaine Mitglied ist.
Mein Linux Server ist im gleichen Physikalischen Netzwerk aber kein Mitglied in er Domain.

Ich habe eine freigabe mit Samba erstellt, diese läuft auch. Wenn ich jetzt versuche diese mit meinem NT rechner zu mounten. Bekomm ich die Meldung, das ich ein Usernamen und ein PW eingeben muss.

Die Freigabe in der smb.conf sieht so aus.

[html]
path = /svr/www
guest ok = yes

Wenn ich jetzt die benutzerdaten für den root eingebe kann ich aber immer noch nicht auf die Freigabe zugreifen.

Was mach ich falsch?

MFG

Nicemice

Ich bedanke mich schon mal für die schnelle Hilfe

control
06.01.2004, 14:29
hast hast du den user smbpasswd -a username hinzugefügt?

Nicemice
06.01.2004, 14:32
Was ist das denn wenn ich fragen darf?

Wo muss man das denn hinzufügen?

control
06.01.2004, 14:41
ich denke schon. so mache ich es. ein smbpasswd -e username kann auch nicht schaden.

Nicemice
06.01.2004, 14:49
Es ist zwar ziehmlich cool das ihr mir so schnell antwortet leider kann ich damit nichts anfangen. :-)

Es gibt eine smbpasswd datei im Ordner Samba.
Dort muss ich wie ich euch verstanden habe einen User anlegen.

Soweit richtig?

Dies tu ich indem ich da diese Zeile rein schreibe

smbpasswd -e nicemice

Wenn ich dies aber mach passiert weiter nichts.

Sorry hab nicht wirklich die Ahnung

control
06.01.2004, 15:00
-e bedeutet enabled
-a bedeutet add

du solltes bevor du ein -e machst ein -a machen.

h2owasser
06.01.2004, 15:32
Es ist zwar ziehmlich cool das ihr mir so schnell antwortet leider kann ich damit nichts anfangen. :-)

Es gibt eine smbpasswd datei im Ordner Samba.
Dort muss ich wie ich euch verstanden habe einen User anlegen.

Soweit richtig?

Dies tu ich indem ich da diese Zeile rein schreibe

smbpasswd -e nicemice

Wenn ich dies aber mach passiert weiter nichts.

Sorry hab nicht wirklich die Ahnung

Nein, so geht das nicht. Diese Befehle mußt du in der Console eingeben. Und auch nur dann, wenn du verschlüsselte Passwörter benutzt. Kauf dir am besten erstmal ein gutes Buch oder schau im Internet nach Anleitungen, Howtos usw. Sonst kann ich dir noch http://www.rootboard.de/vb3/showthread.php?t=97
empfehlen.

Nicemice
08.01.2004, 15:39
ES GEHT


Super Danke THX



--> ICH DOOF

tr0nix
08.01.2004, 17:12
Dann hast du aber keine identifizierung des Users. Willst du das? Sonst mach das:

unter [global]:
security = user

unter dem [] des sharenamens:
write list = user1,user2,user3 # Welche User schreiben duerfen
path = /pfad/zum/ort
public = yes # Wenn man den Share sehen soll, sonst no


Anschliessend eroeffnest du die 3 User im System UND mit smbpasswd -a!

Der Vorteil hier ist, dass wenn user1 eine Datei hochlaedt, diese auf dem System ebenfalls "user1" gehoert. Wenn du willst, dass alle User auf die Daten der anderen user zugreifen koennen, aber nicht veraendern, kannst du noch das machen:
groupadd <beispielgruppe>

In /etc/group bei der neuen Gruppe die Usernamen nach dem : mit Komma separiert eintragen.

Wenn du noch mehr hilfe brauchst, sags einfach! Aber eben, ich wuerde Samba nur mit Benutzerauthentifizierung brauchen.. sonst kann jeder rein!

Denk daran, nach jeder Configaenderung in smb.conf musst du samba restarten. Nicht jedoch bei User die du in smbpasswd aufnimmst! Wenn du nicht nach jedem User den du in "write list = " aufnimmst restarten willst (write list steht ja im smb.conf), mache eine Gruppe mit Benutzer die schreiben duerfen und schreibe ins Configfile "write list = @gruppenname".

Greetz
Joel

(BTW. beim schreiben in das Directory zaehlen die Unix Rechte! Haben die User also keine Rechte in das Verzeichniss zu schreiben wird das auch nicht gehen wenn diese in der "write list" sind. Achte also auf die Gruppe des Verzeichnisses in das die User was hochladen sollen.)