PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Samba Share mounten (Bad password)



rup
29.12.2003, 15:09
Hallo,

ich moechte von meinem Linux Rechner ein Share von einem Samba Server mounten, dies scheitert jedoch an folgender Fehlermeldung. Unter Windows XP kann ich das Share mappen. Ich kann von Linux auch Shares von W2k Server mounten. Ich hab auch verschiedene Accounts probiert. Auch eine manuelle Eingabe des Passworts hilft nichts.

Auf den Samba Server selber hab ich keinen Zugriff, ich weiss nur das er auf einer Siemens Maschine (sinix) laeuft.

1903: session setup failed: ERRSRV - ERRbadpw (Bad password - name/password pair in a Tree Connect or Session Setup are invalid.)
SMB connection failed

unter anderem hab ich folgende Befehle versucht.
smbmount //rechnername/share /mnt/samba/ -o username=rup
mount -t smbfs -o username=rup,password=geheim //rechnername/share /mnt/samba

control
29.12.2003, 15:38
hast du bei windows eine firewall an?

rup
29.12.2003, 15:55
Ich will von einem Linuxrechner auf ein Samba Share zugreifen.

control
29.12.2003, 16:04
ja, genau. wenn du xp hast dann gibest da auch so eine firewall von ms und die verhindert das du drauf zugreifen kannst, oder du versuchst mal mount -t smbfs -o username=winrechner\rup,password=geheim //rechnername/share /mnt/samba

rup
29.12.2003, 16:08
Nein, bei dem Problem ist ueberhaupt kein Windows im Spiel.
Von Windows auf Samba-Server gehts, von Linux auf Windows Share gehts auch, es geht aber von Linux auf Samba Share (auf einer Sinix Maschine) nicht.
Auf dem Linux-Rechner ist keine FW

control
29.12.2003, 16:11
ah, ok. stehe heute etwas neben mir.
hast du smbfs in den kernel compiliert?

Aracon
29.12.2003, 16:17
Wieso das langsame SMB für Linux zu Linux, da würde ich doch lieber nfs nehmen.

rup
29.12.2003, 16:19
da ich auf den Server nur Zugriff ueber SMB habe, es laeuft kein NFS auf der Maschine.

fahrino
29.12.2003, 16:58
Hast du es mal über linneigbourhood probiert?

rup
29.12.2003, 20:39
Noch nicht, werd ich aber morgen frueh gleich nachholen.

h2owasser
29.12.2003, 20:51
kannst du mir mal sagen, was

smbclient -L host

sagt.

Außerdem ob der win2k-server und der samba-server im gleichen netzwerk arbeiten und ob die server ihre passworter verschlüsseln.

rup
30.12.2003, 07:26
Der Win2k Server und der Unix-Samba Server sind nicht im gleichen Netz.
ddc_project moechte ich mounten. Ob die Server Passwoerter verschluesseln weiss ich nicht, wie kann ich das feststellen (Samba-DAU)?

smbclient -L name
added interface ip=172.26.175.115 bcast=172.26.175.255 nmask=255.255.255.0
Password:
Anonymous login successful
Domain=[WORKGROUP] OS=[Unix] Server=[Samba 2.0.7]

Sharename Type Comment
--------- ---- -------
dcc_project Disk
automationKM Disk
...
...
statadm Disk statadm's Service
IPC$ IPC IPC Service (Samba 2.0.7)

Server Comment
--------- -------

Workgroup Master
--------- -------

h2owasser
30.12.2003, 13:08
Der Win2k Server und der Unix-Samba Server sind nicht im gleichen Netz.
ddc_project moechte ich mounten. Ob die Server Passwoerter verschluesseln weiss ich nicht, wie kann ich das feststellen (Samba-DAU)?

smbclient -L name
added interface ip=172.26.175.115 bcast=172.26.175.255 nmask=255.255.255.0
Password:
Anonymous login successful
Domain=[WORKGROUP] OS=[Unix] Server=[Samba 2.0.7]

Sharename Type Comment
--------- ---- -------
dcc_project Disk
automationKM Disk
...
...
statadm Disk statadm's Service
IPC$ IPC IPC Service (Samba 2.0.7)

Server Comment
--------- -------

Workgroup Master
--------- -------

hmm. Also vorweg fällt mir auf das die version 2.0.7 eine ganz
schön alte ist. -

Wenn sich andere Maschinen auf dem smb-server anmelden können, dann müßte man mal schauen, ob der server verschlüsselte passworter entgegenninnt.
Zu schauen in smb.conf:

[global]
workgroup = TUX-NET
hosts allow = 192.168.1. 192.168.2.0./24
security = user
...........
...........
encrypt passwords = Yes
...........

Ist diese (letzte) Option gesetzt, muß jedes Benutzerpasswort nochmal neu mit smbpasswd am server gesetzt werden. - Hier wird es aber auch gerade interessant. Es kann es auch sein, das Einbenutzer nicht von allen Clients connecten darf.

rup
30.12.2003, 13:34
Dumme Frage, wie schalte ich am Client zwischen verschluesselt und unverschluesselt um? Bei smbmount kann ich nichts dergleichen finden.

rup
30.12.2003, 13:54
Ich hab gerade mit dem Admin des Samba Servers gesprochen. Der Server ueberprueft das Passwort ueber irgend einem Password-Server, und hier scheint es ein Problem zu geben.

h2owasser
30.12.2003, 14:34
Ich hab gerade mit dem Admin des Samba Servers gesprochen. Der Server ueberprueft das Passwort ueber irgend einem Password-Server, und hier scheint es ein Problem zu geben.

dann steht da bei security irgentwas anderes.

seim
07.11.2009, 22:40
mount -t smbfs -o username=rup,password=geheim //rechnername/share /mnt/samba

Wenn ich jetzt nicht will, dass mir jemand genau in diesem Augenblick über die Schulter guckt oder anders gesagt.. Wie kann ich das Passwort so eingeben, dass die Zeichen nicht auf dem Bildschirm erscheinen?


P.S. Der Thread ist von 2003, ja sowas findet man schonmal wenn man brav Google benutzt - also bitte nicht zum oben genannten Problem antworten.

pyropeter
08.11.2009, 13:54
du könntest vorher eine steuersequenz ausgeben, die die ausgabe der getippten zeichen unterbindet.

MfG, PyroPeter