PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : MDK 9.2 und Kernel 2.6



redlabour
19.12.2003, 15:34
So ein passendes RPM für den Kernel hab ich nu´ .

Muss ich etwas bestimmtes beachten wenn ich den Kernel per RPM installiere ?

Bestimmte Abhängigkeiten die sich nicht per urpmi bzw. Mandrakekontrollzentrum direkt anzeigen ?

Frage mal so blöd weil ich noch nie einen Kernel per RPM installiert habe.

NiceDay
19.12.2003, 20:10
Was bestimmtes beachten? Jo nach der Install einmal "lilo" ausführen (ein Eintrag wird in die lilo.conf zugefügt jedoch das Kommando "lilo" nicht direkt ausgeführt).
Abhängikeiten müssten per urpmi direkt aufgezeigt werden.

Bis jetzt habe ich aber nur die Version "2.6.0-0.test5.1" gefunden, d.h. nicht die aktuelle 2.6.0-stable!

redlabour
26.12.2003, 12:48
So, habe ich nun gemacht und mir extra einen Eintrag für den alten 2.4´er aufbewahrt.

Fakt :

2.6 - X nicht möglich NVidia Kernel Module is missing.
Schönen Dank auch für den neuen Treiber nvidia - wieso proggen die einen Installer wenn der nicht alles mitbringt ?

2.4 - System ist platt - Kernel Panic no ID mode

3 Tage Arbeit sind dahin - wär mir wohl bei Win wieder mal nicht passiert !

Weiterer Fakt - Wieso macht man sich den Stress überhaupt und kauft sich keinen Mac mit einem funktionierenden OS ? 8o

Wieso läuft das System nun nicht mal mehr mit dem 2.4´er ? Was macht der Sch.... 2.6´er denn ? Wieso soll man sich dann zur 'Sicherheit' (ich lach mich weg) den Eintrag erhalten wenn er nach einem Boot mit 2.6´er
eh nicht mehr läuft ?

Sorry - aber bin gerade etwas = :devil: :finger:

X(

Hat jemand einen Tipp wie ich beim 2.6´er in der Konsole meinen alten MDK Kernel (der mit dem blauen Bootprompt) wiederbekomme ohne zu formatieren ?

Der jetzige 2.4´er hat den Bootprompt auch nicht.... ist das überhaupt der alte ?

redlabour
26.12.2003, 15:08
Also habe die lilo.conf nochmals editiert.

Kernel 2.4.22-10mdk ist nun der Standard.
Der sagt jedoch :

Kernel requires old insmod, but couldn't run /bin/insmod.old: No such file or directory.

Dies sagt er sowohl bei jbd.ko module als auch bei ext3.ko module .

Abschliessen tut er mit :

Kernel panic: No init found. Try passing init= option to kernel.

Was tun ?

Ich würde mal vorschlagen zuallerst damit aufzuhören den Usern zu erzählen mit einem Eintrag des alten Kernels in die lilo.conf nach dem Update wäre jedes Risiko ausgeschlossen.

Kann ich per urpmi den alten einfach neu drüberziehen und den 2.6' er deinstallieren ?

Wenn ja - mit welchen Befehlen in der Konsole ?

redlabour
26.12.2003, 19:29
Danke MDK =

http://www.unixboard.de/comments.php?catid=12&id=210

Vielleicht wird es ja so etwas mit dem 2.6´er ! ;)