PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : curl: (7) couldn't connect to host



doc
10.03.2011, 20:39
curl -I '<anyURL>'

bringt bei mir die meldung
curl: (7) couldn't connect to host

hat irgendwer eine ahnung woran das liegen könnte, oder kann jemand mit aktuellem arch das mal eben bei sich testen.

ping und alles andere läuft problemlos ...

konkretes beispiel:

von nem server mit debian lenny:

curl -I 'http://www.unixboard.de/vb3/showthread.php?47713-curl-(7)-couldn-t-connect-to-host'
HTTP/1.1 200 OK
Date: Thu, 10 Mar 2011 20:51:48 GMT
Server: Apache/2.2.16 (FreeBSD) mod_fastcgi/2.4.6 mod_ssl/2.2.16 OpenSSL/0.9.8k
Set-Cookie: unixboard_; path=/; domain=.unixboard.de; HttpOnly
Set-Cookie: unixboard_lastvisit=1299790308; expires=Fri, 09-Mar-2012 20:51:48 GMT; path=/; domain=.unixboard.de
Set-Cookie: unixboard_lastactivity=0; expires=Fri, 09-Mar-2012 20:51:48 GMT; path=/; domain=.unixboard.de
Cache-Control: private
Pragma: private
Content-Length: 25913
Content-Type: text/html; charset=ISO-8859-1

at home mit aktuellem arch

curl -I 'http://www.unixboard.de/vb3/showthread.php?47713-curl-(7)-couldn-t-connect-to-host'
curl: (7) couldn't connect to host

marce
10.03.2011, 21:13
evtl. einfach ein Nameserver-Problem? Hier geht's problemlos... (Auch mit Arch...)

doc
10.03.2011, 21:22
danke für den test.
bei nem nameserver problem würde das wohl nicht gehen:

ping unixboard.de
PING unixboard.de (82.193.243.67) 56(84) bytes of data.
64 bytes from housing-b67.bytecamp.net (82.193.243.67): icmp_req=1 ttl=55 time=26.7 ms
64 bytes from housing-b67.bytecamp.net (82.193.243.67): icmp_req=2 ttl=55 time=25.3 ms

und wie gesagt es gibt ansonsten keinerlei probleme nur curl will nicht mehr ...

und du hast wirklich ein aktuelles arch ?

weil ich hab das hier in verdacht:
[2011-03-09 17:41] upgraded kernel26 (2.6.37.2-1 -> 2.6.37.3-1)
[2011-03-09 17:41] upgraded kernel26-headers (2.6.37.2-1 -> 2.6.37.3-1)

ansonsten muss ich wohl mal sehen was ich in der letzten zeit deinstalliert habe und als verantwortlicher in frage kommen könnte :(

HeadCrash
10.03.2011, 21:23
Proxy einstellungen oder ähnliches?

marce
10.03.2011, 21:25
und du hast wirklich ein aktuelles arch ?

[2011-03-10 22:16] upgraded kernel26 (2.6.37.1-1 -> 2.6.37.3-1)
[2011-03-10 22:16] Fixing gshadow file ...
[2011-03-10 22:16] upgraded shadow (4.1.4.2-4 -> 4.1.4.3-1)
[2011-03-10 22:16] upgraded tzdata (2011b-1 -> 2011c-1)
[2011-03-10 22:16] upgraded wget (1.12-4 -> 1.12-5)

ja :-)

wget tut?

... und mach mal ein curl -vvv $url...

doc
10.03.2011, 21:28
wget unixboard.de
--2011-03-10 22:26:52-- http://unixboard.de/
Auflösen des Hostnamen »unixboard.de«.... 82.193.243.67
Verbindungsaufbau zu unixboard.de|82.193.243.67|:80... verbunden.
HTTP Anforderung gesendet, warte auf Antwort... 200 OK
Länge: 62824 (61K) [text/html]
In »»index.html«« speichern.

100%[================================================== ================================================== ===============>] 62.824 154K/s in 0,4s

2011-03-10 22:26:53 (154 KB/s) - »»index.html«« gespeichert [62824/62824]



ich hab kein router, ich hab kein proxy, ich hab keine firewall ...

könnte der provider da irgend nen scheiss verzapfen ?

doc
10.03.2011, 21:35
uhm ok vielen dank

curl -vvv 'http://www.unixboard.de/vb3/showthread.php?47713-curl-(7)-couldn-t-connect-to-host'
* About to connect() to proxy localhost port 9999 (#0)

ich habe letztens diverse browser getestet und deren möglichkeiten einen proxy zu benutzen ... sehr seltsam das da einer anscheinend irgendwo ein globale proxy einstellung vorgenommen hat, von der anscheinend nur curl wirklich betroffen ist

/me ist verwirrt und sucht nach der config

doc
10.03.2011, 21:50
hmmh joa evtl hat da irgend einer der browser die gnome-proxy einstellung verändert zumindest war da dieser proxy eingestellt, man sollte halt nicht zuviel mit diesem beta klickibunti-kram rumspielen :)

mich wundert nur noch warum nur curl damit probleme hatte ...

aber danke [solved]

HeadCrash
11.03.2011, 07:50
Morgen,

liegt an der Konfiguration von wget, der ignoriert in den Defaulteinstellungen die Proxy-Environmentvariablen (http://forum.ubuntuusers.de/topic/wget-ignoriert-systemweite-proxyeinstellungen/#post-2790340) während curl sie auswertet, bin da auch rigendwann mal drüber gestolpert. Für beide gibt es übrigends eine "--no-proxy"-Option.

mfg
HeadCrash