PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Kann svgalib nicht installieren



bartlaby
20.10.2003, 20:25
Moin
also ich bin nun auch mehr oder weniger fertig mit der Installation.
Nun wollte ich KDE installieren, aber wenn svgalib installiert werden soll kommt die Fehlermeldung im Anhang
Ich hab die Sourcen auch schon manuell runtergeladen und make install versucht, aber es kommt das gleiche
Weiss jemand hilfe?
danke schonmal
bartlaby

PS: die wahrscheinlich interessanten letzten zeilen:


/var/tmp/portage/svgalib-1.4.3-r4/work/svgalib-1.4.3/src/vga.c:3919:31: pasting "." and "HDisplay" does not give a valid preprocessing token
/var/tmp/portage/svgalib-1.4.3-r4/work/svgalib-1.4.3/src/vga.c:3920:33: pasting "." and "HSyncStart" does not give a valid preprocessing token
/var/tmp/portage/svgalib-1.4.3-r4/work/svgalib-1.4.3/src/vga.c:3921:31: pasting "." and "HSyncEnd" does not give a valid preprocessing token
/var/tmp/portage/svgalib-1.4.3-r4/work/svgalib-1.4.3/src/vga.c:3922:29: pasting "." and "HTotal" does not give a valid preprocessing token
/var/tmp/portage/svgalib-1.4.3-r4/work/svgalib-1.4.3/src/vga.c:3923:31: pasting "." and "VDisplay" does not give a valid preprocessing token
/var/tmp/portage/svgalib-1.4.3-r4/work/svgalib-1.4.3/src/vga.c:3924:33: pasting "." and "VSyncStart" does not give a valid preprocessing token
/var/tmp/portage/svgalib-1.4.3-r4/work/svgalib-1.4.3/src/vga.c:3925:31: pasting "." and "VSyncEnd" does not give a valid preprocessing token
/var/tmp/portage/svgalib-1.4.3-r4/work/svgalib-1.4.3/src/vga.c:3926:29: pasting "." and "VTotal" does not give a valid preprocessing token
make[1]: *** [.depend.src] Error 1
make[1]: Leaving directory `/var/tmp/portage/svgalib-1.4.3-r4/work/svgalib-1.4.3/staticlib'
make: *** [staticlib/libvga.a] Error 2

!!! ERROR: media-libs/svgalib-1.4.3-r4 failed.
!!! Function src_compile, Line 33, Exitcode 2
!!! (no error message)

cellarcat
16.11.2003, 03:27
I had exactly the same problem and solved it by changing compilers from GCC 3.3.2 to GCC 3.2.3-r2. Hope it works for you!