PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Keyboard problem



TheBunman
15.10.2003, 22:11
Hi!
hab mir gestern gentoo installiert und bin tierisch zufrieden damit! hammergeile ladezeiten, da hat sich die etwas längere installation auf jeden fall gelohnt. ausserdem bin ich jetzt schon absolut begeister von emerge und kemerge :)

Leider hab ich noch ein kleines Tastatur problem. Ich kann im kompletten KDE enviroment keine @ zeichen machen (das hier is mit copy pate gekommen *g) wenn ich vim benutze kan ich nicht die INSERT taste benutzen, da dadurch nur das zeichen unter dem cursor gross oder klein gemacht wird. d.h. ist vim unbenutzbar mit diesem prob. ausserdem wenn ich im vim pfeil nach oben machen kommt ein A bei nach unten nen B und so geht das mit den anderen pfeiltasten weiter mit C und D. die tasten HOME und END klappen auch nicht. bei HOME kommt nen H und bei END kommt nen F.
in der text konsole kann ich zwar das @ machen aba auch im vim wieder diese probleme (kommen aba andre buchstaben bei den HOME und END tasten und so). ausserdem kommen statt äöü irgendwelche komischen *g* zeichen.

meine XF86config:
Option "XkbVariant" "nodeadkeys"
Option "XkbRules" "xfree86"
Option "XkbModel" "pc104"
Option "XkbLayout" "de_DE@euro"

rc.conf:
KEYMAP="de-latin1-nodeadkeys"
EXTENDED_KEYMAP="windowkeys"
CONSOLEFONT="lat9w-16"

ich habe eine deutsche standard tastatur mit schaebbigen windows tasten :P


ausserdem wollte ich Wolfenstein: Enemy Territory zocken, was aber immer mit

-----------------------
----- CL_Shutdown -----
-----------------------
Sys_Error: Sys_LoadDll(ui) failed, no corresponding .so file found in fs_homepath or fs_basepath

abstürtzt


hoffe einer von euch weiss da rat :)

ps.: hab grad gemerkt das die eckigen klammern auch nich klappen :/

saiki
16.10.2003, 15:23
XF86Config bei mir:


Option "XkbRules" "xfree86"
Option "XkbModel" "pc105"
Option "XkbLayout" "de"
Option "XkbVariant" "nodeadkeys"


rc.conf:



KEYMAP="de"
EXTENDED_KEYMAP="windowkeys"
CONSOLEFONT="lat9w-16"

TheBunman
16.10.2003, 17:31
okay jetz klappen @ und € und so alles :)

jedoch sehe ich im irc keine sonderzeichen wie äöü (ae oe ue) und im vi das problem besteht immernoch. bzw in der console halt kann ich keine INSERT, DELETE, PG UP, PG DN und so machen ....

merc
20.10.2003, 12:02
Im IRC musst du dein Charakter Set von auf "ISO-8859-1 (Western Europe)" setzen. Da steht im moment sicher "UTF-8" ... Wenn du X-Chat2 benutzt geht das unter "Server List" (CTRL-S)