PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : upgrade Problem



schwedenmann
09.08.2009, 15:00
Hallo


Habe ein Problem beim Upgrade von Arch-unstable

Am Ende von pac,an -Syu kommt folgendes:


checking package integrity...
:: File glibc-2.10.1-3-i686.pkg.tar.gz is corrupted. Do you want to delete it? [Y/n] n
error: failed to commit transaction (invalid or corrupted package)
glibc-2.10.1-3-i686.pkg.tar.gz is invalid or corrupted
Errors occurred, no packages were upgraded.


Auch ein pacman -S glibc
oder
pacman-Sf glibc

führt zu keinem Erfolg.
Hab auch schon die Mirror gewechslt (i.Moment 1. Mirror Esslingen) und nach pacman -Sc, nochmals komplett yu laufen lassen, keine Änderung.
Wie kriege ich jetzt ein pacman -syu hin ?

mfg
schwedenmann

espo
10.08.2009, 07:15
Ne Idee wäre mal die distfiles auf der Platte zu löschen. Und dann nochmal versuchen.

Gruss

skull-y
10.08.2009, 13:13
Wenn das Paket schon beschädigt auf dem Archlinux-Server so liegt, wird das Wechseln des Mirrors nicht viel bringen.

Ist das unstable-Paket so wichtig oder würde das aus den stable-Quellen auch ausreichen?