PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Sound unter Mandrake 9.1 / sis7012



ceus79
11.09.2003, 10:27
Ich versuche hier gerade bei nem Freund den Sound unter Mandrake zum laufen zu bringen.
Das ist eine onboard Soundkarte mit diesem SiS7012 Chip.

Ich habe es zwar geschafft die modules.conf so zu verändern das der Sound nach einem Neustart von alsa einwandfrei läuft, aber nach einem reboot vom PC verändert Mandrake die modules.conf wieder und der Sound ist wieder weg :-(
Wie kann ich verhindern das mandrake ständig diese Datei zerschießt??

Andre
11.09.2003, 11:11
Wenn du als root "modprobe Modulname" ausfürst, sollten die Module doch idR immer beim start geladen werden...

ceus79
13.09.2003, 13:54
Ich glaube das istnicht das Problem, oder ich verstehe das Falsch.
Die modules.conf sieht so aus:

#OSS
alias char-major-14 soundcore
alias sound-slot-0 snd-0

alias sound-service-0-0 snd-mixer-oss
alias sound-service-0-1 snd-seq-oss
alias sound-service-0-3 snd-pcm-oss
alias sound-service-0-8 snd-seq-oss
alias sound-service-0-12 snd-pcm-oss

#Alsa
alias char-major-116 snd
alias snd-card-0 snd-intel8x0


Wenn modules.conf so aussieht und ich alsa neu starte, geht der Sound einwandfrei.
Nach einem Neustart fügt Mandrake aber automatisch die Zeile

"above snd-intel8x0 snd-pcm-oss"

hinzu, was dazu führt das der Sound wieder streikt. Entferne ich die Zeile und starte Alsa neu, geht es wieder.
Kann damit jemand was anfangen?

Tarzipan
14.09.2003, 10:43
am besten gehst du in kontrollzentrum unter hardware und lädst sounddrake. da kannst du manuell den treiber auswählen, den er dann auch immer laden müsste.

ceus79
15.09.2003, 10:43
Klappt nicht. Sounddrake behauptet jetzt es gibt keinen treiber für meine Soundkarte...davor konnte ich wenigstens noch was auswählen.