PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Mono unter Etch zwei Versionen



Bender_OS
16.03.2008, 10:00
Hallo Leute

Mist habe ein kleines Problem bei meiner Mono installation auf Debain etch.

habe mono über:
apt-get -t etch-backports install mono
als root installiert. :brav:

Ich möchte das Mono für den BF2CCD (ein Battlefield Server Remote Tool)
benutzen. Es läuft allerdings nur mit der Monoversion 1.1.12.x :oldman

Nach der Installation habe ich unter root die richtige Version aber unter den andern Usern eine neuere. (siehe screenshot)

Da ich die Gameserver nicht als root laufen lassen möchte weiß ich jetzt nicht mehr weiter :think::think::think:

http://www.igelbrink.com/ssh_023.jpg

Danke schon mal im Vorraus :headup:

bender

Bender_OS
16.03.2008, 11:42
habe in der bashrc folgendes im rootverzeichnis gefunden:



export PATH="/opt/mono-1.1.12.1/bin:$PATH"

export PKG_CONFIG_PATH="/opt/mono-1.1.12.1/lib/pkgconfig:$PKG_CONFIG_PATH"

export MANPATH="/opt/mono-1.1.12.1/share/man:$MANPATH"

export LD_LIBRARY_PATH="/opt/mono-1.1.12.1/lib:$LD_LIBRARY_PATH"

das habe ich dann in die anderen bashrc reinkopiert.
jetzt wird mir immer die richtige version angezeigt.

Muste mein startscript noch anpassen und die shell ändern.
Habe 3 BF2 Server auf dem Root laufen jeweils mit anderen Usernamen.
unter 2 läuft es jetzt aber der letzte will nicht.
Wenn ich ihn als root starte läuft er sofort.
Habe auch alle recht schon überprüft :hilfe2::hilfe2:

Aber irgendwie habe ich das gefühl das ist eine sehr unsaubere Lösung ?(
Habe die andere monoversion über Webmin schon deinstalliert

Vielleicht weiß noch jemand rat ???:think::think::think:

DANKE