PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Nach Kernelupdate Sound leise



Mitzekotze
12.07.2007, 13:20
Servus zusammen,

nach dem Update des Kernels auf Version 2.6.21 ist bei mir auf einmal der Ton sehr leise. Um ein wenig zu hören muss ich den Lautstärkenregler ganz aufdrehen. Im Alsamixer hab ich den Ton auch schon bis zum Anschlag aufgedreht, aber es hat sich nichts verbessert.

Weiß einer von euch eine Lösung für das Problem?
Woher nimmt das Programm "alsamixer" eigentlich seine Daten bzw. kann man diese Auch manuell verändern?

Zico
12.07.2007, 13:44
Was hast du denn aufgedreht? Nur Master? Meist kann auch PCM zimelich leise sein, wo dann auch Master nix mehr reisst.

MrBoe
12.07.2007, 13:51
Mich würde auch mal interessieren, ob man die alsamixer Daten irgendwo fest einstellen kann. Bei meiner Soundkarte stellt sich immer der optische Ausgang ab wenn kdm gestartet wird. Das nervt.
Gestern hab ichs ausprobiert, kann gar nicht nachvollziehen warum das so ist:
Mit dem alsamixer optisch eingeschaltet.
Dann hab ich den XServer neu gestartet und die Einstellung war wieder weg.

Wieso passiert das?

Zico
12.07.2007, 14:08
alsactl store

müsste das eigentlich tun.

MrBoe
12.07.2007, 14:09
Cool, danke! Das probier ich nachher mal aus.

Mitzekotze
12.07.2007, 14:39
PCM ist voll aufgedreht. Aber was meinst du mit Master? Im Alsamixer kann man bloß Master aktiviert, die Lautstärke kann man dort aber nicht regeln. Mein Sound System scheint jetzt aber auch völlig Amok zu laufen, den mittlerweile hab ich gar kein Sound. Kann es sein das nach dem Kernelupdate plötzlich irgendwelche Sound Module fehlen, bzw. nicht mehr richtig zugeordnet werden können?

MrBoe
12.07.2007, 14:49
Natürlich kann das sein! Vielleicht hat sich aber auch was an alsa geändert, das ist ja auch im Kernel. Was hast du denn für eine Karte?

Vielleicht musst du auch nur noch einmal "alsaconf" aufrufen....

Zico
12.07.2007, 14:50
Wenn du die alte KErnel config richtig geclont hast sollte das eigentlich kein Problem sein.
Ich mach das immer per

cd /usr/src/linux
zcat /proc/config.gz > .config
make oldconfig

Mitzekotze
12.07.2007, 22:00
Ich hab die alte Kernel Config nicht kopiert *schäm* und im /usr/src finde ich auch nur den Ordner des aktuellen Kernels.
Durch den Aufruf von "alsaconfig" hat sich auch nicht mehr viel geändert, aber es war immerhin ein Versuch wert.
Mittlerweile funktioniert mein Sound übrigens wieder, wenn auch so leise wie zuvor.
Ist es vielleicht möglich die Lautstärke irgendwo manuell zu ändern, also nicht über ein Programm wie Alsamixer?

btw ich habe eine Intel Corporation 82801G (ICH7 Family) High Definition Audio Soundkarte.

Mitzekotze
13.07.2007, 17:52
Mhhh ich sollte vielleicht noch erwähnen das ich das Update per pacman gemacht habe.

Mitzekotze
14.07.2007, 14:54
Ich habe jetzt das System nochmal komplett neu aufgesetzt mit dem selben Ergebnis. Anscheinend hab ich einen Bug gefunden oder lässt sich das ganze noch anders erklären?

defcon
14.07.2007, 15:30
Tu doch mal just4fun den Kernel 2.6.22 aus testing installieren.
BTW.. welche WM nutzt du? Was für ne Soundcard?

Mitzekotze
16.07.2007, 13:40
Habs mal ausprobiert das Ergebnis war leider das selbe. Anscheinend hängt der Fehler mit dem letzten Alsapatch zusammen. Nun ja da hilft wohl nichts weiter als abwarten und Tee trinken. Ich werde aber vorsichtshalber nochmal andere Distris mit dem aktuellen Kernel testen, um ganz sicher zu sein.

Mein WM war Fluxbox und ich hab eine "Intel Corporation 82801G (ICH7 Family) High Definition Audio" Soundkarte. Eigentlich wundert es mich dass der Sound mit dieser Karte nicht geht. Immerhin ist sie ja von Intel und diese werden bekanntermaßen ja immer gut unterstützt.

Mitzekotze
22.07.2007, 17:43
Das Problem hat sich erledigt. Der Fehler lag am Einbinden eines falschen Moduls. Genaueres findet man hier: *klick* (http://www.unixboard.de/vb3/showthread.php?t=32011)