PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : Kernel



Diabolo
08.05.2003, 21:56
Hi,

heute wollte ich mein SuSE Linux 8.1 mit Kernel 2.4.19-4GB auf den Kernel 2.4.20-62 umstellen.
Dazu habe ich mir vom SuSE ftp die rpm gesaugt (k_athlon-2.4.20-62.i586.rpm).
Soweit so gut , dann habe ich versucht mit Yast das Ganze zu installieren.
Dann kam leider die Meldung: k_athlon benötigt /sbin/mk_initrd
Was kann ich dagegen tun, ich habe schon überall nach diesem Paket gesucht, aber bin wieder einmal nicht (wie so oft) fündig geworden.
Oder habe ich die falsche rpm? Ich habe einen AMD Athlon XP 1800+ auf einem MSI K7T266 Pro2-A.

LG
Diabolo

MTS
09.05.2003, 16:58
naja ...
also der neue kernel verwendet eine initial ramdisk,
also gib einfach hier auf der hauptseite bei tuxfinder oder so
mkinit ein, klicke rpm an, und dann haste da schon genug packete.
schau aber vorher ob du nicht das von suse findest.
das is eigtlich standard und sollte auf deiner cd sein.
mkinitrd-xxxxxxx.i386.rpm sollte das eignetlich heißen


(( xxxxx = Versionsnummer))

Diabolo
10.05.2003, 10:54
Danke erstmal, aber wenn ich bei tuxfinder mkinitrd herunterlade, dann mekert YAST, daß er andere Pakete auch brauch.

Woher weiß ich, welche Version von mkinitrd die richtige ist?


LG Diabolo

MTS
10.05.2003, 12:42
also:

Als erstes .. wenn du ne CD da hast (oder yast so konfiguriert hast, dass er nen ftpserver verwendet), dann starte yast, und suche da erstmal nach dem packet, DAS MUSS DA SEIN, eigentlich *G*--- und der sorgt auch dafür dass die abhängigkeiten passen

Prinzipiell kannst du auch rpm erstmal in der commandline benutzen, und zwar die query (???) options; lies dazu am besten die manpages, das müsste sowas wie
rpm --whatrequires packetname.rpm sein. da hab ich aber keine ahnung. dann bekommst du ne auflistung der abhängigkeiten.

eigentlich sollte aber das ganze schon installiert sein (dachte ich zumindest immer, dass das bei suse so wäre), also log dich mal als root ein und schau ob es mkinitrd gibt, nicht unbedingt mk_initrd ...