PDA

Archiv verlassen und diese Seite im Standarddesign anzeigen : alias im LDAP



seadog
13.04.2007, 13:41
Hallo *x-Freunde

ich habe den OpenLdap-Server (2.3.30) installiert und mit einigen Objekten per phpldapadmin gefüllt. Nun möchte ich gerne aliase (Objectclass alias) anlegen. Beim Anlegen wird die Fehlermeldung "Internal (implementation specific) error" ausgegeben.

Nach langer Suche im Internet, bin ich auf eine interessante Mail gestossen. In der wird behauptet, das aliase mit den bdb-backend nicht möglich sind, sondern nur mit dem ldbm-backend. Leider gibt es unter Debian ETCH kein ldbm-backend mehr.

Hier meine Frage an euch:
Kann einer von euch diese Aussage bestätigen oder wiederlegen? Benutzt einer von euch das bdb-backend und hat keine Probleme mit dem alias?

MfG
seadog

peser
09.05.2007, 15:02
Hallo seadog,

vielleicht hast du's ja schon gelöst, aber ich hatte ein ähnliches Problem mit aliases und musste eine zusätzliche Schema-Datei einbinden:

objectClass ( 1.3.6.1.4.1.42.2.27.1.2.1 NAME 'aliasObject'
DESC 'objectclass for all alias objects'
SUP 'ALIAS'
MUST cn )

Ist aus dem Internet Draft:
Use of Aliases within LDAP <draft-byrne-ldap-alias-00.txt>

seadog
14.05.2007, 08:05
Hallo peser,

nein ich hab es noch nicht gelöst, da ich erstmal an einer andere Projekt arbeite. Wenn ich eine Lösung gefunden habe, poste ich sie meist auch.

Danke für den Tip, ich werde ihn sofort ausprobieren, wenn ich ein wenig Luft habe.

MfG
seadog

PS: Benutzt du auch das BDB-backend?

peser
16.05.2007, 09:29
Hallo seadog,

ja, ich benutze bdb
ich hab nochmal ein alias angelegt (funzt auch noch)
JXplorer mach dann einen kleinen grünen Pfeil an den Eintrag und zeigt die Daten des anderen Baumteils an.

Gruss, peser

seadog
16.05.2007, 10:21
Hallo peser,

das hört sich gut an. Ich werde wahrscheinlich erst nächste Woche dazu kommen es zu testen.
Wenn das klappt kann ich im Bereich LDAP endlich richtig loslegen.

MfG
seadog